Das Erste: Livestream not working (1 Viewer)

SilentBob

Portal Pro
January 1, 2011
54
56
Germany Germany
Country flag
Hi,

for me the livestream of "Das Erste" is not working I always get an Information that playing the stream is not possible
I am using MP1, ZDF Mediathek is working fine
in Logs I get this message



Code:
[08-03 23:20:59,250] [MPMain      ] [INFO ] DoPageLoad with CurrentState 'videos', PreviousWindowId '4758'
[08-03 23:23:51,559] [OnlineVideos] [INFO ] Looking for dynamic categories for site 'Das Erste'
[08-03 23:23:51,763] [OnlineVideos] [INFO ] Found 13 dynamic categories for site 'Das Erste'
[08-03 23:23:59,530] [MPMain      ] [INFO ] Preparing graph for playback of 'http://daserstelive-lh.akamaihd.net/i/daserste_de@38086/master.m3u8'
[08-03 23:23:59,868] [OnlineVideos] [INFO ] Start prebuffering ...
[08-03 23:23:59,869] [OnlineVideos] [INFO ] BufferFile : using 'MediaPortal IPTV filter and url source splitter' as source filter
[08-03 23:23:59,870] [OnlineVideos] [INFO ] BufferFile : loading url: 'http://daserstelive-lh.akamaihd.net####Url=http%3a%2f%2fdaserstelive-lh.akamaihd.net%2fi%2fdaserste_de%4038086%2fmaster.m3u8&'
[08-03 23:24:00,359] [OnlineVideos] [INFO ] Buffering was aborted.
[08-03 23:24:00,517] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException
   at OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile(SiteUtilBase siteUtil)
   at OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass128_0.<Play_Step4>b__0()
   at OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass19_0.<ExecuteInBackgroundAndCallback>b__0()
when i open the mentioned uri in browser (http://daserstelive-lh.akamaihd.net/i/daserste_de@38086/master.m3u8) it works fine
 

ms.fox

Portal Member
October 15, 2017
9
2
Germany Germany
I have the same problem. The info of logs are equals.
If you look the line
http://daserstelive-lh.akamaihd.net...akamaihd.net/i/daserste_de@38086/master.m3u8&
That's a m3u8-File. It's a playliste only - or?
(MediaPortal IPTV filter and url source splitter)
I have download this file and opend it - an url to an other m3u8-file is inside.
Download this and open: In the m3u8 is the URL http://daserstelive-lh.akamaihd.net/i/daserste_de@38086/segment150809417_184_av-p.ts?sd=10&rebase=on
"segment"?
I think, the livestream is working with much segements and "onlinevideos" doesn't understand this.
 

SilentBob

Portal Pro
January 1, 2011
54
56
Germany Germany
Country flag
finally it seems that this plugin is no longer supported

so i added a fix into "DasErste" and "WDR" Site, please test with attached binaries, than i can create a pull request.
I took latest git sources and rebuild all, therefore i created a zip with only patched dlls and an mpe1 installer, where i increased version number to 2.3.1.1

please test them, for me "DasErste", "ZDF" and "WDR" are working again
 

Attachments

catavolt

Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    12,779
    9,202
    Lanzarote
    Germany Germany
    Country flag
    Sorry to say that after installing 2.3.1.1 none of the "Das Erste" is working - neither live streams nor streams from mediathek :oops:
    Error "Fehler beim Abrufen der Abspieladresse" :confused:
     

    SilentBob

    Portal Pro
    January 1, 2011
    54
    56
    Germany Germany
    Country flag
    Can you please send me/attach the online Video logfile
     
    Last edited:

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,630
    1,229
    Germany Germany
    Country flag
    Tried with MP 1.20 pre and all live streams tested so far are working(y)(y)(y)(y). Unfortunately all of the catchup content fails with "Error getting playback URLs for Video"
    Many thanks for your excellent work so far, it is great to have these streams working again after so long.:)
     

    SilentBob

    Portal Pro
    January 1, 2011
    54
    56
    Germany Germany
    Country flag
    Tried with MP 1.20 pre and all live streams tested so far are working(y)(y)(y)(y). Unfortunately all of the catchup content fails with "Error getting playback URLs for Video"
    Many thanks for your excellent work so far, it is great to have these streams working again after so long.:)
    Please send me the clicks you did to the not working content, I will check this as well later the day.

    My primary focus was the live stream.... Soccer world Cup was the motivation
     
    Last edited:

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,630
    1,229
    Germany Germany
    Country flag
    Please send me the clicks you did to the not working content, I will check this as well later the day.
    Hi
    Selected each highlighted item shown in the attached screen shots starting at DE1.
    Using the same procedure on my unmodified HTPC (MP 1.19) the same vid plays OK as do several other I tested, but of course the live streams don't.

    UPDATE:-
    Just wanted to clarify that when I said all catchup content failed, I actually meant all catchup content in the Das Erste category. ZDF Mediatek seems to be working 100% all live (even Arte) and catchup as are WDR. Deutsche Welle live stream in Das Erste is good and catchup from its own category, also both Arte (Deutsch and French) steams work.(y)

    DE1.jpg DE2.jpg DE3.jpg DE4.jpg
     
    Last edited:

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,498
    1,702
    Nuenen
    Netherlands Netherlands
    Country flag
    FYI, it's not necessary to put the whole onlinevideos folder (nor the mpe1) here just to fix some site.
    That is, assuming you only changed things in the DasErsteMediathekUtil.cs or other files in the OnlineVideos.Sites.offbyone folder.
    You only need the OnlineVideos.Sites.offbyone.dll.
    If you can commit the changes I'm more than happy publishing that dll so that it will be automatically picked up in the onlinevideos plugin
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom