Das Erste: Livestream not working

Discussion in 'OnlineVideos' started by SilentBob, August 3, 2017.

  1. SilentBob

    SilentBob Portal Pro

    Joined:
    January 1, 2011
    Messages:
    54
    Likes Received:
    38
    Ratings:
    +50 / 0
    Home Country:
    Germany Germany
    Hi,

    for me the livestream of "Das Erste" is not working I always get an Information that playing the stream is not possible
    I am using MP1, ZDF Mediathek is working fine
    in Logs I get this message





    Code (Text):
    1. [08-03 23:20:59,250] [MPMain      ] [INFO ] DoPageLoad with CurrentState 'videos', PreviousWindowId '4758'
    2. [08-03 23:23:51,559] [OnlineVideos] [INFO ] Looking for dynamic categories for site 'Das Erste'
    3. [08-03 23:23:51,763] [OnlineVideos] [INFO ] Found 13 dynamic categories for site 'Das Erste'
    4. [08-03 23:23:59,530] [MPMain      ] [INFO ] Preparing graph for playback of 'http://daserstelive-lh.akamaihd.net/i/daserste_de@38086/master.m3u8'
    5. [08-03 23:23:59,868] [OnlineVideos] [INFO ] Start prebuffering ...
    6. [08-03 23:23:59,869] [OnlineVideos] [INFO ] BufferFile : using 'MediaPortal IPTV filter and url source splitter' as source filter
    7. [08-03 23:23:59,870] [OnlineVideos] [INFO ] BufferFile : loading url: 'http://daserstelive-lh.akamaihd.net####Url=http%3a%2f%2fdaserstelive-lh.akamaihd.net%2fi%2fdaserste_de%4038086%2fmaster.m3u8&'
    8. [08-03 23:24:00,359] [OnlineVideos] [INFO ] Buffering was aborted.
    9. [08-03 23:24:00,517] [OnlineVideos] [WARN ] OnlineVideos.OnlineVideosException
    10.    at OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile(SiteUtilBase siteUtil)
    11.    at OnlineVideos.MediaPortal1.GUIOnlineVideos.<>c__DisplayClass128_0.<Play_Step4>b__0()
    12.    at OnlineVideos.MediaPortal1.Gui2UtilConnector.<>c__DisplayClass19_0.<ExecuteInBackgroundAndCallback>b__0()
    when i open the mentioned uri in browser (http://daserstelive-lh.akamaihd.net/i/daserste_de@38086/master.m3u8) it works fine
     
    • Agree Agree x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. ms.fox

    ms.fox Portal Member

    Joined:
    October 15, 2017
    Messages:
    9
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    Germany Germany
    I have the same problem. The info of logs are equals.
    If you look the line
    http://daserstelive-lh.akamaihd.net...akamaihd.net/i/daserste_de@38086/master.m3u8&
    That's a m3u8-File. It's a playliste only - or?
    (MediaPortal IPTV filter and url source splitter)
    I have download this file and opend it - an url to an other m3u8-file is inside.
    Download this and open: In the m3u8 is the URL http://daserstelive-lh.akamaihd.net/i/daserste_de@38086/segment150809417_184_av-p.ts?sd=10&rebase=on
    "segment"?
    I think, the livestream is working with much segements and "onlinevideos" doesn't understand this.
     
  4. SilentBob

    SilentBob Portal Pro

    Joined:
    January 1, 2011
    Messages:
    54
    Likes Received:
    38
    Ratings:
    +50 / 0
    Home Country:
    Germany Germany
    finally it seems that this plugin is no longer supported

    so i added a fix into "DasErste" and "WDR" Site, please test with attached binaries, than i can create a pull request.
    I took latest git sources and rebuild all, therefore i created a zip with only patched dlls and an mpe1 installer, where i increased version number to 2.3.1.1

    please test them, for me "DasErste", "ZDF" and "WDR" are working again
     

    Attached Files:

    • Like Like x 2
  5. catavolt
    • Team MediaPortal
    • Administrator

    catavolt Design Group Manager

    Joined:
    August 13, 2007
    Messages:
    12,109
    Likes Received:
    4,863
    Gender:
    Male
    Occupation:
    Technical Documentation, Translation
    Location:
    Lanzarote
    Ratings:
    +7,216 / 38
    Home Country:
    Germany Germany
    Show System Specs
    Sorry to say that after installing 2.3.1.1 none of the "Das Erste" is working - neither live streams nor streams from mediathek :oops:
    Error "Fehler beim Abrufen der Abspieladresse" :confused:
     
  6. SilentBob

    SilentBob Portal Pro

    Joined:
    January 1, 2011
    Messages:
    54
    Likes Received:
    38
    Ratings:
    +50 / 0
    Home Country:
    Germany Germany
    Can you please send me/attach the online Video logfile
     
    Last edited: June 20, 2018
  7. catavolt
    • Team MediaPortal
    • Administrator

    catavolt Design Group Manager

    Joined:
    August 13, 2007
    Messages:
    12,109
    Likes Received:
    4,863
    Gender:
    Male
    Occupation:
    Technical Documentation, Translation
    Location:
    Lanzarote
    Ratings:
    +7,216 / 38
    Home Country:
    Germany Germany
    Show System Specs
    Here we go ;)
     

    Attached Files:

  8. joecrow
    • Team MediaPortal

    joecrow Test Group

    Joined:
    August 9, 2012
    Messages:
    1,403
    Likes Received:
    678
    Ratings:
    +1,143 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Tried with MP 1.20 pre and all live streams tested so far are working(y)(y)(y)(y). Unfortunately all of the catchup content fails with "Error getting playback URLs for Video"
    Many thanks for your excellent work so far, it is great to have these streams working again after so long.:)
     
    • Thank You! Thank You! x 1
  9. SilentBob

    SilentBob Portal Pro

    Joined:
    January 1, 2011
    Messages:
    54
    Likes Received:
    38
    Ratings:
    +50 / 0
    Home Country:
    Germany Germany
    Please send me the clicks you did to the not working content, I will check this as well later the day.

    My primary focus was the live stream.... Soccer world Cup was the motivation [emoji3]
     
    Last edited: June 20, 2018
    • Like Like x 1
  10. joecrow
    • Team MediaPortal

    joecrow Test Group

    Joined:
    August 9, 2012
    Messages:
    1,403
    Likes Received:
    678
    Ratings:
    +1,143 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Hi
    Selected each highlighted item shown in the attached screen shots starting at DE1.
    Using the same procedure on my unmodified HTPC (MP 1.19) the same vid plays OK as do several other I tested, but of course the live streams don't.

    UPDATE:-
    Just wanted to clarify that when I said all catchup content failed, I actually meant all catchup content in the Das Erste category. ZDF Mediatek seems to be working 100% all live (even Arte) and catchup as are WDR. Deutsche Welle live stream in Das Erste is good and catchup from its own category, also both Arte (Deutsch and French) steams work.(y)

    DE1.jpg DE2.jpg DE3.jpg DE4.jpg
     
    Last edited: June 20, 2018
  11. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,742
    Likes Received:
    702
    Location:
    Nuenen
    Ratings:
    +1,048 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    FYI, it's not necessary to put the whole onlinevideos folder (nor the mpe1) here just to fix some site.
    That is, assuming you only changed things in the DasErsteMediathekUtil.cs or other files in the OnlineVideos.Sites.offbyone folder.
    You only need the OnlineVideos.Sites.offbyone.dll.
    If you can commit the changes I'm more than happy publishing that dll so that it will be automatically picked up in the onlinevideos plugin
     
Loading...

Users Viewing Thread (Users: 0, Guests: 1)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!