[TV] DVB-C not all Channels work (1 Viewer)

Status
Not open for further replies.

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,760
    7,117
    Home Country
    Germany Germany
    Country flag
    AW: DVB-C not all Channels work

    I think the main issue is following: the channel scan does find channels for both QAM64 and QAM256 on the same frequency:
    Code:
    2010-02-07 10:19:20.642578 [(13)]: Scan: tuner locked:True signal:0 quality:0
    2010-02-07 10:19:25.673828 [(13)]: Found: DVBC:tv:ARD Das Erste Freq:410000 ONID:1 TSID:1101 SID:28106 PMT:0x64 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod64Qam
    2010-02-07 10:19:25.673828 [(13)]: Found: DVBC:tv:ARD Bayerisches FS Süd Freq:410000 ONID:1 TSID:1101 SID:28107 PMT:0xC8 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod64Qam
    2010-02-07 10:19:25.673828 [(13)]: Found: DVBC:tv:ARD hr-fernsehen Freq:410000 ONID:1 TSID:1101 SID:28108 PMT:0x12C FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod64Qam
    2010-02-07 10:19:25.673828 [(13)]: Found: DVBC:tv:ARD Bayerisches FS Nord Freq:410000 ONID:1 TSID:1101 SID:28110 PMT:0x1F4 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod64Qam
    2010-02-07 10:19:25.673828 [(13)]: Found: DVBC:tv:ARD WDR Köln Freq:410000 ONID:1 TSID:1101 SID:28111 PMT:0x258 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod64Qam
    2010-02-07 10:19:25.673828 [(13)]: Found: DVBC:tv:ARD BR-alpha* Freq:410000 ONID:1 TSID:1101 SID:28112 PMT:0x2BC FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod64Qam
    2010-02-07 10:19:25.673828 [(13)]: Found: DVBC:tv:ARD SWR Fernsehen BW Freq:410000 ONID:1 TSID:1101 SID:28113 PMT:0x320 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod64Qam
    2010-02-07 10:19:25.673828 [(13)]: Scan Got 7 from 7 channels
    2010-02-07 10:19:25.908203 [(13)]: dvbc: Tune:DVBC:tv:  Freq:410000 ONID:-1 TSID:-1 SID:-1 PMT:0xFFFFFFFF FTA:False LCN:10000 SymbolRate:6900 Modulation:Mod256Qam
    2010-02-07 10:19:25.908203 [(13)]: dvb:Submiting tunerequest Channel: subChannel:0 
    2010-02-07 10:19:25.908203 [(13)]: dvb:using existing subchannel:0
    2010-02-07 10:19:25.908203 [(13)]: dvb:Submit tunerequest size:1 new:0
    2010-02-07 10:19:25.908203 [(13)]: subch:0 OnBeforeTune
    2010-02-07 10:19:25.908203 [(13)]: subch:0 OnAfterTune
    2010-02-07 10:19:25.923828 [(13)]: dvb:  LockedInOnSignal ok
    2010-02-07 10:19:25.923828 [(13)]: subch:0 OnGraphStart
    2010-02-07 10:19:25.923828 [(13)]: subch:0 Graph already running - WaitForPMT
    2010-02-07 10:19:25.923828 [(13)]: subch:0 SetupPmtGrabber:pid FFFFFFFF sid:FFFFFFFF
    2010-02-07 10:19:25.923828 [(13)]: subch:0 SetupPmtGrabber:pid FFFFFFFF sid:FFFFFFFF
    2010-02-07 10:19:25.970703 [(13)]: Scan: tuner locked:True signal:0 quality:98
    2010-02-07 10:19:31.017578 [(13)]: Found: DVBC:tv:ARD Das Erste Freq:410000 ONID:1 TSID:1101 SID:28106 PMT:0x64 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod256Qam
    2010-02-07 10:19:31.017578 [(13)]: Found: DVBC:tv:ARD Bayerisches FS Süd Freq:410000 ONID:1 TSID:1101 SID:28107 PMT:0xC8 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod256Qam
    2010-02-07 10:19:31.017578 [(13)]: Found: DVBC:tv:ARD hr-fernsehen Freq:410000 ONID:1 TSID:1101 SID:28108 PMT:0x12C FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod256Qam
    2010-02-07 10:19:31.017578 [(13)]: Found: DVBC:tv:ARD Bayerisches FS Nord Freq:410000 ONID:1 TSID:1101 SID:28110 PMT:0x1F4 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod256Qam
    2010-02-07 10:19:31.017578 [(13)]: Found: DVBC:tv:ARD WDR Köln Freq:410000 ONID:1 TSID:1101 SID:28111 PMT:0x258 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod256Qam
    2010-02-07 10:19:31.017578 [(13)]: Found: DVBC:tv:ARD BR-alpha* Freq:410000 ONID:1 TSID:1101 SID:28112 PMT:0x2BC FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod256Qam
    2010-02-07 10:19:31.017578 [(13)]: Found: DVBC:tv:ARD SWR Fernsehen BW Freq:410000 ONID:1 TSID:1101 SID:28113 PMT:0x320 FTA:True LCN:10000 SymbolRate:6900 Modulation:Mod256Qam
    2010-02-07 10:19:31.017578 [(13)]: Scan Got 7 from 7 channels

    I suggest following steps:
    • clear your channel list
    • make a manual scan, single transponder: 410000, Sym 6900, QAM64
    • try to tune one of the channel (i.e. Das Erste) --> tune ok?
    • clear your channel list again
    • make a manual scan, single transponder: 410000, Sym 6900, QAM256
    • try to tune one of the channel (i.e. Das Erste) --> tune ok?

    If you know if either QAM64 or QAM256 is the right one, we can look further
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,760
    7,117
    Home Country
    Germany Germany
    Country flag
    AW: DVB-C not all Channels work

    I think I found the cause for your problem:

    There is a check if it's needed to performe a new tune request by checking the transponder info.

    This check only looks at the frequency, not the modulation or symbolrate.

    The result is following (your) issue:
    • Scan tunes 4100000, QAM64 -> tune ok
    • Scan tunes 4100000, QAM256 -> tune think its already on this TP
    • the scan still finds the same channels, but with QAM256. this information is stored -> you can't tune them

    Please try attached tvlibrary! clear your channels before testing....

    Btw, the reason why only few (or even only you ;) ) see this, is the usage of the common "Germany all" transponders list, which tries everytime with both QAM64+256...
     

    Attachments

    • TVLibrary.zip
      30.6 KB · Views: 169

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,760
    7,117
    Home Country
    Germany Germany
    Country flag
    AW: DVB-C not all Channels work

    put this channel list to your tuning info folder ("C:\ProgramData\Team MediaPortal\MediaPortal TV Server\TuningParameters\dvbc\"

    select this list inside setuptv, do a scan, post your logfiles using my modified tvlib

    edit:
    I attached also the tvlib.interfaces dll. there was the patch done, I verified it locally. result is ok now.

    can you confirm this? it will get into mantis+svn then
     

    Attachments

    • Germany.SteffelGreenTest.xml
      30.7 KB · Views: 170
    • TvLibrary.Interfaces.dll.zip
      30.7 KB · Views: 141

    SteffelGreen

    Portal Pro
    March 29, 2009
    158
    3
    found 11 channels...the free channels NOW work, eg Das Erste QAM64..
    Channel window: digital cable is empty, listed only in "all channels" and "channels"
     

    SteffelGreen

    Portal Pro
    March 29, 2009
    158
    3
    On RC1

    Export xml, delete all channels, import channels -> in "all channels" channel are double and the sortation is messed up.

    I can fix it, if i only import "TV channels", but sortation is gone.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,760
    7,117
    Home Country
    Germany Germany
    Country flag
    AW: DVB-C not all Channels work

    please start a new thread in the proper forum part (for RC1).

    I'll close this thread now, as the initial issue is fixed.
     
    Status
    Not open for further replies.

    Users who are viewing this thread

    Similar threads

    The TBS 6281 DVB T/T2 is a dual tuner without CAM capability it should work on both DVBT and DVBT2 as it seems it did in WMC according to the OP. I do not see why it should not work with MP, I am using its successor the TBS 6281-SE which works well with both MP1 and MP2 but I only have OTA DVBT2, no DVBT any more. Which version of MP...
    The TBS 6281 DVB T/T2 is a dual tuner without CAM capability it should work on both DVBT and DVBT2 as it seems it did in WMC...
    I am trying to set up the latest version of Mediaportal 2 using Windows 10 Home I have a TBS 6281 DVB T/T2 card with the latest...
    Replies
    3
    Views
    484
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this year, in march 2020) the Telenet provider will stop broadcasting Analog TV and Radio signals on their cable, and make the switch to Digital (DVB-C). The radio signals will disappear completely, so you'll...
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this...
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this...
    Replies
    0
    Views
    819
    Maybe uncheck DVB-S2 Tuning/scanning?
    Maybe uncheck DVB-S2 Tuning/scanning?
    Hi everyone, I'm attempting to set up MP2 with a Sundtek SkyTV Ultimate 5 DVB-S/S2 USB tuner. When doing a full channel scan on...
    Replies
    1
    Views
    812
    Yes I think it's best to test with TVE3.5 the different combinations. The MTD and MCD modes are handled differently, so we have an option more to evaluate
    Yes I think it's best to test with TVE3.5 the different combinations. The MTD and MCD modes are handled differently, so we have an...
    Hi, i wrote this problem already in the german section, but the problem could not be solved until now. @morpheus_xx tryed it with...
    Replies
    21
    Views
    2K
    I wasn't able to find the source of the problem but I was able to fix it. In the "Channels" settings of the MP Server Configuration, I deleted the DVB-C and DVB-T source in the "Edit Channel" dialog and after that, I deleted the channel itself. Then I scanned the DVB-C and DVB-T card to find the deleted channels again and matched it...
    I wasn't able to find the source of the problem but I was able to fix it. In the "Channels" settings of the MP Server...
    I have been using MediaPortal with a DVB-C card for years without any problems. Some weeks ago, I bought a new DVB-T2 USB stick and...
    Replies
    1
    Views
    540
    Top Bottom