DVB subtiles crash BBC HD (2 Viewers)

mortstar

MP Donator
  • Premium Supporter
  • January 30, 2008
    415
    41
    England England
    Hi, I'll try to get up a sample and logs up soon also, as I have (allthough very very very rare now) the same problems with BBC HD DVB subtitle.
    It makes MP crash within a second of watching BBC HD with subtitles. I reported this some time ago elsewhere on the forum and Tourettes solved the problem. But it seems not to be entirely stable.
    As I've been posting in this thread....just a quick update to say that I do still get this error intermittently, usually after MediaPortal has been active over more than 24 hours. A quick fix seems to be a restart of the TVServer.
     

    Pletskop

    MP Donator
  • Premium Supporter
  • January 7, 2009
    92
    12
    Belgium Belgium
    DVBSub Crash

    Hi Tourettes,

    I've been investigating my problem with crashing DVBSubs some more and have come to the conclusion that it is probably not just related to BBCHD subs...
    Yesterday, the subs showed fine when I fired up my MP. I then went over to watch a video [x264 mkv] and when I returned to MyTV, MP just crashed.
    In the event viewer I find the following error for the Application Log:
    "Faulting application MediaPortal.exe, version 1.0.0.21306, time stamp 0x49651b6f, faulting module DVBSub2.ax, version 0.0.0.0, time stamp 0x49650d72, exception code 0xc0000005, fault offset 0x00003cf4, process id 0x55c, application start time 0x01c992cbe4d3f410."

    All my previous crashes also generated the same eventID. When I don't enable DVBSubs, I never have this problem. Seems to be coming from the DVBSub2.ax module.

    I posted my MP log for reference.

    Is this something which could be handled within this thread or do I need to start a separate bug report?

    Regards,

    Peter
     

    Pletskop

    MP Donator
  • Premium Supporter
  • January 7, 2009
    92
    12
    Belgium Belgium
    HD Subtitles keep crashing

    TV-Server Version: 1.0.0.0 Final (svn21306)
    MediaPortal Version: 1.0.0.0 Final (svn21306)
    MediaPortal Skin: Blue3 wide
    Windows Version: Vista Ultimate SP1
    CPU Type: Intel Core2 Duo E4400
    HDD: Samsung SpinPoint 40GB/750GB
    Memory: 1GB DDR2
    Motherboard: Asrock 775i945GZ
    Video Card: Asus 8500GT 512Mb
    Video Card Driver: NVidea 8500GT 181.22
    Sound Card: Internal
    Sound Card AC3: N/A
    Sound Card Driver: N/A
    1. TV Card: TechnoTrend S2-3200
    1. TV Card Type: DVB-S2
    1. TV Card Driver: 5.0.0.19
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: ffdshow rev 2447
    MPEG2 Audio Codec: ffdshow rev 2447
    h.264 Video Codec: PDVD8
    Satelite/CableTV Provider: Astra 2
    HTPC Case: Antec Fusion
    Cooling: N/A
    Power Supply: N/A
    Remote: Windows MCE Remote
    TV: Sony
    TV - HTPC Connection: Sub-D

    Hi Tourettes,

    Yesterday, I reinstalled my Vista+MP from scratch as part of a HDD replacement. I also applied the 21306 svn as this one was reported to solve the HD subtitles crashes.
    Unfortunately, my MP keeps crashing when I activate DVB Subs on an HD channel. On SD channels it works fine.

    Any ideas on how to proceed?
    Submitting an HD ts-file will probably not add much more info as the issue is probably located in the MP code and not in the ts-stream.

    Peter
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Any ideas on how to proceed?
    Submitting an HD ts-file will probably not add much more info as the issue is probably located in the MP code and not in the ts-stream.
    Only way I can reproduce the issue is to submit a TS file that can be used to reproduce the crash. Othwise the issue will stay open.
     

    The Doctor

    MP Donator
  • Premium Supporter
  • December 24, 2007
    180
    14
    Netherlands Netherlands
    Country flag
    Running the latest public SVN did solved the dvbs-subtitle crash with BBC-HD. (SVN 21864)

    With SVN 21813 sometimes MP crashed with BBC-HD. And even after a complete powerdown and restart the problem stayed. I almost think that BBC-HD sometimes changes their broadcast codec. Because watching BBC HD can work ok and crash MP a minute later.

    Between the two SVN's I did not change anything. All codecs stayed the same.
     

    mortstar

    MP Donator
  • Premium Supporter
  • January 30, 2008
    415
    41
    England England
    Any ideas on how to proceed?
    Submitting an HD ts-file will probably not add much more info as the issue is probably located in the MP code and not in the ts-stream.
    Only way I can reproduce the issue is to submit a TS file that can be used to reproduce the crash. Othwise the issue will stay open.
    I've had to turn DVB-subtitles off because of this problem.

    If DVB subtitles are on this is my experience:
    • All channels can be tuned to and viewed for extended periods of time.
    • Switching to and from BBC HD does not cause crash initially
    • DVB subtitles are viewable on all channels (inc. BBC HD)
    • Within 24 hours from turning the option on (but not a definitive amount of time), tuning to BBC HD will cause MediaPortal to crash within seconds.

    If you can explain how and where to supply a recent BBC HD .ts sample, then I can provide one. I will also provide full logs and screenshots when recreating this issue.

    EDIT: Just doing a bit of testing now - rather than there being a timelimit on the change from not-crashing to crashing ...it seems to me that dvb subtitles work the first time MediaPortal is opened after the option is enabled. Once MP is closed and then opened for the 2nd time, this is when the crash occurs. This is the experience I just had. The logs below show:
    • MediaPortal Start
    • Navigate to TV Guide
    • Tune to BBC 1 (SD channel)
    • Enable DVB subtitles
    • Tune to BBC HD

    After a crash a 'sc stop tvservice' followed by 'sc start tvservice' starts the cycle again

    EDIT 2: Typical of this problem. I'm just trying to recreate the problem again, but this time I had to close and open MediaPortal about 4 times before the crash occurred again....but invariable the crash does occur.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    If it is related to the 2nd start up of MP, then it sounds like server side issue (that shoulnd't have any affect on the subtitles). So, I hihgly doubt that the MediaPortal start count has anything to do with the issue.

    To provide TS data for testing do following:

    1) start MP
    2) turn tv on
    3) reproduce the error
    4) copy timeshifting files(s) to some safe place
    5) test all those timeshifting files inside my videos
    6) After you have found the one that can be used to reproduce the issue upload the .ts file to FTP:

    Address: ftp.team-mediaportal.com
    Login: tsdump@team-mediaportal.com
    Password: mpuser88

    ...and remember to name the file in such whay that it can be tracked back to this thread :)
     

    Pletskop

    MP Donator
  • Premium Supporter
  • January 7, 2009
    92
    12
    Belgium Belgium
    Hi Tourettes,

    Based on the recommendations in this thread, I have now upgraded both my MP and TVS to svn21864.
    Unfortunately, I'm still getting intermittent crashes when activating subtitles on BBC HD.

    However, I think I may have found a possible cause.
    MP only seems to crash when there is a subtitle to be shown immediately after tuning to BBC HD [or starting a recorded program].
    If you tune in to BBC HD and they are not immediately broadcasting subtitles [e.g. when there is only music and nothing being said], MP doesn't crash and the subtitles get shown correctly when they pop up in the stream.

    I have uploaded a rar-file to the ftp-server, called "BBCHD_TS_Related2DVB subtiles crash BBC HD.rar"
    It contains 2 ts-streams:
    1. "Test - SubHD@StartofStream.ts": This one has subs starting at the start of the stream and causes a crash on my MP.
    2. "Test - NoSubHD@StartofStream.ts": This one starts of with an SD-channel for about 6 seconds and then tunes into BBC HD without any issues. The first ten seconds are the BBC HD test page and then another program with subs start. This doesn't cause a crash on my MP.​

    For the stream that is crashing, I have provided my MP logs generated by MP Watchdog.
    In case of a crash, the eventlog is filled always with the same error:
    "Faulting application MediaPortal.exe, version 1.0.0.21864, time stamp 0x49b1c57e, faulting module DVBSub2.ax, version 0.0.0.0, time stamp 0x49a793e0, exception code 0xc0000005, fault offset 0x00003d14, process id 0x(null), application start time 0x考 ."​
    This can be found back in the logs, application eventlog.xls, line 1489.

    Hope this information can bring you somewhat closer to solving this annoying bug in MP.

    Regards,

    Peter
     

    Pletskop

    MP Donator
  • Premium Supporter
  • January 7, 2009
    92
    12
    Belgium Belgium
    Hi Tourettes,

    Just applied the patch and it seems to do the trick. Yipee!
    I'm guessing you're just delaying the start of showing subs until some seconds after tuning into the HD channel as I can notice a short delay which isn't the case when tuning into an SD channel.

    Quick question: is this is definitive fix and is this only applicable to BBC HD or to all HD channels?

    Thanks again. I'll keep monitoring the situation and let you know if I discover any further issues.

    Regards,

    Peter
    :D
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    OP Similar threads Forum Replies Date
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 7
    R Suggestions for reliable PCIe DVB-S2 tuner MediaPortal 1 Talk 8
    Golf4 DVB-IP über Fritzbox - m3u-Senderliste Allgemeines Support- und Diskussionsforum 43
    M TV Server can't tune to some DVB-S multiplexes while other software can General 0
    C Telenet analog-to-digital switch -- manually finding and inputting DVB-C channels in Mediaportal2 General 0
    framug No color in TVGuide when XMLTV without DVB EPG MediaPortal 1 Talk 59
    T [solved] Any idea where Channel 107 (DVB-T2) BBC News HD (and others!) have gone??? Installation, configuration support 12
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    badboyxx TV card is listed as unknown in TV-server config General 4
    bribbon [Pending] Switzerland: DVB-T switch-off on 03 June 2019 Submit: EPG-Grabbers and tuningdetails 0
    bribbon [Pending] DVB-C Tuning Parameters: Switzerland.UPC Cablecom [NID 43020] v.7.xml Submit: EPG-Grabbers and tuningdetails 0
    J DVB-S2 card fails to tune? Subchannel count increasing Television (MyTV frontend and TV-Server) 3
    D Cannot get a fully populated UK Freesat EPG (DVB-S) General 14
    hanfmaster Dvb-s2 zu android ipad Einsteigerforum 0
    C DVB-C Empfänger Hauppauge Win TV dual wird in Media Portal nicht aktiviert TV / Streaming 1
    Terra [solved] MP TV Server cannot find any channels anymore, DVB viewer works Installation, configuration support 8
    Booner [Verkauf] Verkaufe Max S8 8 Tuner DVB-S2 Karte von Digital Devices neuwertig Marktplatz 2
    N [solved] How to record a series (UK Freeview dvb-t) General 10
    N What dvb-t/t2 dual or quad tuners work with media portal (in the UK)? Newcomers Forum 8
    E [solved] Vodafone Kabel dvb-c Braunschweig Tuning Liste (Stand 31.01.2019) TV / Streaming 0
    items [Verkauf] Hauppauge Dual TV Tuner USB DVB-C, DVB-C Marktplatz 0
    A Help! MP2 - DVB-T Not recognised (DRIVERS?) General 12
    porky996t DVB Sat card possibly failed General Support 1
    splatterpop My optimized dvb epg configuration for tv server MediaPortal 1 Talk 0
    Similar threads

























    Top Bottom