Tools and other software EPG-Buddy a new EPG Tool with easy usage. (1 Viewer)

Lehmden

Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,085
    3,685
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Don't give up, tvguide again has changed something on their site. I got the same error here, so it's not your fault at all... As I'm living in Europe I can't use tvguide.com on a regular basis so I don't be aware of changes they do. So it may take some time but we are working to fix the new tvguide.com issue asap.

    WebGrab++ really is complicated and very slow but sometimes there is no alternative available. That's why it is implemented in EPG-Buddy.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,085
    3,685
    Lehmden
    Germany Germany
    Country flag
    Hi.
    A new version 0.5.0.7 is available to download. Download Link is as always and can be found twice in first posting.
    With this new release the tvguide.com issues should be gone. The download error and the time issue (0:00 to 2:00) are both fixed now. Aside this there are some security updates included so it's recommended to install the new version for everyone, not only tvguide.com users.
     

    TLD

    Portal Pro
    October 26, 2007
    640
    98
    Rainy Washington
    United States of America United States of America
    Country flag
    Had to restart the computer before it would install. then ran it manually, program hung at shutdown with windows error (program has stopped responding). It did fill the epg though. attached the logs, i don't see anything in there.
     

    Attachments

    sandiego1001

    New Member
    January 24, 2020
    3
    0
    59
    United States of America United States of America
    Country flag
    Version 0.5.0.7 / tvguide.com now works fine, no runtime problems or errors, no problems with loading channels and programs into MediaPortal - many thanks!! Don't know if it helps, but I attached the resulting tvguide xml file.

    I'm still at a loss as to why the WebGrab+ / tv.com implementation will NOT load programs into MediaPortal. For what it's worth, I've attached my files for informational purposes. I had to refer to the WebGrab site to understand that using tv.com requires a cookie file and how to generate it. Also to ensure that the following tv.com.ini lines are this way around:

    url_index{url|http://www.tv.com/listings/station/|channel|}
    *url_index{url|http://www.tv.com/listings/singlestation/?start=##TIMESTAMP##&station=|channel|}

    and NOT this way around:

    *url_index{url|http://www.tv.com/listings/station/|channel|}
    url_index{url|http://www.tv.com/listings/singlestation/?start=##TIMESTAMP##&station=|channel|}

    The latter pair of lines resulted in errors for me.

    I'm posting the WebGrab+ details here as I have zero understanding of where the problem lies - WebGrab+ or its EPG-Buddy implementation.
     

    Attachments

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,085
    3,685
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Had to restart the computer before it would install. then ran it manually, program hung at shutdown with windows error (program has stopped responding).
    Maybe the background processes were active (means the scheduled EPG grabbing runs in background) while you are updating the program. And if the EPG download did not finish successfully it will restart as soon as the system is up and running again. I don't think this will occur again while you are using the tool "normal"...


    I'm posting the WebGrab+ details here as I have zero understanding of where the problem lies - WebGrab+ or its EPG-Buddy implementation.
    The problem solely is on the WebGrab side. EPG-Buddy only writes the config file that is independent of any site.ini file always the same. And nothing has changed on the configuration for a long time.

    As there are hundreds of site.ini files I can't monitor all of them especially as WebGrab only is implemented as "fallback" if nothing else can deliver the needed data. In general you better use a different data source like tvguide.com (in your case) as it is faster a lot...

    I had a closer look at the tv.com site.ini file and it was not updated since 2016. According to the logs you deliver there is only one issue with a single channel, "KGTV HDTV (ABC)".
    ( 5/19 ) TV.COM -- chan. (xmltv_id=KGTV HDTV (ABC)) -- mode Smart
    [Error ] Unable to update channel KGTV HDTV (ABC)
    [Critical] Generic syntax exception:
    [Critical] message:
    [Error ] no index page data received from KGTV HDTV (ABC)
    [Error ] unable to update channel, try again later
    [ Info ] Existing guide data restored!
    Aside this, the delivered data really is poor. Very little information about the programs, no episodes data, no proper description, really poor. And if you have a look to the webgrab forums there are many issues with the tv.com website being down every now and then. Maybe it's no good choice to use tv.com at all...
    Are those channels you have configured in Webgrab are not available on tvguide.com? I don't know much about US TV but ABC seems to be a major channel (because I often heard about ABC even here in Germany) so I'm pretty sure it is available on tvguide.com too.

    Do you know you can have more than one account on tvguide.com and for this more than one lineup? Maybe you receive tv channels for more than one region. You only need to use a second email address for creating a second account at tvguide.com to setup a different lineup for a different region and this way you may find the missing channels. In EPG-Buddy you can add as much tvguide.com accounts as you like or need. You only need to be sure that email and password are in the same line of the input fields...
     

    sandiego1001

    New Member
    January 24, 2020
    3
    0
    59
    United States of America United States of America
    Country flag
    Thanks Lehmden, I've come to that same conclusion about tv.com - it would error out on some channels on one run, fill them in on a later run but then error out of others. Not what I'd call reliable ................ tvtv.us won't allow epg's so that's out. I was actually looking for a backup to TVguide.com (which is really good and has all I need) for any future instances of them changing their site's inner workings.

    Have a Jever or Beck's on me. Miss those beers ...........
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,085
    3,685
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Have a Jever or Beck's on me
    Thanks and "Prost" as we say in Germany.

    Also I live in northern Germany (Bremen = Becks is 40 miles away from my home, Jever around 60 miles) I prefer Bavarian (400 miles away) beer like this:
     

    jjspas

    New Member
    January 27, 2020
    1
    0
    United States of America United States of America
    Country flag
    I have just setup EPG-Buddy and am using tvguide.com as my source. I am using the xml file output and importing it into NextPVR. The issue that I am having is that in the NextPVR TVguide all of the shows are off by 5 hours. Looking at the xml file I see that their is a -0500 in the programme start and stop. If I manually change all of them to 0000 then the data in the NextPVR TVguide is correct. Is their some setting in EPG-Buddy or on the tvguide web site that I can set to fix this problem.

    </channel>
    <programme start="20200125130000 -0500" stop="20200125150000 -0500" channel="WDTN-DT-14416">
    <title>Today</title>
    <sub-title>01-25-2020</sub-title>
    <length units="minutes">120</length>
    <category>news</category>
    </programme>

    Thanks for the help

    Jim
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,085
    3,685
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Is their some setting in EPG-Buddy or on the tvguide web site that I can set to fix this problem.
    No there is none as the XMLTV specs are explicitly asking for a time correction compared to GMT (-0500 in your case +0100 in my case), if the program is aired in a different timezone than GMT. In MediaPortal, Argus and TVHeadend you can (de-)activate a time correction if you need but normally there is no need for such. I'm not completely familiar with NextPVR, so I can't answer if and where such a setting can be found...

    Just for testing I've setup NextPVR 4_2_5_191014 (should be the most recent "stable" version) and added my EPG-Buddy xml file as EPG source to it. Here all times are correct also I have time correction included in my XML file like you have:

    XML:
      <programme start="20200127200000 +0100" stop="20200127201500 +0100" channel="ARD">
        <title>Tagesschau</title>
        <sub-title>Mit Wetter</sub-title>
        <country>D</country>
        <length units="minutes">15</length>
        <category>Nachrichten</category>
      </programme>
    And here a screenshot of my EPG screen:
    1580150083287.png


    You can see that "Tagesschau" (aired between 20:00 to 20:15 means 8:00 to 8:15 PM in your time format) and is shown in EPG at 20:00 too... ("ARD" and "Das Erste" is the same channel, just fyi)

    If I remove the +0100 from the xml file this program wrongly is shown at 7:00 pm in EPG

    So there must be something wrong with your NPVR setup, but I don't have a clue what's wrong... The XML file is correct if it has those time corrections...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    F EPG Buddy download Plugins & Erweiterungen 1
    M Guide mapping schedules direct, tvguide, epg buddy How to get correct entry to the correct channel? Electronic Program Guide 0
    P EPG Schedule hours off TV-Server 0
    C EPG-Buddy: so close to no help needed Electronic Program Guide 8
    M EPG color by length of TV-show MediaPortal 1 Talk 1
    D Downloading EPG XML file: Installation, configuration support 0
    D EPG No Data General Support 2
    D [solved] EPG Data off by -20 hours? General 10
    G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
    F Mini EPG more information? WMC Skin 4
    N No TV or EPG on fresh install General 0
    framug No color in TVGuide when XMLTV without DVB EPG MediaPortal 1 Talk 59
    T Freesat EPG in UK anyone? Electronic Program Guide 78
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    G Movie release date in guide Electronic Program Guide 2
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    CyberSimian [fixed] MP1-4990 : Improve horizontal scrolling in the EPG MediaPortal 1 10
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    J Understanding what EPG shows about schedules General 8
    geotwticher TV Guide EPG Grabber for Australia 2020 RIP freepg.tv General 4
    B [solved] MP2.2.3 TV Guide not scrolling with mouse wheel General 2
    HTPCSourcer Special (foreign) characters don't display correctly in EPG MediaPortal 2 4
    B How to Search MP2 for Movies only in 7 day EPG that comes from the Antenna General 3
    Similar threads

























    Top Bottom