Tools and other software EPG-Buddy ATSC USA Testing (3 Viewers)

breese

Retired Team Member
  • Premium Supporter
  • July 11, 2011
    3,903
    770
    63
    Arlington Heights, Illinois
    Home Country
    United States of America United States of America
    Country flag
    You're right, I forgot to adjust the grabepg helper tool. It works with all sources excerpt for TVGuide... :oops:
    Simply replace the file with the attached one and the scheduler should work.
    The last version (3.2.9) does not include the fixed Grab.epg so the scheduler does not work.
    Good One in post #22
     

    breese

    Retired Team Member
  • Premium Supporter
  • July 11, 2011
    3,903
    770
    63
    Arlington Heights, Illinois
    Home Country
    United States of America United States of America
    Country flag
    I am one step closer to the First Start error.
    It is registered as an AutoIt Error
    AutoIt Error.jpg

    What is interesting is when you run EPG-Buddy the first time, it creates 2 log files
    EPG-Buddy.log
    EPG-Grabber.log

    If you look inside EPG-Grabber.log you can see it grabs the channels for TV SPIELFILM live
    After that it does this and dies

    [2017-03-22 05:35:29,232] [INFO ] [TVGUIDE ] [4 ] Login on TVGuide.com
    [2017-03-22 05:35:29,232] [INFO ] [TVGUIDE ] [4 ] email : ''
    [2017-03-22 05:35:29,233] [INFO ] [TVGUIDE ] [4 ] password: ''
    [2017-03-22 05:35:29,676] [INFO ] [TVGUIDE ] [4 ] result: {"status":"failed","message":"<ul class=\"user-form-messages\">\n\t\t\t\t\t<li class=\"user-form-messages-message user-form-messages-message-error\">The email field is required.<\/li>\n\t\t\t\t\t<li class=\"user-form-messages-message user-form-messages-message-error\">The password field is required.<\/li>\n\t\t\t\t\t\t\t<\/ul>\n"}
    [2017-03-22 05:35:29,677] [INFO ] [TVGUIDE ] [4 ] Login failed
    [2017-03-22 05:35:29,678] [INFO ] [SQLITE.DBCONNECT ] [20 ] Connect to database 'C:\Program Files (x86)\EPG-Buddy\EPG-Buddy.s3db'
    [2017-03-22 05:35:29,729] [INFO ] [GETCHANNELS ] [2 ] Add New channels
    [2017-03-22 05:35:29,730] [INFO ] [GETCHANNELLIST ] [3 ] Get channellist for grabbing.
     

    breese

    Retired Team Member
  • Premium Supporter
  • July 11, 2011
    3,903
    770
    63
    Arlington Heights, Illinois
    Home Country
    United States of America United States of America
    Country flag
    It seems that at some point after the initial download of TVGuide channels, EPG-Buddy drops at least one channel.

    On the initial grab of channels
    [2017-03-22 05:43:13,466] [INFO ] [GETCHANNELS ] [2 ] Add channel: WMEU You & Me
    [2017-03-22 05:43:13,467] [INFO ] [GETCHANNELS ] [2 ] Add channel: WMEU CBS HDTV

    [2017-03-22 05:43:13,467] [INFO ] [GETCHANNELS ] [2 ] Add channel: WMEU Decades

    When configuring the EPG info the WMEU CBS HDTV is missing. There could be others, I have not checked the entire list
    WMEU Decades and You & Me are correct, heroes & icons, I have no idea it came from

    3/22/2017 9:14:55 AM - Info - Write Available Channels done for WMEU Decades
    3/22/2017 9:14:58 AM - Info - Write Available Channels done for WMEU Heroes & Icons
    3/22/2017 9:15:00 AM - Info - Write Available Channels done for WMEU You & Me
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,347
    3,799
    Lehmden
    Home Country
    Germany Germany
    Country flag
    f you look inside EPG-Grabber.log you can see it grabs the channels for
    This is intended. As long as you don't have any configuration made the channel update is done for all sources. As soon as you have configured one or two (or so) sources the channel update runs on selected sources only. And this also is the reason that you need to restart EPG-Buddy after you've entered your tvguide.com credentials. Any other supported source can delver the channel list without being logged in. But at tvguide.com you need to be logged in to get the channel lists. So on first run the login fails, as there are no credentials available at this time. As result the channel list for tvguide is empty at first start...

    what tvguide ini file is this new version using to grab?
    It don't use any tvguide.ini as it grabs data directly from tvguide.com using the configured lineup to know which channels to download. The EPG- data is provided in JSON format at tvguide.com. Attached is such a JSON file from tvguide.com for channel "WBBM HDTV" as example. EPG-Buddy downloads all those JSON files (there are literally tenthousands of them) valid for all channels and all days you have configured. Once the download is finished the data is converted into a form, the TV server (exact the XMLTV plugin) can understand. A tvguide.ini is not involved in this process at all. This conversion process also is the reason for those out of memory errors as up to now the conversion is done in RAM.

    At the moment we try to prevent those out of memory errors that appears with big lineups. This is a general problem not limited to tvguide. But as "European" lineups are normally not that large this hasn't been appeared before... The issue is a bit tricky to solve and sadly will lead to much more disk space needed for EPG-Buddy to work and it also will decrease the speed. We try to limit those drawbacks as much as possible but it will take some more days to solve this.
     

    Attachments

    • 1490472000.zip
      47.3 KB · Views: 60

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,347
    3,799
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Hi.
    New version 0.3.2.10 to test. This one hopefully don't throw oom errors that easy.
    The issue with the not constant channel list sadly still is open...
     

    piscdi

    Portal Member
    March 17, 2017
    21
    9
    65
    Minot, Maine
    Home Country
    United States of America United States of America
    Hi,
    Just a quick note to say that your new version seems to be working as advertised. I loaded it Saturday and did four grabs with all channels populating (MY issue was missing channels, not the memory draw as others reported - but I only have 30 or so channels to begin with, all OTA). Sunday, EPG-Buddy grabbed all channels again as scheduled......SUPER!! This morning I checked before work and the scheduler had not activated so I did a manual grab and again, all channels were present. I will take a better look at what may have caused the scheduling failure, but for now, I am a happy camper. Thank you again for all your efforts.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,347
    3,799
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Hi.
    This morning I checked before work and the scheduler had not activated
    Was the pc awake at the time the EPG grabbing should run? The scheduler can not wake the system for EPG grabbing and the used windows command "schtasks.exe" that creates the schedule in taskplaner is not able to set the option "re-run this task as soon as possible after a run has failed". So if the system is not awake the automatic EPG grabbing is not executed for this day. Not much we could do against this. If you don't run your TV server 24/7 you best set the powerscheduler plugin to wake the pc for EPG grabbing at the same time or probably one minute earlier (or so) as EPG-Buddy should grab EPG data automatically.
     

    piscdi

    Portal Member
    March 17, 2017
    21
    9
    65
    Minot, Maine
    Home Country
    United States of America United States of America
    Hi Lehmden,
    Thanks for your reply. Server runs 24/7 so I don't think that was an issue. Just checked the log (it didn't run again this morning either) and the error message is :

    [2017-04-04 03:00:14,004] [INFO ] [TVGUIDE ] [4 ] result: {"status":"failed","message":"<ul class=\"user-form-messages\">\n\t\t\t\t\t\t\t\t\t\t\t\t\t\t<li class=\"user-form-messages-message user-form-messages-message-info\">Are you sure you have an account? If not, click <a href=\"http:\/\/www.tvguide.com\/user\/register\/\">here<\/a> to create one.<\/li>\n\t\t\t\t\t\t\t\t<\/ul>\n"}
    [2017-04-04 03:00:14,010] [INFO ] [TVGUIDE ] [4 ] Login failed​

    When I run a manual grab (and the one instance when it grabbed by timer on Sunday) the handshake is successful. Could it be timeout issue? The "t"s remind me of placeholders I used to use for connecting automated calls. But it did work on Sunday, so I don't have a clue. Thanks again.
     

    bc420

    MP Donator
  • Premium Supporter
  • March 15, 2012
    33
    1
    Bring Cash
    Home Country
    Canada Canada
    Country flag
    Successful grabs over here 4 days on both my providers, I haven't tried for more days yet. It properly mapped to channels for each provider with separate files EPG-Buddy.s3db . Very nice work!
     

    Users who are viewing this thread

    Similar threads

    Sorry to hear that you have to go to hospital. I hope that all wil be fine. In fact you have already all the information needed. The database name and the table name are the same than in mySQL for ArgusTV. How can I provide you the Backup file ?
    Sorry to hear that you have to go to hospital. I hope that all wil be fine. In fact you have already all the information needed...
    Hi. I like to introduce our latest tool, called "EPG-Buddy". This program should make EPG grabbing as easy as possible. Up to now a...
    Replies
    445
    Views
    115K
    MP1 MP2 MediaPortal2-Buddy DE
    That’s what Lehmden said. Watched flags get migrated when updating to 2.2. Also a new plugin is almost finished to backup watched flags and restore later.
    That’s what Lehmden said. Watched flags get migrated when updating to 2.2. Also a new plugin is almost finished to backup watched...
    Hi. And here is another "Buddy"... Today's Buddy is "MediaPortal2-Buddy" (or short, MP2-Buddy), a tool to do some work around...
    Replies
    4
    Views
    9K
    (y) Oh, for sure! Please don't get me wrong. I really appreciate you reporting it. (y) On this occasion I think the log entry being an error is a bit misleading (sorry). As long there's nothing else going on in connection with it I think we can safely leave it. The main reason I'm not going further and trying to eliminate or...
    (y) Oh, for sure! Please don't get me wrong. I really appreciate you reporting it. (y) On this occasion I think the log entry...
    Updated from MP1.12 to MP1.16 over the weekend. No major install problems, just usual grumpiness getting new install working. On...
    Replies
    17
    Views
    3K
    • Sticky
    OK, yeah for some reason it will not work anymore for me using the username and password method. I had to switch over to the zipcode/lineupid method, but now it is working again.
    OK, yeah for some reason it will not work anymore for me using the username and password method. I had to switch over to the...
    EDIT: I am working on a new setup of this and will post here when completed. The new setup will allow the addition of Series info...
    Replies
    40
    Views
    51K
    • Sticky
    Got it! This needs a bit more development from @SilentBob : the url that is given to the player (in this case https://zdfvodnone-vh.akamaihd.net/i/meta-files/zdf/smil/m3u8/300/17/02/170223_wilderplanet_stuerme_neu_tex/5/170223_wilderplanet_stuerme_neu_tex.smil/master.m3u8) needs to be parsed one level deeper, because this m3u8...
    Got it! This needs a bit more development from @SilentBob : the url that is given to the player (in this case...
    GitHub repository | Wiki | Skinning Guide | Available Sites | German Thread History I restarted development on the OnlineVideos...
    Replies
    697
    Views
    131K
    Top Bottom