ffdshow upscale + TV + DVD @ 1366x768 (1 Viewer)

Aeon

New Member
December 13, 2007
1
0
Home Country
Netherlands Netherlands
I also have a scaling problem.

When I burn a DVD to a disc, and use it in my DVD player, it plays on full screen, like it should. However when I play the dvd via my IDE dvd drive, or mount the image via daemon tools it looks like this;

**************************
**************************
screenscreenscreenscreenscreen
screenscreenscreenscreenscreen
screenscreenscreenscreenscreen
screenscreenscreenscreenscreen
**************************
**************************

while when i use my dvd player, it displays like this:

screenscreenscreenscreenscreen
screenscreenscreenscreenscreen
screenscreenscreenscreenscreen
screenscreenscreenscreenscreen
screenscreenscreenscreenscreen
screenscreenscreenscreenscreen
screenscreenscreenscreenscreen
screenscreenscreenscreenscreen

Sorry for idiot mode here, but I guess thats the most clear way of describing the problem.

Anyways, I am using the latest Media portal, latest ffdshow, tried different codecs, and did the post-processing thing (forcing resolution to my LCD screen; 1360*768something) and it doesn't work. (tried different screen modes on both Media portal, and on my TV)

What am I doing wrong? I've done the same on several PC's. All the same results.
My main pc: Athlon X2 5200, Radeon HD3750 (latest Catalyst driver, 7.12)

I could post more info, but as full-screen dvd playback on a widescreen is such basic functionality, im prolly missing something small, or doing something stupid.
 

Arn01805

Portal Pro
July 31, 2006
206
9
Breda
Home Country
Netherlands Netherlands
Aeon:

What is important is the aspect ratio of your DVD. From your post, I guess you have a 2:1 aspect movie and play it on 16:9. That's resulting in 2 black bars on top & bottom of your screen.

You can use the zoom mode (blue button on your MCE remote) to change aspect to zoom or stretch, this will change the aspect ratio of the movie, so you can have more or in this case less round heads or whatever.

If you have a 4:3 movie and play it, you will have the black bars on the side, again, use the zoom mode button to stretch this to full screen if you like.

This is the same thing that will happen on your dvd and tv-set, only then your TV probably detects the aspect of the movie and adjusts to the apriopiate zoom level.

This has nothing to do with upscaling, the upscaling works else you shouldn't have the full width on your lcd screen (1360 pixels) because your dvd movie is only 720 pixels wide.
 

jonaskp

Portal Pro
October 23, 2006
438
15
Home Country
Denmark Denmark
fanoI: I am having sort of the same problem as you, not being able to use zoom modes. Did you ever find a fix?

I'm using FFDshow to upscale to 1280x720, on a Samsung 42Q96 Plasma. FFDshow is used as video decoder.

My problem is this: I get my TV from analog cable, which is sent in 4:3 aspect, right? When I'm watching 4:3 content, this is shown correctly, image filling the screen top to bottom, but with black bars on the sides. This is the way I like it, I don't like stretching it. So far so good.
When I am watching 16:9 content, I get centered picture with black bars all around. My guess is this: Since this is still recieved as a 4:3 picture, it is fitted to the screen the same way, with bars on the side. Within this picture, there is black bars on the top and bottom, because of the 16:9 content.
Now I would like to use zoom, so the picture fills the entire screen, in 16:9 aspect, but when I select zoom modes, nothing happens. Zoom and stretch doesn't work, but Pan&scan does.

If I disable resize in ffdshow, I can use zoom without problems and get the picture size I want, but I think this is not the best way to upscale. Not sure though.

I haven't tried to use another decoder, and then adding FFDshow as post-processing as seen in the guide. Will try that once I get home.
If any of you guys ever found a solution to this problem, it would be much appreciated.
 

Kiwi

Portal Pro
September 21, 2006
73
1
Pukerua Bay
Home Country
New Zealand New Zealand
I also have the same problem with zoom / stretch when using ffdshow resize. Zoom & stretch etc work fine when not using postprocessing. I have ffdshow set to keep aspect ratio. Im using ffdshow tryouts, downloaded a couple of weeks ago - can anyone recommend a better version perhaps?
Any suggestions appreciated, as ffdshow has really improved the quality of the picture!
Thanks
 

jonaskp

Portal Pro
October 23, 2006
438
15
Home Country
Denmark Denmark
Since I last posted, I got it working, at least with normal and zoom which are the only modes im using.
I'm not positive how i did it, and im not at home right now so cant check it.
But what I remember is that I used a different decoder, and added ffdshow raw video as post processing. In ffdshow I'm using either "keep aspect ratio" or "No aspect ratio correction". It now works, so that when im watching a TV-show thats in 16:9 I can use zoom and fill the screen, and when its in 4:3 I just use normal and it has the black bars on the sides (hate stretched picture).
 

Spragleknas
Country flag

Administrator
  • Team MediaPortal
  • December 21, 2005
    9,472
    1,821
    Located
    Home Country
    Norway Norway
    Whenever I involve FFDShow (or any SW-decoder), hitting "!" gives me 25 FPS - no matter what. When only using DXVA (ie. using Cyberlink) I get 50 FPS.

    Is this the way it is intended to be, or is there something messed up in my computer of DSHOW filters?
     

    Djang

    Portal Pro
    November 3, 2007
    79
    6
    Home Country
    Netherlands Netherlands
    The 25 frames shows the current rate. But when you don't use FFdshow you probally use Harware Accceleration which shows in your frames in double speed.
    The movies still play correctly though, it's just the way Hardware Acceleration shows up in fps. When using FFdshow Hardware Accelertion is turned off automaticly.
     

    Pascal

    Portal Pro
    February 1, 2007
    99
    7
    IJsselmuiden
    Home Country
    Netherlands Netherlands
    Spargleknas,

    If I tick at ffdshows Output form, the option 'Set Interlace flag in output media' I got 50 fps playback (checked with '!').

    Hope it works for you too,

    Pascal
     

    Spragleknas
    Country flag

    Administrator
  • Team MediaPortal
  • December 21, 2005
    9,472
    1,821
    Located
    Home Country
    Norway Norway
    Interesting. I'll give it a try when I find "fiddle time".
    After clean install, I have gotten 50FPS w/SW.decoders, though.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom