Finally there's an artist image grabber available!

rtv

Retired Team Member
  • Premium Supporter
  • April 7, 2005
    3,622
    83
    Osnabruck
    Actually I would love to just have a list of the items that don't have cover art.
    Format doesn't really matter, I was just wondering if there was a way to capture the data.
    I did not really like the idea of adding an "export" button as it might not be a very common feature.
    Therefore I've decided to log all missing covers to Configuration.log everytime you push "Refresh".

    The result will look like this:

    PHP:
    2007-11-13 00:50:05.359375 [Info.][Config Main]: Audioscrobbler: Album cover missing: Anthrax - Attack Of The Killer B's
    2007-11-13 00:50:05.656250 [Info.][Config Main]: Audioscrobbler: Album cover missing: HammerFall - Legacy of Kings
    2007-11-13 00:50:05.812500 [Info.][Config Main]: Audioscrobbler: Album cover missing: Paradise Lost - In Requiem
    2007-11-13 00:50:05.859375 [Info.][Config Main]: Audioscrobbler: Album cover missing: Queensryche - Empire
    Feel free to use our pastebin if you want to paste it somewhere for future reference ;)
     

    Monchi

    Portal Pro
    January 7, 2008
    78
    8
    first of all, thx rtv for this nice working "new" feature.
    the only problem I have: the covers are only displayed (in myMusic) if one of the songs of an album is already played for at least one time.
    i had the same problem in myVideos, there i could "fix" it by activating the option "Each Movies has its own folder" (or similar)

    do you have any suggestions for a workaround?
     

    rtv

    Retired Team Member
  • Premium Supporter
  • April 7, 2005
    3,622
    83
    Osnabruck
    first of all, thx rtv for this nice working "new" feature.
    the only problem I have: the covers are only displayed (in myMusic) if one of the songs of an album is already played for at least one time.
    i had the same problem in myVideos, there i could "fix" it by activating the option "Each Movies has its own folder" (or similar)

    do you have any suggestions for a workaround?
    Sorry - this is not obvious but you have to scan the share with those albums to create the "folder cache" after applying all covers if you want to see them all right from the start.
     

    Monchi

    Portal Pro
    January 7, 2008
    78
    8
    works very well

    and now i can see that i should have spend some extra time on properly tagging my musiccollecton....damn ;-)
     

    bkwilos

    New Member
    February 23, 2008
    1
    0
    Where is it getting these images from? I'm wondering if there's any way to get higher quality images.

    I'm using the Spinsafe 1080p skin and I have my thumbnails set to the highest, but since it only downloads a smaller resolution file (around 140 x 140) when it blows it up to 600 x 600 for the larger icon it looks really fuzzy. Is there any way to actually download a separate larger image that isn't just the smaller image expanded to a bigger resolution?
     

    2BitSculptor

    Super Moderator
  • Team MediaPortal
  • January 23, 2008
    1,835
    83
    South Central Wisconsin
    Country flag
    This doesn't affect only artist thumbnails. I've complained about this previously. see this post and recapped elsewhere.
    Maybe you haven't stumpled upon while searching but I already wrote instructions how to change the xml file for your personal taste.

    Here's a little summary:
    1. Go to your skin's folder
    2. Open MyMusicPlayingNow.xml with a decent UTF8 editor (like Notepad++)
    3. Find the album art image control (<id>112</id>)
    4. Edit its properties to your liking. Possible settings of interest here are (set to true or false):
    - keepaspectratio
    - zoom
    - zoomfromtop
    - fixedheight
    - centered
    5. Save the file
    6. Restart MP to check the difference (repeat the steps until happy with the result).

    If some users provide feedback with a better solution than the current settings I'll be happy to add it to svn ;)

    Enjoy!

    Is there a property to get the artist pic to align to the righthand edge of the image frame instead of left (center=no) or center=yes?

    Thanks

    Chuck
     

    adam_purkis

    Portal Pro
    May 10, 2008
    120
    16
    i know im kinda raising an old thread.. but i am having problems getting the audioscrobbler plugin to get artist images. i already have most album art, so am not bothered about that, but the plugin appears not to find art for any of the artists in my database. it goes through the list, but everything remains at 'none' for high and low res images. presumably meaning that it is not downloading art for any of these artists?

    any idea why its not downloading anything? thanks!!
     

    dir

    MP Donator
  • Premium Supporter
  • August 30, 2006
    408
    28
    This doesn't affect only artist thumbnails. I've complained about this previously. see this post and recapped elsewhere.
    Maybe you haven't stumpled upon while searching but I already wrote instructions how to change the xml file for your personal taste.

    Here's a little summary:
    1. Go to your skin's folder
    2. Open MyMusicPlayingNow.xml with a decent UTF8 editor (like Notepad++)
    3. Find the album art image control (<id>112</id>)
    4. Edit its properties to your liking. Possible settings of interest here are (set to true or false):
    - keepaspectratio
    - zoom
    - zoomfromtop
    - fixedheight
    - centered
    5. Save the file
    6. Restart MP to check the difference (repeat the steps until happy with the result).

    If some users provide feedback with a better solution than the current settings I'll be happy to add it to svn ;)

    Enjoy!

    Is there a property to get the artist pic to align to the righthand edge of the image frame instead of left (center=no) or center=yes?

    Thanks

    Chuck
    Sorry to sound stupid, but I tried this and it didn't make any difference. Perhaps I'm looking at the wrong screen.
    I modified MyMusicPlayingNow.xml in the StreamedMP directory thusly:

    <control>
    <type>image</type>
    <description>album art image</description>
    <id>112</id>
    <keepaspectratio>true</keepaspectratio>
    <posX>220</posX>
    <posY>150</posY>
    <width>280</width>
    <height>280</height>
    <texture>-</texture>
    </control>

    But when I view the artist images, they're still square. I couldn't find any other xml files to modify. Did I mistype it or looking at the wrong screen?

    Any clues for the clueless gratefully received!
     

    adam_purkis

    Portal Pro
    May 10, 2008
    120
    16
    i know im kinda raising an old thread.. but i am having problems getting the audioscrobbler plugin to get artist images. i already have most album art, so am not bothered about that, but the plugin appears not to find art for any of the artists in my database. it goes through the list, but everything remains at 'none' for high and low res images. presumably meaning that it is not downloading art for any of these artists?

    any idea why its not downloading anything? thanks!!
    does anybody know why the the artists images are not being grabbed?
     
    Top Bottom