[fixed] Forced subtitles still not work (2 Viewers)

ShIvADeSt

Portal Pro
May 30, 2009
71
2
LAV filter not supported for downloading forced subs in 1.2.0. Only MPC matroskasplitter.
For MPC splitter I just manage it as default system splitter (any merrit programm), then add MP audio post processing (look screen above) and it's all. Forced subs autoload for me.
 

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hi,

    Just a quick, LAV and MPC-HC Engine works for Forced Subtitle track like MPC Matroska Splitter, need to patch MPC-HC Engine dll.
    Thanks to Nevcairiel to add ITrackInfo support in LAVF and cpp2005 to patch MPC-HC engine :)
    I don't know if it will be added for 1.2.0RC but for sure, it will be for next 1.3.0 :)
    Thanks.
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    AW: Forced subtitles still not work

    Maybe you could post a test .dll here?
    Thanks for you work!
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hi,

    For testing, ou can try this attached dll :)
    Thanks,
    Seb.

    Edit Dll removed, it was already include in Final version 1.2.1 :)
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    AW: Forced subtitles still not work

    For my understanding:
    I have a .mkv file which contains a forced subtitle.. with this .dll + LAVF Splitter it should show automatically with setting "Autoload subtitles OFF" shouldn't it? =) Can't test it until next week tho. :(
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    AW: Forced subtitles still not work

    Hello!
    I wanted to test your .dll but I get a runtime error (see screenshot).
    Am I missing the Microsoft Visual C++ 2010 Redistributable Package (x64)? x86 is installed.
    Thanks!
     

    Attachments

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hi,

    it's works on my system, i recompil it, can you retry ?
    Thanks,
    Seb.
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    AW: Forced subtitles still not work

    Still not working. :(
    I guess I'm missing something..


    PS: Got this error.log now.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    OP Similar threads Forum Replies Date
    M.Hulot Blu-ray: Es werden nicht nur Forced Subtitles angezeigt Allgemeines Supportforum 1
    G [fixed] [MP2-811] Forced client wake-up at 2:00 2.2 Archive 32
    Neoculture Force installation of TV-Server? Newcomers Forum 3
    mickb Subtitles My TVSeries 9
    J How to change y position of subtitles General 3
    R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
    S Remote button to change audio and subtitle on / off General 10
    P [solved] ATSC subtitles not fixed yet? General 2
    E Swedish subtitles problem General 2
    ratata Someone stole my subtitles... General Support 0
    Dark Eyes Display subtitles on a separate display or device MediaPortal 1 Plugins 0
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    S Display non english folder name, subtitle, etc. General 23
    S [solved] Movie SRT subtitle didn't display on client 2.2 Archive 18
    S [solved] Live TV subtitle issue if not using 100% font General 31
    D [solved] How to configure subtitle color in MP 2.2.1? General 5
    S [fixed] [MP2-611] Teletext subtitles language selection 2.2 Archive 20
    G [fixed] [MP2-611] Having problems with subtitles (ATSC) 2.2 Archive 14
    S Australia live TV teletext subtitle General 4
    Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
    ratata Non present codecs is still showing... MediaPortal 1 Talk 2
    P [solved] TV server no longer saving to NAS - (can still play from NAS) General Support 2
    high [Help Me!] Atlassian Fisheye/Crucible still used? Team Lounge 8
    N Onscreen keyboard to still accept input from real keyboard Feature Requests 6
    Similar threads

























    Top Bottom