Help needed troubleshooting freezing issues in Kodi/LE w Mediaportal backend

Discussion in 'Television (MyTV frontend and TV-Server)' started by tomoqv, January 23, 2018.

  1. tomoqv

    tomoqv Portal Pro

    Joined:
    June 28, 2006
    Messages:
    125
    Likes Received:
    4
    Location:
    Stockholm
    Ratings:
    +4 / 0
    Home Country:
    Sweden Sweden
    My current setup:
    Mediaportal TV Server (v 1.18.1 on Win7 Pro) - wired network connection
    Kodi (v 17.6 on Ubuntu 16.04.3) - wired network connection
    LibreElec (v 8.02 on RPi3) - Wi-Fi connection
    Mediaportal PVR Client (v 2.4.19)

    The problem:
    Intermittent Kodi or LE UI freezes when streaming live TV or recordings from my PVR backend. Usually the freezes occur within an hour after starting playback, but before the freeze everything works as expected. I know it is the UI that freezes, because I can still access my Kodi clients through ssh. My current workaround is too reboot the client or just kill and restart Kodi on the Ubuntu PC. After rebooting or restarting the PVR client, I can resume PVR streaming again (but expect another freeze within an hour or so).

    Sometimes, if I just leave the Kodi or LE client alone after a freeze, PVR starts again. My kodi.log includes such a case where Kodi froze (around 14:04) and then resumed streaming again after 20-30 minutes.

    I have been running this setup for a few years without any major issues. These problems started occuring around the time I replaced my Asus RT-AC68U with a Ubiquiti EdgeRouter X and a couple of Unifi AP Pro.

    Kodi log file:
    Ubuntu Pastebin

    MP tvserver_streaming server.Log
    Ubuntu Pastebin

    I will update with the LE kodi.log next time it freezes. In line with Murphy's law or the "demo devil", PVR streaming just ran for 2 hours without freezing.



    Any help on troubleshooting this would be greatly appreciated!
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hi

    Is it the stream that's freezing, or the entire UI?
    What does TV Server Configuration "manual control" and "streaming server" sections say about the stream/clients?
     
  4. tomoqv

    tomoqv Portal Pro

    Joined:
    June 28, 2006
    Messages:
    125
    Likes Received:
    4
    Location:
    Stockholm
    Ratings:
    +4 / 0
    Home Country:
    Sweden Sweden
    The entire UI freezes. Last time I checked the MP TV server after a freeze, the stream was still running in "manual control". I haven't checked "streaming server" though.

    Including log file from LibreElec as well after freeze:
    Ubuntu Pastebin
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Okay. From these symptoms it sounds like the problem is on the network, KODI or LE side. Also, in the previous KODI log at ~14:04 you can see:
    Show Spoiler

    14:01:05.040 T:139654271923968 ERROR: Read - Error( -1, 110, Förbindelsen dog ut (timeout) )
    14:01:30.493 T:139656850999040 DEBUG: Thread JobWorker 139656850999040 terminating (autodelete)
    14:01:35.047 T:139654271923968 ERROR: Read - Error( -1, 110, Förbindelsen dog ut (timeout) )
    14:01:35.048 T:139654271923968 ERROR: AddOnLog: MediaPortal PVR Client: MultiFileReader has error 0xe2 in Loop 0. Try to clear SMB Cache.
    14:01:35.048 T:139654271923968 DEBUG: AddOnLog: MediaPortal PVR Client: RefreshTSBufferFile: filesAdded -1, filesAdded2 -2, filesRemoved -1, filesRemoved2 -2.
    14:01:35.048 T:139654271923968 DEBUG: CSMBFile::Close closing fd 10000
    14:02:05.048 T:139654271923968 INFO: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() smb://TVServer:tvserver@NEWTVSERVER/Timeshift/live3-1.ts.tsbuffer.
    14:02:35.060 T:139654271923968 DEBUG: CSMBFile::Open - opened smb://USERNAME:pASSWORD@NEWTVSERVER/Timeshift/live3-1.ts.tsbuffer, fd=10000
    14:02:35.061 T:139654271923968 DEBUG: AddOnLog: MediaPortal PVR Client: OpenFile: OpenFile(smb://TVServer:tvserver@NEWTVSERVER/Timeshift/live3-1.ts.tsbuffer) succeeded.
    14:02:35.068 T:139654271923968 DEBUG: CSMBFile::Open - opened smb://USERNAME:pASSWORD@NEWTVSERVER/Timeshift/live3-1.ts.tsbuffer1.ts, fd=10002
    14:02:35.069 T:139654271923968 DEBUG: CSMBFile::Close closing fd 10002
    14:02:35.070 T:139654271923968 DEBUG: CSMBFile::Open - opened smb://USERNAME:pASSWORD@NEWTVSERVER/Timeshift/live3-1.ts.tsbuffer2.ts, fd=10002
    14:02:35.071 T:139654271923968 DEBUG: CSMBFile::Close closing fd 10002
    14:03:05.073 T:139654271923968 ERROR: Read - Error( -1, 110, Förbindelsen dog ut (timeout) )
    14:05:59.373 T:139654734976768 ERROR: Previous line repeats 5 times.


    So, it looks like KODI is having trouble accessing the timeshift files over the network.
    For such problems it's usually best to ask for help on the KODI forum.
     
  6. tomoqv

    tomoqv Portal Pro

    Joined:
    June 28, 2006
    Messages:
    125
    Likes Received:
    4
    Location:
    Stockholm
    Ratings:
    +4 / 0
    Home Country:
    Sweden Sweden
    I have now opened port 8080 for MP TV Server in my router firewall config. Read somewhere that port shouldn't be blocked by a firewall. Could that have something to do with my issue?
     
  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    I doubt it.
    According to the KODI log file, KODI is accessing the time-shift files directly via SMB shares. If that's the case, the streaming server won't be used at all. Also, the streaming server doesn't use port 8080.
     
  8. tomoqv

    tomoqv Portal Pro

    Joined:
    June 28, 2006
    Messages:
    125
    Likes Received:
    4
    Location:
    Stockholm
    Ratings:
    +4 / 0
    Home Country:
    Sweden Sweden
    Ok, I see. Any idea what could be affecting the SMB access?
     
  9. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    No, nothing specific. In general reliable SMB shares require reliable networking stacks... so think NIC drivers, firewalls, routers, OS SMB protocol config etc..
     
  10. tomoqv

    tomoqv Portal Pro

    Joined:
    June 28, 2006
    Messages:
    125
    Likes Received:
    4
    Location:
    Stockholm
    Ratings:
    +4 / 0
    Home Country:
    Sweden Sweden
    Thanks, I will read up on that.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!