Importer ignores "wild" episodes (no named folder) | Page 2

Discussion in 'My TVSeries' started by emphatic, February 3, 2016.

  1. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,457
    Likes Received:
    4,241
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,385 / 0
    Home Country:
    Australia Australia
    I just tried putting "Chuck.S03E01.Chuck Versus the Pink Slip.720p.WEB-DL.DD5.1.H.264-LP.mkv" into my root import folder which is defined as \\nas\tv. This appears to get picked up fine.



    What is your import path defined as? Is it a root directory or a folder on a drive? Mine is a folder on a network drive but it would be the same as a local drive e.g. C:\TV.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
    My root folder is:
    \\emphaticnas\Serier\

    Emph
     
  4. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,457
    Likes Received:
    4,241
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,385 / 0
    Home Country:
    Australia Australia
    I just ran a test on a clean database:

    Import Path = \\NAS\Recordings
    File = \\NAS\Recordings\The.Flash.2014.S02E12.720p.mkv

    All good.

    Can you run a similar test with a clean DB and confirm if it works?
     

    Attached Files:

    • ImportPath.jpg
      ImportPath.jpg
      File size:
      183.2 KB
      Uploaded:
      February 5, 2016
      Views:
      43
    • Parsing.jpg
      Parsing.jpg
      File size:
      160.4 KB
      Uploaded:
      February 5, 2016
      Views:
      40
  5. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
    I'll do that after work. ;)
    Emph
     
  6. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
    Did an import with a clean database (removed the latest db3 from the database folder) and still am not getting wild files imported. Attached logs and database. The file that was skipped is called "Suits.S05E12.720p.HDTV.x264-KILLERS.mkv"

    Emph
     

    Attached Files:

  7. RoChess
    • Premium Supporter

    RoChess Extension Developer

    Joined:
    March 10, 2006
    Messages:
    4,182
    Likes Received:
    1,304
    Ratings:
    +1,683 / 2
    I do remember users complaining about import issues before, and it turned out it was their NAS acting up with permissions. Maybe your shared folder has different permissions at root level for files, then it does inside subfolders?

    If you make a subfolder "TV" at root level, and then try:

    \\emphaticnas\Serier\TV\The.Flash.2014.S02E12.720p.mkv versus \\emphaticnas\Serier\TV\The.Flash.2014.S02E12.720p\The.Flash.2014.S02E12.720p.mkv

    That would quickly verify if that is the case.

    To me though it looks like the only active parsing expression is the "show-folder\season-episode-filename" one, and not the "show-season-episode-filename" one that should be primary by default. You should be able to see what parsing expression was used to do the match when it "works" to verify that.
     
    • Thank You! Thank You! x 1
  8. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
    Would I really be able to edit and move files to and from the root folder of a shared folder from the client computers using Windows/Mac if that was the case? Also, I've yet not seen this problem in Moving Pictures, that picks up files without an extra directory layer before root, and the shared folders for Movies is setup the same way as shows.

    Looking at my NAS permission settings for my shared folders, especially the one with TV-shows in, there are no special rules or permissions active. I can see options to add stuff like that, but it's just not being used.

    Thanks!
    Emph
     
  9. RoChess
    • Premium Supporter

    RoChess Extension Developer

    Joined:
    March 10, 2006
    Messages:
    4,182
    Likes Received:
    1,304
    Ratings:
    +1,683 / 2
    I solve a lot of problems with the Sherlock Holmes approach of eliminating all other possibilities. If you are sure that it is not a contributing factor by running a quick test to confirm, then I'll step out and hope somebody else can figure it out for ya.
     
    • Agree Agree x 1
  10. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
    You were right, making a TV directory ( \\emphaticnas\Serier\tv\ ) makes the importer pick up even loose episodes inside it. It also works for stuff inside yet another directory.

    I wonder though how this has changed on my NAS, as I have no recollection of ever changing anything.
    Emph
     
  11. RoChess
    • Premium Supporter

    RoChess Extension Developer

    Joined:
    March 10, 2006
    Messages:
    4,182
    Likes Received:
    1,304
    Ratings:
    +1,683 / 2
    At least we can now exclude MP-TVSeries more as being the problem, and you can focus on what the NAS is doing that makes root files special, but not when it is a folder. Could be as easy as chmod/chown properties on the root folder, or some other setting.

    Of course for MP-TVSeries it does not matter, and you could make that "TV" folder in the root the new location for MP-TVSeries.

    I guess that could be another test, if you make "\\emphaticnas\Serier\tv\" the MP-TVSeries import path and see if you can then recreate the problem with files in the root of "TV" subfolder to see if that brings back the issue again.

    In that case I would say there is something wrong with the way MP-TVSeries handles import folders.
     
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!