(Inofficial) New release major updates - NOW WITH SOURCE CODE :) (1 Viewer)

emphatic

Design Group
  • Team MediaPortal
  • August 25, 2006
    3,602
    1,093
    Alingsås
    Sweden Sweden
    Country flag
    I just installed the latest official release a couple of days ago (with MediaPortal 1.1.2 Alpha) and it works just fine (only running a couple of MAME games though). Something that's been bothering me with the official release is that it seems you can't start it showing favorites with Filmstrip view. I have to go into the menu each startup and change the view manually. Is this something that has been added to the unofficial release?

    I guess I'll have to try this unofficial build sometime soon. I'd really love to see Cover Flow added to this emulator in the future though.
    Emph
     

    Liggs

    Portal Member
    December 11, 2009
    5
    0
    EDIT: This is if I try and add fanart before saving it. If I try after saving it, I get no error, just nothing happens.


    Getting this error in the config for the plugin when I try and choose a logo or fanart for an emulator:

    ----

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
    at myEmulators.ThumbsHandler.createEmulatorArt(Emulator item, String ArtType)
    at myEmulators.Conf_Emu_Details.btnLogoView_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    -----

    Any ideas? I've tried completely uninstalling and reinstalling everything, twice, but no luck.
     

    biohazardxxx

    Portal Pro
    August 5, 2010
    104
    15
    Germany Germany
    AW: (Inofficial) New release major updates - NOW WITH SOURCE CODE :)

    It really looks good with the Nova skin! But now I can not start any PC game.
    Nothing happens. It worked fine with the verion before.
    This is from error.log:
    2011-01-02 11:25:13.848669 [ERROR][MPMain(1)]: OnMessage exception:confused:ystem.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
    bei myEmulators.MainPresenter.onFacadeClicked(ActionType ButtonPressed)
    bei myEmulators.Plugin.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
    bei MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)
    2011-01-02 11:25:17.592883 [ERROR][MPMain(1)]: OnMessage exception:confused:ystem.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
    bei myEmulators.MainPresenter.onFacadeClicked(ActionType ButtonPressed)
    bei myEmulators.Plugin.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
    bei MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)
    2011-01-02 11:25:20.502049 [ERROR][MPMain(1)]: OnMessage exception:confused:ystem.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
    bei myEmulators.MainPresenter.onFacadeClicked(ActionType ButtonPressed)
    bei myEmulators.Plugin.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
    bei MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)
    2011-01-02 11:42:07.300992 [ERROR][MPMain(1)]: OnMessage exception:confused:ystem.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
    bei myEmulators.MainPresenter.onFacadeClicked(ActionType ButtonPressed)
    bei myEmulators.Plugin.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
    bei MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)
    and this from MediaPortal.log:
    2011-01-02 11:42:07.299992 [Info.][MPMain(1)]: OnMessage exception:confused:ystem.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
    bei myEmulators.MainPresenter.onFacadeClicked(ActionType ButtonPressed)
    bei myEmulators.Plugin.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
    bei MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)
    Do you have an idea what this could be? Do you need something else?
     

    powermarcel10

    Retired Team Member
  • Premium Supporter
  • November 30, 2010
    2,839
    898
    32
    Groningen
    Netherlands Netherlands
    hi Guys,

    I was wondering if my emulators is compatible with MP 1.2.0, and if this plugin under constuction is..

    Grtz
     

    ofird

    Portal Pro
    January 8, 2011
    78
    4
    I updated this on MP 1.2a + myEmulators 3.3

    I got this when trying to Config the plugin

    Code:
    SQLite.NET.SQLiteException: SQLiteClient: myEmulators_v2.db3 cmd:sqlite3_prepare16:pvm=null err:ERROR detailed:table Gamestemp already exists query:CREATE TABLE Gamestemp(path varchar(200),parentemu int,title varchar(100),grade int,playcount int,yearmade int,latestplay varchar(16),description varchar(200),genre varchar(50),company varchar(50),visible char(5),favourite char(5),LaunchFile varchar(200))
       ב-  SQLite.NET.SQLiteClient.ThrowError(String statement, String sqlQuery, SqliteError err)
       ב-  SQLite.NET.SQLiteClient.Execute(String query)
       ב-  myEmulators.DB.init()
       ב-  myEmulators.Plugin.startUp()
       ב-  myEmulators.Plugin.ShowPlugin()
       ב-  MediaPortal.Configuration.Sections.PluginsNew.itemConfigure_Click(Object sender, EventArgs e)
       ב-  System.Windows.Forms.Control.OnClick(EventArgs e)
       ב-  System.Windows.Forms.Button.OnClick(EventArgs e)
       ב-  System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
       ב-  System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       ב-  System.Windows.Forms.Control.WndProc(Message& m)
       ב-  System.Windows.Forms.ButtonBase.WndProc(Message& m)
       ב-  System.Windows.Forms.Button.WndProc(Message& m)
       ב-  System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       ב-  System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       ב-  System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
     

    joz

    Portal Pro
    March 17, 2008
    1,353
    306
    Netherlands Netherlands
    I'd say read the error, the solution is in there;
    Drop the table Gamestemp from your MyEmulators.db3 (with something like sqlite browser). If you do not know how then just delete the complete DB
     

    nimroder

    Portal Pro
    July 25, 2010
    57
    0
    I reinstalled my system completly but still got the same error.

    Code:
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    SQLite.NET.SQLiteException: SQLiteClient: myEmulators_v2.db3 cmd:sqlite3_prepare16:pvm=null err:ERROR detailed:table Gamestemp has 13 columns but 14 values were supplied query:INSERT INTO Gamestemp SELECT * FROM games;
       at SQLite.NET.SQLiteClient.ThrowError(String statement, String sqlQuery, SqliteError err)
     
    
    ....
    Found my problem. Just delete the database once and it will be recreated on next config start with all fields required..
     

    ofird

    Portal Pro
    January 8, 2011
    78
    4
    I'd say read the error, the solution is in there;
    Drop the table Gamestemp from your MyEmulators.db3 (with something like sqlite browser). If you do not know how then just delete the complete DB
    you are right, I did delete the db and it works fine

    But pc games are only shown with their art and info once I added a "pc game" emulator and direct it to a folder with shortcuts to the games themselves

    this is a fine workaround for me :)

    BTW - are there any nice emulators with simple games for kids that I can start with?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ajs [Action Required] MP 1.27 Pre Release thread MediaPortal 1 0
    A VideoDatabaseV5.db3 lock not released on shutting down PC from MediaPortal Installation, configuration support 0
    ajs [Action Required] MP 1.26 Final Release thread MediaPortal 1 9
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    ajs [Action Required] MP 1.25 Final Release thread MediaPortal 1 503
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    G Movie release date in guide Electronic Program Guide 2
    atlantic [solved] MP1.24 Pre released crash in TV General Support 12
    ajs [Action Required] MP 1.26 Pre Release thread MediaPortal 1 307
    ajs [Action Required] MP 1.25 Pre Release thread MediaPortal 1 515
    azzuro [News] MediaPortal 1.24 Pre-Release ready for testing! News and Announcements 0
    ajs [Action Required] MP 1.24 Final Release thread MediaPortal 1 37
    HTPCSourcer [News] MediaPortal 2.2.3 Release News and Announcements 0
    ge2301 [Finished] MP 2.2.3 Release MediaPortal 2 81
    azzuro [Action Required] MP 1.24 Pre Release thread MediaPortal 1 207
    HTPCSourcer [WiP] MP 2.3 Release MediaPortal 2 620
    HTPCSourcer [News] MediaPortal 2.2.2 Release News and Announcements 0
    2BitSculptor MP1.23 release mediainfo issue? MediaPortal 1 Talk 4
    azzuro [News] MediaPortal 1 - 1.23 Released! News and Announcements 42
    ajs [News] MediaPortal 1.23 Pre-Release ready for testing! News and Announcements 6
    azzuro [Action Required] MP 1.23 Final Release thread MediaPortal 1 58
    O [Help Me!] How to change 'release' status in Jira? Developer Discussions 9
    Top Bottom