installing 1.3 beta alongside 1.2.3 ?? (1 Viewer)

NewbieFromHell

Portal Member
July 10, 2012
9
0
44
Home Country
United Kingdom United Kingdom
does this work, have got my 1.2.3 setup with all the addons i like, question is can i install 1.3 alongside so i can try it, just don't wanna break my original setup

thanks
 

powermarcel10

Retired Team Member
  • Premium Supporter
  • November 30, 2010
    2,839
    898
    35
    Groningen
    Home Country
    Netherlands Netherlands
    does this work, have got my 1.2.3 setup with all the addons i like, question is can i install 1.3 alongside so i can try it, just don't wanna break my original setup

    thanks

    Hi NewbieFromHell, (good nickname btw:p)

    You can't run 2 installations at the same time on one pc I'm affraid..

    So you need to check if all your plugins and the skin you like to use is compatible with the new version of MP, and try it..

    Offcourse you can backup your current installation and put it back if MP 1.3.0 is not working fine for you..

    Let me say that MP 1.3.0 beta is allready very stable.. I'm running it on my main system without problems..

    Good luck!
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,751
    New Zealand
    Home Country
    New Zealand New Zealand
    1.3B is stable enough for most people, I say go for it, All the main plugins work, but some skins and the less mainstream plugins aren't 1.3B compatible yet.
     

    Bernard

    Portal Pro
    March 5, 2012
    103
    25
    39
    Centurion
    Home Country
    South Africa South Africa
    Oh boy NewbieFromHell,

    YOU ARE MISSING OUT BIG TIME! I also have 1.3.0Beta as my main install, and like kiwijunglist mentioned most of the popular plugins are already updated for 1.3.0 Beta. So you should just maybe go to your plugins under the configuration and check online if each of your plugins that you use is updated for 1.3.0 Beta.

    But really my setup took ages to startup with 1.2.3, like 3 to 4 minutes to boot!, but since I upgraded to 1.3.0 Alpha (now on Beta) the startup is so fast, I can actually close media portal do a config change and start it up again in seconds!

    Now if only TV-Series and Moving Pictures can follow lead... for some reason when opening Moving Pictures for the first time, it takes about a minute to load the options list of: "All Movies, Unwatched Movies, Genres, ....". And when it start scanning for new movies my current movie starts stuttering. (Yes my system does not have that much excess processing power! I'm on a budget P4 3Ghz). But this is nothing new between 1.2.3 and 1.3.0.

    EDIT:
    Just to add, your original concern is valid, it would be nice if someone can design a nice 3rd party application that you can use to "backup" and "restore" media portal setups, so that you can instantly backup your current, then do a upgrade, then just backup the new one and jump back to the old backup, then backup again, and jump to the new version.... you get the idea.. I hope...
     
    Last edited:

    Wbunaarf

    Portal Pro
    December 9, 2005
    534
    103
    Sweden
    Home Country
    Sweden Sweden
    Just to add, your original concern is valid, it would be nice if someone can design a nice 3rd party application that you can use to "backup" and "restore" media portal setups, so that you can instantly backup your current, then do a upgrade, then just backup the new one and jump back to the old backup, then backup again, and jump to the new version.... you get the idea.. I hope...

    Something like https://forum.team-mediaportal.com/threads/backupsettings-for-tv-server-and-media-portal.45715/ ?

    //W
     

    Bernard

    Portal Pro
    March 5, 2012
    103
    25
    39
    Centurion
    Home Country
    South Africa South Africa
    Just to add, your original concern is valid, it would be nice if someone can design a nice 3rd party application that you can use to "backup" and "restore" media portal setups, so that you can instantly backup your current, then do a upgrade, then just backup the new one and jump back to the old backup, then backup again, and jump to the new version.... you get the idea.. I hope...

    Something like https://forum.team-mediaportal.com/threads/backupsettings-for-tv-server-and-media-portal.45715/ ?

    //W
    Yes! I'm bookmarking that thread for later.
     

    Marcus Venturi

    MP Donator
  • Premium Supporter
  • March 23, 2012
    614
    745
    56
    Home Country
    Germany Germany
    I'm using 1.2.3 and 1.3 beta in parallel.

    First I made a backup of the relevant directories by copying them to a safe location:

    c:/ProgramData/Team MediaPortal
    c:/Program Files (x86)/Team MediaPortal

    Then I installed 1.3. Afterwards I went to Services and stopped the TVService and renamed the directories of the 1.3:

    c:/ProgramData/Team MediaPortal 1.3
    c:/Program Files (x86)/Team MediaPortal 1.3

    I copied back the backup of 1.2 to the original locations

    Then I started the service again.

    Now I can switch betwen 1.2.3 and 1.3 by just stopping the service, renaming the folders and restarting the service.
     
    Last edited:

    Users who are viewing this thread

    Similar threads

    I had the same issue and found the executable under C:\ProgramData\Team MediaPortal\MediaPortal\skin\Titan\BasicHome.Editor\TitanEditor.exe Only the shortcut was missing.
    I had the same issue and found the executable under C:\ProgramData\Team...
    Hi all, Not a rant, more a sharing of experience (maybe hoping to get some clarification on which wrong turn I took) It has been...
    Replies
    9
    Views
    1K
    That fixed the problem. I just manually installed VC_redist.x64.exe and reinstalled 1.32 64-bit. Thanks for that. A couple of things; the deployment tool for 1.32 doesn't remove the previous version when you're updating from 1.31 to 1.32 and "MediaPortal TV Server" gets installed even when you choose to install the client only. I...
    That fixed the problem. I just manually installed VC_redist.x64.exe and reinstalled 1.32 64-bit. Thanks for that. A couple of...
    I have performed client installations of 1.32 64-Bit on four machines using the central configuration setup on Windows 10 Pro...
    Replies
    2
    Views
    542
    restarting is supported but depends on the reason why it failed. As an external tool try JDownloader.org - Official Homepage
    restarting is supported but depends on the reason why it failed. As an external tool try JDownloader.org - Official Homepage
    Earlier this year I changed my internet service provider from a landline (where I was consistently overcharged), to a mains-powered...
    Replies
    1
    Views
    555
    Hi, First off: there are some issues with the latest Mediaportal (32bits vs 64bits), so that is one of the issues you're stumbling with. If you take the previous version (1.31) it should work as expected. For IPTV there is also a different option (with different pros and cons): Onlinevideos. I'm using that sometimes for my IPTV as...
    Hi, First off: there are some issues with the latest Mediaportal (32bits vs 64bits), so that is one of the issues you're stumbling...
    Hi I am trying to play a m3u file from my IPTV provider, but when I try to install the TV part of Media Portal v1.3.2 I get an...
    Replies
    1
    Views
    474
    Thank you! I guess I was overthinking it.
    Thank you! I guess I was overthinking it.
    This is apparently such a low level question that it's not even documented that I can find - I apologize in advance for this: I...
    Replies
    2
    Views
    559
    Top Bottom