Kurzanleitung MyFilms! | Page 7

Discussion in 'Tipps, Tricks & Tutorials' started by Helios61, November 20, 2008.

  1. catalpa

    catalpa Portal Pro

    Joined:
    May 9, 2009
    Messages:
    353
    Likes Received:
    14
    Ratings:
    +18 / 1
    Home Country:
    Germany Germany
    Show System Specs
    ah, warum sind das Start- und Stoptags? Kann man mehr als zwei Files aufnehmen und wenn ja, wie unterscheidet er cover von fanart?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. catalpa

    catalpa Portal Pro

    Joined:
    May 9, 2009
    Messages:
    353
    Likes Received:
    14
    Ratings:
    +18 / 1
    Home Country:
    Germany Germany
    Show System Specs
    er rödelt jetzt schon recht lange (konnte Abendessen und hab erst 50%) *facepalm*
    Da ich gleichzeitig die Pfade für Fanart, Cover, xml usw. auf den Server umgelegt habe,
    ist es mir nicht ganz gehäuer ob es auch klappt. Ein einfaches neu importieren ging nicht,
    habe dann vom zweiten Reiter Update der Records gemacht, hoffe das ist richtig. Muss man
    für die zenrale Datenhaltung auf dem Server was besonderes beachten oder reicht es (wie
    gemacht) die Pfade zu verstellen? Ziel der Übung ist dass ich nicht auf dem HTPC die Sache
    pflegen will, zu unbequem, außerdem soll ein anderer Client noch darauf zugreifen und die
    bessere Hälfte hätte noch n iMac mit XBMC. Wie sind denn die Exportmöglichkeiten zu XBMC?

    Danke und n schönen Feiertag

    update:
    zu früh gefreut, er hat nichts von den lokalen Files genommen sondern viel Fanart runtergeladen :(

    drei Versuche später:
    o.k. Cover scheinen zu klappen, hatte ein # zuviel in den scrapereinstellungen, aber von den
    backdrops weiter keine spur... sicher dass die bei CoverURL eingetragen werden?
     
    Last edited: October 31, 2012
  4. catalpa

    catalpa Portal Pro

    Joined:
    May 9, 2009
    Messages:
    353
    Likes Received:
    14
    Ratings:
    +18 / 1
    Home Country:
    Germany Germany
    Show System Specs
    o.k. habs, unter Database Fields unten die Checkbox musste noch gesetzt werden...
    kann ich die runtergeladenen Files von Hand löschen oder muss das über den Updater laufen?
    Die runtergeladenen Files haben alle die selbe Namensstrucktur mit geschweiften Klammer,
    die kopierten haben nur den Filmnamen. Ist der Name relevant oder wird schlicht alles
    aus dem ensprechenden Ordner genommen was ein jpg ist?
     
    Last edited: November 2, 2012
  5. catalpa

    catalpa Portal Pro

    Joined:
    May 9, 2009
    Messages:
    353
    Likes Received:
    14
    Ratings:
    +18 / 1
    Home Country:
    Germany Germany
    Show System Specs
    beim Rumtesten habe evtl. n Bug gefunden, klickt man bei laufendem Update auf "View Movies" kommt es zu einer Fehlermeldung: Error reading xml database after 256 records; Film; error: Die Eingabezeichenfolge hat das falsche Format.

    update:
    angeblich hat er mit allen Filmen ab dem 256. ein Problem, was hat "Die Eingabezeichenfolge hat das falsche Format" zu bedeuten? ANT zeigt alle Filme an und Fehler kann ich beim 256er auch keine sehen. Am besten wird es sein alles platt zu machen und eine neue xml-Datei aufzubauen. Aber ich würde gerne verstehen was los ist.
     
    Last edited: November 2, 2012
  6. Guzzi
    • Team MediaPortal

    Guzzi Retired Team Member

    Joined:
    August 20, 2007
    Messages:
    2,161
    Likes Received:
    704
    Ratings:
    +922 / 0
    Der Ordnername wird zur Zuordnung verwendet. Am einfachsten ist es wahrscheinlich alles zu löschen und dann nochmal einzulesen.
     
  7. Guzzi
    • Team MediaPortal

    Guzzi Retired Team Member

    Joined:
    August 20, 2007
    Messages:
    2,161
    Likes Received:
    704
    Ratings:
    +922 / 0
    Das deutet auf einen Parserfehler hin - rating oder datum kann nicht konvertiert (gelesen und umgewandelt) werden.
    Wenn Du mir das XML file schickst, schaue ich es mir an.
     
  8. catalpa

    catalpa Portal Pro

    Joined:
    May 9, 2009
    Messages:
    353
    Likes Received:
    14
    Ratings:
    +18 / 1
    Home Country:
    Germany Germany
    Show System Specs
    Hallo,
    habe ich schon gelöscht und neu aufgebaut und auch schon wieder gelöscht... ;)
    Bin z.Z. etwas genervt weil ich nicht mehr weiter komme, wenn ich ein Problem
    gelöst (oder umgangen) habe stoße ich an anderer Stelle auf zwei neue :(
    z.B. klappt es mit der remote config nicht weil mir der "Confing-Empfänger"
    erzählt er könne die Conig nicht lokal speichern. Egal, hebe ich mir für später
    auf, aber nerviger ist, dass ich mir immer wieder alles zerschieße und schon
    x-mal von Vorne angefangen habe. :-( Ich wollte die Covers aus dem gemeinsamen
    Ordner mit dem Katalog raus haben, weil ich es merkwürdig finde alles zusammen
    zu packen. War mir nicht sicher ob das mit dem relativem Pfad gemacht werden
    muss, habe mit wohl fasch entschieden und mit einem mal war in dem Prefixfeld
    ein String der wohl eher Programmcode gewesen ist... hab es jedenfalls nicht
    verstanden, es war mein Serverpfad mit weiteren Anhängseln.
     
  9. catalpa

    catalpa Portal Pro

    Joined:
    May 9, 2009
    Messages:
    353
    Likes Received:
    14
    Ratings:
    +18 / 1
    Home Country:
    Germany Germany
    Show System Specs
    ich war jetzt sehr zurückhalten und habe ein Rumpfsystem. Jetzt läuft der Onlineimport von fehlenden Daten, was mich dabei wunder, warum kommt es zu nicht erkannten Filmen obwohl es nur ein Update ist und alle (!) Filme bereits erkannt sind?

    hm, bei einer der Filmunbekanntabfragen ist er mit einem .Net-Fehler ausgestiegen und danach fehlten 11 Filme die vorher schon mal drin waren. Im Log steht die Dateinamen seien zu lang, sind sie aber nicht.

    Code (Text):
    1. ErrorEvent : ErrorEvent importing Godzilla\Godzilla.avi : Der angegebene Pfad und/oder Dateiname ist zu lang. Der vollständig qualifizierte Dateiname muss kürzer als 260 Zeichen und der Pfadname kürzer als 248 Zeichen sein.,    bei System.IO.Path.SafeSetStackPointerValue(Char* buffer, Int32 index, Char value)
    2.   bei System.IO.Path.NormalizePathFast(String path, Boolean fullCheck)
    3.   bei System.IO.Path.NormalizePath(String path, Boolean fullCheck)
    4.   bei System.IO.Path.GetFullPathInternal(String path)
    5.   bei System.IO.FileInfo..ctor(String fileName)
    6.   bei Grabber.GrabUtil.CopyFanartToFanartFolder(String fanartfile, String artFolder, String title, Boolean first)
    7.   bei AMCUpdater.AntRecord.ProcessFile(ProcessModeNames ProcessMode)
     
    Last edited: November 4, 2012
  10. Guzzi
    • Team MediaPortal

    Guzzi Retired Team Member

    Joined:
    August 20, 2007
    Messages:
    2,161
    Likes Received:
    704
    Ratings:
    +922 / 0
    Es wäre am besten, wenn Probleme und Fehler im MyFilms Support Forum gepostet werden.
    Fehler dann bitte immer mit Beschreibung und vor allem vollständigen Logs - siehe Support.
    Ohne ist es "Stochern im Dunken" - und ich würde gerne ggf. auftretende Fehler und Bugs noch für die nächste Version beheben.
     
  11. creativ

    creativ Portal Pro

    Joined:
    May 12, 2011
    Messages:
    65
    Likes Received:
    4
    Ratings:
    +4 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Ich brauch mal Hilfe,

    ich habe mir My Films mal installiert und habe folgendes Problem.

    Ich bearbeite jeden Film mit Ember Media Manager und habe für jeden Film einen Ordner mit der .nfo. Als cover habe ich im Ordner eine cover.jpg und als Hintergrundbild habe ich in jedem Ordner eine backdrop.jpg

    Meine Filme liegen auf einem NAS in folgender Ordnerstrucktur: \\NAS\Filme (und dann für jeden Film einen Unterordner).
    Wie gebe ich das ein das er alle Filme aus den Unterordner einliesst? Wenn ich im Grabber \\NAS\Filme\ eingebe passiert da nichts. Wenn ich dann einen Unterordner noch auswähle wo ein Film drin ist, dann läd er die .nfo aber nur für diesen einen Film.

    die cover.jpg und backdrop.jpg für den Film läd er aber nicht. Wo kann ich das eigeben das er diese läd?

    DANKE!
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!