[WiP] - madVR support in MP1 | Page 413

Discussion in 'Area 51 - Testing Area' started by Sebastiii, March 20, 2016.

  1. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,182 / 9
    Home Country:
    France France
    Show System Specs
    Ok tested and not MP EVR handle the video differently than EVR in MPC-HC. So Auto3D just scale the current video.
    Will try to see if we can move the subtitle based on aspect ratio change :p


     
    • Thank You! Thank You! x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Kotik
    • Premium Supporter

    Kotik MP Donator

    Joined:
    March 19, 2009
    Messages:
    699
    Likes Received:
    337
    Gender:
    Male
    Location:
    Athens
    Ratings:
    +555 / 2
    Home Country:
    Greece Greece
    Show System Specs
    I agree it should revert to the most stable. Can we cgange the warning text to something like that : XySubFilter is supported only under madVR, please select a different subtitle engine.

    I know, i know..... small details but .......

    Sent from my GT-I9205 using Tapatalk
     
    • Thank You! Thank You! x 2
  4. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,182 / 9
    Home Country:
    France France
    Show System Specs
    For both warning ? :)
    Sure it can be changed :p
     
  5. daWooky
    • Premium Supporter

    daWooky MP Donator

    Joined:
    April 3, 2012
    Messages:
    770
    Likes Received:
    393
    Gender:
    Male
    Ratings:
    +920 / 0
    Home Country:
    Germany Germany
    anyway, minor issue:LOL: warning works(y)
     
    • Like Like x 1
  6. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,182 / 9
    Home Country:
    France France
    Show System Specs
    Changed the text and put by default "MPC-HC engine" :p
     
    • Thank You! Thank You! x 1
  7. daWooky
    • Premium Supporter

    daWooky MP Donator

    Joined:
    April 3, 2012
    Messages:
    770
    Likes Received:
    393
    Gender:
    Male
    Ratings:
    +920 / 0
    Home Country:
    Germany Germany
    retried with that startrek tab file a bit
    mphc:
    Screenshot (433).png Screenshot (434).png Screenshot (393).png
    mepo:
    madvr normal and stretched if auto3d-2d converted :sick:
    madVR - 18-16-56.jpg madVR - 18-17-07.jpg
    maybe it was once 16:9 before tmpeg did a 4:3 3d transition:LOL:, and just encoded it with a wrong 1,2+ aspect ratio 1920x1600 :ROFLMAO:
    but works with evr:
    19-28-29.png 19-28-49.png

    tbh. i gave up on that strange file ^^ and btw. the subs dont match the german soundtrack

    but i compared madvr auto3d with some other samples again;) (switched auto3d manually:p)
    madVR - 18-17-55.jpg madVR - 18-18-05.jpg madVR - 18-19-35.jpg madVR - 18-19-47.jpg
    only the problem with wrong auto detection remained
    sbs as tab:p
    madVR - 19-01-47.jpg
    still always the first detection that decides whether auto3d switches to sbs or tab at the next file following ones..;)
    and all seems very well so far with normal usage :p:p:p:LOL:
     
    • Thank You! Thank You! x 1
  8. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,182 / 9
    Home Country:
    France France
    Show System Specs
    Yep, i think i have quite fixed the subtitle position (position relative to video frame MPC-HC engine option) only happen when doing 3D to 2D (SBS or TAB) :p
    I did try again the detection and i didn't get the same as you, it fully detect SBS or TAB.
    Sometimes it didn't detect at all because the Auto3D start detection while video is not fully displayed.

    I did have this option : (delay playback)

    Also can you try my madVR.ax version just to be sure it does the same as me ? :p

    upload_2017-10-7_19-58-43.png

    Ps : about the subs, yes they comes from Stargate Atlantis, i used it for just displaying subs lol
     
    Last edited: October 8, 2017
    • Thank You! Thank You! x 1
  9. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,182 / 9
    Home Country:
    France France
    Show System Specs
    This sample is detected as TAB : bbb_sunflower_2160p_30fps_stereo_abl.mp4
    And in fact , i was able to reproduce your issue (i think).

    Imagine, i start a movie TAB and Auto3d detect the TAB.
    If i start another movie (SBS) but the detection didn't work somehow, here it stay on the previous detected mod (TAB).
    But if the detection is OK, it switch correctly to SBS.

    Will try to see if i can delay the detection for madVR :p (just sure how but i have an idea).
     
    • Thank You! Thank You! x 1
  10. daWooky
    • Premium Supporter

    daWooky MP Donator

    Joined:
    April 3, 2012
    Messages:
    770
    Likes Received:
    393
    Gender:
    Male
    Ratings:
    +920 / 0
    Home Country:
    Germany Germany
    nice:ROFLMAO: that explains a lot
     
    • Funny Funny x 1
  11. daWooky
    • Premium Supporter

    daWooky MP Donator

    Joined:
    April 3, 2012
    Messages:
    770
    Likes Received:
    393
    Gender:
    Male
    Ratings:
    +920 / 0
    Home Country:
    Germany Germany
    yap thats like it happens to me too

    see capture ;)
     

    Attached Files:

    Last edited: October 7, 2017
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!