Massive memory leak (1 Viewer)

Stéphane Lenclud

Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Germany Germany
    Country flag
    Hi guys,

    It seems we have a massive memory leak in the latest StreamedMP running on top of 1.8.
    I believe it managed to use up all my 16GB of system memory until is crashed MP. It did that a couple of times.
    As result either MP crashes or the UI is all black and broken, fan arts and background images are not loading anymore.
    Restarting MP fixes the issue until your RAM is full again.

    I did monitor MP RAM usage for a few minutes and it's pretty obvious that StreamedMP is leaking. On start-up it uses ~250MB after ~10mn it was around 350MB.

    Titan skin has no such problem. It remains at around 150MB.

    During monitoring I did not actually used MP so it remained on the Home Screen.

    Could it be a fan art issue?
    Anyone else seeing this? I think its a regression cause I do not remember getting those issues in the last two years :)

    Cheers,
    S.
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,698
    7,083
    Sydney
    Australia Australia
    Country flag
    Skins don't leak memory, MediaPortal's skin engine possibly is though.

    Each skin might use different features of MediaPortal, at the end of the day it's MediaPortal's job to behave correctly. No doubt you have a leak or something related but you need to raise this with the MP team.

    StreamedMP does not use any code to change artwork or navigate on BasicHome...the only thing that would be driven from code would be the latest media handling for TVSeries and MovingPictures.I highly doubt there is a memory leak of that magnitude related to that though.

    Try disable all plugins except for StreamedMP config.
     

    Gcarr

    MP Donator
  • Premium Supporter
  • August 17, 2014
    95
    21
    United States of America United States of America
    Country flag
    Stéphane, did you ever figure out what was causing this? I seem to be having this issue also. Over a GB of memory usage after about 45 minutes.
     

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Germany Germany
    Country flag
    No I did not investigate that any further. I'm not even sure I can still reproduce the issue. I've recently switched to Windows 10 doing a clean install following a disk crash.

    However since I noticed this issue I did get into the habit of closing MP when I'm not using it. That worked arround the issue well enough for me since you usually don't watch TV more than 3 hours at a time :)
     

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Germany Germany
    Country flag
    I just checked the memory usage of my MP 1.12 client with StreamedMP running and playing TV for like 6 hour on Windows 10 v1511.
    No memory leak there, it uses between 90MB and 110MB.
     

    Gcarr

    MP Donator
  • Premium Supporter
  • August 17, 2014
    95
    21
    United States of America United States of America
    Country flag
    I guess my problem was slightly different than yours, I never see any problem with TV. It only seems to appear when I play music and keep the Now Playing screen up. And even then, only with certain skins (two of 4 that I tested). I brought it up in the Mediaportal Support forum, hopefully someone can shed some light on it there cos I really like this skin :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    C How well can MediaPortal handle 10,000+ recordings? MediaPortal 1 Talk 3
    Similar threads

    Top Bottom