MediaPortal Audio renderer - better video playback quality (2 Viewers)

edterbak
Country flag

Test Group
  • Team MediaPortal
  • March 4, 2008
    2,114
    1,176
    Home Country
    Netherlands Netherlands
    Edit: Actually don't panic - I've spotted something...
    Davidf's spotting results can be found in the attached binary. All Xonar users please test how it behaves. It has relaxed clock handling so it wont detect driver bugs for other HW (but backward jumping clock shouldn't even exist based on MSDN documentation :))

    So, Xonar owners please download and test (others don't need to bother with the download).
    Hi Tourettes,

    I downloaded it, I have time to test this tonight. Obliged birthdays :(
     

    red5goahead

    MP Donator
  • Premium Supporter
  • November 24, 2007
    695
    144
    Italy, North West
    Home Country
    Italy Italy
    Edit: Actually don't panic - I've spotted something...
    Davidf's spotting results can be found in the attached binary. All Xonar users please test how it behaves. It has relaxed clock handling so it wont detect driver bugs for other HW (but backward jumping clock shouldn't even exist based on MSDN documentation :))

    So, Xonar owners please download and test (others don't need to bother with the download).
    Probably then best version ever builded for Xonar. :D

    No synch problem at all. 14 minutes only but should be enough.

    HWBasedRefClock=1 WASAPIUseEventMode=0 (off course)

    edit: 42 minutes standard tvseries lenght . result: perfect
     

    edterbak
    Country flag

    Test Group
  • Team MediaPortal
  • March 4, 2008
    2,114
    1,176
    Home Country
    Netherlands Netherlands

    red5goahead

    MP Donator
  • Premium Supporter
  • November 24, 2007
    695
    144
    Italy, North West
    Home Country
    Italy Italy
    I have to agree with red5 :) Most perfect one till now :eek:
    Tested HWBaseRefclock 1 and eventdrivenmode 1
    new log attached
    Very good, but are you sure about eventdrivenmode = 1 because event driven mode here continue not working . Should be the other oddity problem of Xonar driver and shouldn't be involved by this version. Actually it shouldn't be possible to fix.

    Anyway I guess this Xonars border-line case was important to improve the renderer.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    I have to agree with red5 :) Most perfect one till now :eek:
    Tested HWBaseRefclock 1 and eventdrivenmode 1
    new log attached
    Very good, but are you sure about eventdrivenmode = 1 because event driven mode here continue not working . Should be the other oddity problem of Xonar driver and shouldn't be involved by this version. Actually it shouldn't be possible to fix.
    14-11-2010 09:52:31.820 [ 1134] WASAPIUseEventMode: 1

    Dont ask me why it works - maybe a driver update has fixed that?

    Anyway I guess this Xonars border-line case was important to improve the renderer.
    Actually it makes the other possible (unknown) driver bugs now more severe since audio renderer cannot detect those anymore - lets just hope that there aren't other buggy drivers that comes to the audio clock implementation :)
     

    red5goahead

    MP Donator
  • Premium Supporter
  • November 24, 2007
    695
    144
    Italy, North West
    Home Country
    Italy Italy
    I have to agree with red5 :) Most perfect one till now :eek:
    Tested HWBaseRefclock 1 and eventdrivenmode 1
    new log attached
    Very good, but are you sure about eventdrivenmode = 1 because event driven mode here continue not working . Should be the other oddity problem of Xonar driver and shouldn't be involved by this version. Actually it shouldn't be possible to fix.
    14-11-2010 09:52:31.820 [ 1134] WASAPIUseEventMode: 1

    Dont ask me why it works - maybe a driver update has fixed that?
    My english is not good for sure but I said that even driven mode is still NOT working for me. I have to disable it as usual.
    I asked to edterbak to recheck and confirm.
     

    edterbak
    Country flag

    Test Group
  • Team MediaPortal
  • March 4, 2008
    2,114
    1,176
    Home Country
    Netherlands Netherlands
    :D

    using driver .1792 brainbit 1.20 with asio + dpc latency patch. dont know if the latter makes a difference though.

    tourettes quoted some line from my log... confirmed it is using event driven mode.

    (edit)
    errrr how does one test if event driven mode is working?
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    My english is not good for sure but I said that even driven mode is still NOT working for me. I have to disable it as usual.
    I asked to edterbak to recheck and confirm.
    Yes, I did understood the issue - but it seems to work for edterbak, so maybe there is something fixed on driver side.

    edterbak, could you check with the Microsoft exclusive mode sample application if it works with that as well? Just to be sure.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom