MediaPortal SVN-Snapshot:-02-06-2010 13-59h - Revision:24975.rar (2 Viewers)

Status
Not open for further replies.

xvffx

Portal Pro
August 15, 2007
313
53
Home Country
Canada Canada
Re: MediaPortal SVN-Snapshot:-02-06-2010 13-59h - Revision:24975.rar

Hi all,

here's a few logs from a clean install with no codec installed (Win7 64 bit)

when using the builtin MS codec it crashes MP (only a few movies does this)
from both backup and using the original DVD from drive.

changed to a MPC codec.. all is fine.

Vff
 

Attachments

  • MS Codec crash-rip DVD.zip
    30.7 KB
  • MPC Codec-stable rip DVD.zip
    30.7 KB
  • MS Codec-from Drive DVD crash.zip
    30.7 KB

tourettes

Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Re: MediaPortal SVN-Snapshot:-02-06-2010 13-59h - Revision:24975.rar

    Hi all,

    here's a few logs from a clean install with no codec installed (Win7 64 bit)

    when using the builtin MS codec it crashes MP (only a few movies does this)
    from both backup and using the original DVD from drive.

    changed to a MPC codec.. all is fine.

    Vff

    Please test attached DLL.
     

    xvffx

    Portal Pro
    August 15, 2007
    313
    53
    Home Country
    Canada Canada
    Re: MediaPortal SVN-Snapshot:-02-06-2010 13-59h - Revision:24975.rar

    Hi all,

    here's a few logs from a clean install with no codec installed (Win7 64 bit)

    when using the builtin MS codec it crashes MP (only a few movies does this)
    from both backup and using the original DVD from drive.

    changed to a MPC codec.. all is fine.

    Vff

    Please test attached DLL.

    Hi Tourettes,

    I've tested this and still having issues.. I was able to find out a little more tho.

    1: with this file.. I was able to view the DVD (only from resume from where it left off)
    2: it crashes when trying to go to the DVD menu (only from this trouble movie)
    3: If I remember correctly... going to the non-trouble DVD's menu is ok.. then after viewing from troubled-dvd (resume) then to go back to the non-troubled dvd's menu.. it crashes

    I was able to reproduce this

    Vff
     

    Zinu

    Portal Pro
    February 28, 2008
    650
    23
    Home Country
    Netherlands Netherlands

    joz

    Portal Pro
    March 17, 2008
    1,353
    306
    Home Country
    Netherlands Netherlands
    Re: MediaPortal SVN-Snapshot:-02-06-2010 13-59h - Revision:24975.rar

    With this SVN MP simply eats memory when custom backdrops are selected.
    Also look at this: Issue 231 - streamedmp - Fanart Handler option in Basichome eating memory - Project Hosting on Google Code

    I can confirm this myself as well. With this SVN, memory usage spikes as high as 800.000. With the previous SVN 24923 it's performing normal.

    Had the same experience,downgraded to svn of 31st of jan and all was fine again
     

    doveman

    Portal Pro
    February 12, 2008
    2,326
    178
    Home Country
    United Kingdom United Kingdom
    Re: MediaPortal SVN-Snapshot:-02-06-2010 13-59h - Revision:24975.rar

    Just some more logs relating to the same bugs I reported earlier, where after watching an avi, MP's GUI is all messed up and I have to restart it. I also tried playing Live TV and that wasn't displaying properly either. This was from a cold boot and playing the avi was the first thing I did.

    The avi also got stuck and repeated the same section several times for about 1 second. The avi was on a different PC to MP, so was playing over the network, although I've seen this problem playing Recorded TV files which are on the same PC as MP.
     

    technick

    Portal Pro
    May 6, 2009
    566
    155
    Home Country
    France France
    Re: MediaPortal SVN-Snapshot:-02-06-2010 13-59h - Revision:24975.rar

    Remark/Bug : If you use EPG grabbing while timeshifting/recording and set the timout to zero you have a "unknow error" when you look TV

    2010-02-17 18:27:55.629400 [(15)]: Exception :confused:ystem.ArgumentException: '0' is not a valid value for 'Interval'. 'Interval' must be greater than 0.
    (Tested on this Beta and on the actual SVN 25055 - this error text)
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Re: MediaPortal SVN-Snapshot:-02-06-2010 13-59h - Revision:24975.rar

    1: with this file.. I was able to view the DVD (only from resume from where it left off)
    2: it crashes when trying to go to the DVD menu (only from this trouble movie)
    3: If I remember correctly... going to the non-trouble DVD's menu is ok.. then after viewing from troubled-dvd (resume) then to go back to the non-troubled dvd's menu.. it crashes

    I was able to reproduce this

    Vff


    17-02-2010 11:02:13.713 [734]MyQueue: No more space
    17-02-2010 11:02:13.716 [734]MyQueue: No more space
    17-02-2010 11:02:13.718 [734]MyQueue: No more space

    For some reason MS codec seems to cause EVR renderer to buffer huge amount of frames. Not sure if this is the reason for crash (most likely). Hopefully you can rip the DVD menus from that specific disk so that those are small enough to be uploaded somewhere. That way I could try to reproduce / debug the issue (with logs only it is helpless).
     

    jameson_uk

    Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    Home Country
    United Kingdom United Kingdom
    Re: MediaPortal SVN-Snapshot:-02-06-2010 13-59h - Revision:24975.rar

    With this SVN MP simply eats memory when custom backdrops are selected.
    Also look at this: Issue 231 - streamedmp - Fanart Handler option in Basichome eating memory - Project Hosting on Google Code

    I can confirm this myself as well. With this SVN, memory usage spikes as high as 800.000. With the previous SVN 24923 it's performing normal.

    Think the issue is aready fixed for RC1
    0002686: TextureManager: CleanupThumbs issues - MediaPortal Bugtracker
     

    chemelli

    Retired Team Member
  • Premium Supporter
  • September 28, 2006
    6,159
    2,264
    50
    Milano, Italy
    Home Country
    Italy Italy
    Re: Revision:24975 Hebrew problems

    I found some problem with Hebrew under V1.1
    On the TV schedule screen the day of the week in the upper left corner is not showing (see attached image).
    If I change the text of the short day in "strings_he.xml" (id 657-663) to English text then the day will appear.
    While playing TV or Video the skip steps do not appear. Nothing is shown, not the units ("sec", "min" etc) and not the numeric quantity (5,10 etc).
    Only after changing "strings_he.xml" id 2997-2999 to English the step will appear.
    Bob

    Hi, Bob!
    1) Open Your strings_he.xml by notepad,
    2) Change characters="1456" to characters="1524"
    3) Save as Unicode.
    4) (optional) Clean skin cache.
    5) If it helps You - post fixed file to the Submit: Localization of MediaPortal and DeployTool - MediaPortal Forum

    Change commited to MPLanguageTool. :D

    Simone
     
    Status
    Not open for further replies.

    Users who are viewing this thread

    Top Bottom