MediaPortal SVN-Snapshot:-07-25-2008 22-31h - Revision:19778.rar (2 Viewers)

seco

Development Group
  • Team MediaPortal
  • August 7, 2007
    1,580
    1,236
    Finland Finland
    Country flag
    Hi, TVService doesn't work correctly after bring suspended overnight. The system is scheduled to begin recording at 6:25am and powers on. Errors are recorded in the attached logs. This could be related to the other posts in this thread regarding the TVService not running after a suspend.

    Thanks from NZ :D
    1. Can you watch live TV after wake up from suspend?

    2. Do you have "Re-initialize TV service after wake up" (or something like that) enabled in TV Server Powerscheduler settings?
     

    nschoot

    Portal Pro
    July 29, 2007
    70
    0
    1. Can you watch live TV after wake up from suspend?
    2. Do you have "Re-initialize TV service after wake up" (or something like that) enabled in TV Server Powerscheduler settings?
    I can answer this (I have the same problem... see a few posts above - including logs).
    1. No. Even watching using the TV-Server config tool (preview) does not work
    2. I have that enabled. Without it MP just won't work at all.
    - Previous builds worked correctly.
     

    seco

    Development Group
  • Team MediaPortal
  • August 7, 2007
    1,580
    1,236
    Finland Finland
    Country flag
    1. Can you watch live TV after wake up from suspend?
    2. Do you have "Re-initialize TV service after wake up" (or something like that) enabled in TV Server Powerscheduler settings?
    I can answer this (I have the same problem... see a few posts above - including logs).
    1. No. Even watching using the TV-Server config tool (preview) does not work
    2. I have that enabled. Without it MP just won't work at all.
    - Previous builds worked correctly.
    Well, according to Bavarian the "Re-initialize TV Server" option has some problems when enabled:

    See https://forum.team-mediaportal.com/...eduler-synchronization-concurrency-bug-42094/ (post #9 is my working settings & test run)

    EDIT: I'm not using RC2 at the moment so it's possible that your problems are only RC2 related. The link I posted is about RC1 SVN (see my system specs for revision) and I'm using Powerscheduler.dll that Bavarian posted there.
     

    gibman

    Retired Team Member
  • Premium Supporter
  • October 4, 2006
    2,998
    1,372
    Aarhus
    Denmark Denmark
    Country flag
    Its a bug indeed, thanks for reporting it.

    Fixed-
    0001500: CAM limits ignored when 2 consecutive recordings on same transponder are running. - MediaPortal Bugtracker

    /gibman

    I have set CAM-Limits to 1 (default) on my tv-server configuration.

    This seems not to work: When I have a recording going and then start timeshifting (or recording) on the same transponder, then the same DVB-S card is reused and the first recording changes to scrambled=yes. The second recording is starting ok.

    I upload a log where I did the following:

    SF1 and SF2 are 2 channels on the same transponder. I have 2 DVB-S cards. SF1 and SF2 are mapped to both cards and both channels are scrambeled.

    - tune media portal to SF1 (ok)
    - start recording this channel (ok, scrambled=no)
    - tune media portal to SF2 (ok, but the recording session of SF1 changes status to scrambled, the recording is not usable).

    Did I do something wrong, or is this a bug?

    Thanks
     

    iosub

    Portal Pro
    April 26, 2006
    573
    30
    San Sebastian
    Hi
    Running on Vista Sp1 Ultimate

    I'm having problems with DVD-Play and AC3Filter as AudioCodec (With Ms Audio Codec works), I have found the solution and is to remove from "mediaportal.xml" the audio codec " <entry name="audiocodec">AC3Filter</entry>"

    Then MP does not find a AudioCodec on the mediaportal.xml so it gets the AudioCodec from the registry... And Works..(getting AC3Filter) as the codec..

    I have attach both logs, setting Ac3Filter as codec and removing the Audio codec from Mediaportal.xml, I have also add the graph

    Thanks
     

    ovld_nz

    Portal Member
    July 28, 2008
    5
    0
    New Zealand New Zealand
    Hi, TVService doesn't work correctly after bring suspended overnight. The system is scheduled to begin recording at 6:25am and powers on. Errors are recorded in the attached logs. This could be related to the other posts in this thread regarding the TVService not running after a suspend.

    Thanks from NZ :D
    1. Can you watch live TV after wake up from suspend?

    2. Do you have "Re-initialize TV service after wake up" (or something like that) enabled in TV Server Powerscheduler settings?

    1. No live TV doesn't work

    2. "Re-initialie TV service after wake up" isn't checked. If I do I still get same result. With this set if I suspend for any length of time it doesn't work on restart.

    If I suspend for say 5 minutes without "Re-init" checked everything comes back fine without issue. But overnight it doesn't work (7-8 hours).
     

    romadd64

    MP Donator
  • Premium Supporter
  • October 24, 2007
    82
    15
    Italy Italy
    Hi!

    Yes, it is intentional.
    ...
    Also, the reason why a timeshifting user has faster access to the mini EPG is simply because those cached channel states are now located on the user object on the server.

    When u r not timeshifting, then the server does not know about you - (thus no user object) in other words it has to do a non-cached/slow channel states query on the fly.

    OK. Good work, Gibman.

    romadd
     

    kkendall

    Portal Pro
    April 24, 2007
    864
    16
    40
    Gouda
    Netherlands Netherlands
    Hi..

    can anyone explain what is "There is now added an option for TV-Server to preload graph for tuners."??
    Benefictes?

    Thanks!
    I checked this option - after starting Mediaportal the tuning time for the first channel remained the same (about 10-15 seconds).
    OK, but can anyone explain what this function actually does? How does this work? I mean, different graphs are needed for different channels because different channels need different codecs (mpeg2/h264/AC3/etc), right? It is not possible to know what channel you are going to tune to, so how can the graph than be preloaded?

    I never had the problem of the first tuned channel being slow. But that might be because I have only one pc with mp/tvserver.

    Sometimes the sound is missing though on my SD channels. Sometimes, when I change from one SD channel to another, I lose the audio. If I'm timeshifting, sometimes rewinding some seconds to the previous channel (where the audio still was there) helps and the sound returns also for the channel where it was gone, so the audio must also be in the timeshift buffer... :confused:
    What always works is when I change to a HD channel and back, the sound also returns.
    This happens every day at some point, but never very predictable...
    Any suggestions?
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    OK, but can anyone explain what this function actually does? How does this work? I mean, different graphs are needed for different channels because different channels need different codecs (mpeg2/h264/AC3/etc), right? It is not possible to know what channel you are going to tune to, so how can the graph than be preloaded?
    There are two directshow graphs running when you are using TVE3. 1st one is running in the service process and it handles the BDA driver side + writing data to the HD. 2nd graph is inside MediaPortal process and that handles the .ts file / TS buffer playback.

    The 1st graph doesnt need to know anything about the video and audio formats that its recording, therefore that graph canbe preloaded. Also the 1st one is usualy much slower graph to build.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    OP Similar threads Forum Replies Date
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 41
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Rob Hexenmeister Mediaportal Properties #plot etc... General Support 3
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    S [solved] access the desktop without leaving mediaportal General Support 5
    J New computer with win10 and how will i set Mediaportal up ? Newcomers Forum 55
    T MediaPortal Extensions Manager Fehlermeldung bei Installation einer Erweiterung Installationsprobleme? 1
    geotwticher TV Guide EPG Grabber for Australia 2020 RIP freepg.tv General 4
    azzuro [News] MediaPortal 1.24 Pre-Release ready for testing! News and Announcements 0
    Similar threads

























    Top Bottom