MediaPortal SVN-Snapshot:-08-09-2008 09-21h - Revision:19876.rar (1 Viewer)

grubi

Portal Pro
June 16, 2007
1,216
80
127.0.0.1
Germany Germany
Please, can somebody confirm to have this problem also ?

Watching a channel in client - in MyTV; click on "Record Now"; after a while, stop recording by click on "Stop Record".
After this, channel change no more possible; the "Unable to start timeshifting, No free card available" message showed.

In TvServer Config / Manual Control I can see that two TimeShifts of this channel are in progress - one for watching (user: pcname - ok) and other for recording (user: schedulerXX - this should be stopped - but it isn't)... After stopping these by clicks on "Stop TimeShift", MyTV in client is working normally again - as before the manual recording...

Thx
Hi zdney.

To help you with this problem it is essential that you post logs. Also it would be very helpful if you enter your system specs in your profile and make it visible to the community. Further details can me found on the first post of this thread.

Thanks.

grubi.
 

zdeny

Portal Member
May 29, 2008
5
6
Country flag
Hi grubbi,
I just wanted to know if it is my system/tvcard specific problem or if it is more general problem... If it happens only to me, we can let it be for now...
Meanwhile, I went back to "good old" MP inbuild TV-Plugin; I'm using an analog tvcard with sw encoding (with Intervideo encoder) - and I discover that there is no way with this card to get better picture resolution than 320x240 in new MP client-server architecture...

Thank you for effort...

zdeny
 

grubi

Portal Pro
June 16, 2007
1,216
80
127.0.0.1
Germany Germany
Hi grubbi,
I just wanted to know if it is my system/tvcard specific problem or if it is more general problem... If it happens only to me, we can let it be for now...
It did not happen with my system however there are so many factors that it would be speculation to say that it is not a more general problem. Logs would make things easier.

grubi.
 

pilotedge

Portal Pro
February 19, 2008
50
1
United Kingdom United Kingdom
Hi,

I cannot stop recording TV if I start a manual record.... I have attached my mediaportal log as looking at the TVServer log it doesnt seem to be getting a command to stop the recording....
INcidently the record button in Manual Control is permanently greyed out so I cant try it that way, but through MP I can start the recording OK but when I hit stop nothing happens.... there is definately an Error in the MediaPortal.log, but I don't know what it means!!
THanks
James
 

Gixxer

Retired Team Member
  • Premium Supporter
  • August 18, 2007
    1,383
    41
    36
    Spain
    Spain Spain
    please can someone have a look at this log, its not long, and tell me why tvservice is not starting, not even when i run tvserver configuration.

    as i mention before in this post, sometimes tvservice starts perfectly but others its just impossible.

    this is with this SVN.

    thanks
     

    Pe2RM

    Portal Member
    October 26, 2007
    29
    3
    Netherlands Netherlands
    Please, can somebody confirm to have this problem also ?

    Watching a channel in client - in MyTV; click on "Record Now"; after a while, stop recording by click on "Stop Record".
    After this, channel change no more possible; the "Unable to start timeshifting, No free card available" message showed.

    In TvServer Config / Manual Control I can see that two TimeShifts of this channel are in progress - one for watching (user: pcname - ok) and other for recording (user: schedulerXX - this should be stopped - but it isn't)... After stopping these by clicks on "Stop TimeShift", MyTV in client is working normally again - as before the manual recording...

    Thx
    Zdeny, your not the only one, see Active timeshift with closed TV - MediaPortal Forum

    The good news is that one of the devs is working on it. 0001482: Not possible to stop recording/timeshift in some circomstances - MediaPortal Bugtracker
     

    Jeditrav

    Portal Pro
    May 17, 2007
    319
    20
    New Zealand New Zealand
    Hi Chemelli,

    tried it now and the result was simple... Mediaportal started :) But how can I manage now that it does when it's coming from Hibernate? Sorry if that sounds strange but I'm not a developer, so sometimes I need a kickin to find out what a solution for a problem could be ;) If there is one for this behaviour I can do myself?
    Somehow the script seems to behave differently when PC wakes up from S3. I was able to reproduce the bug on my HTPC also. Could you test following, seems to work on my HTPC:

    replace the "taskkill..." line in restart.vbs with "shell.Run "tskill Mediaportal", 0, true"

    Hi tourettes,

    tried and... wow :) It works! Mediaportal is starting up again after Hibernation.


    :D a lot :D

    Hi,

    replacing the line restart.vbs worked for me:D, but now when I go into myTV, after waking from hibernation, I get an 'Unable to start timeshifting - unknown error occured' window, and no TV until I restart the computer.:confused:
     

    neilk

    Portal Pro
    June 22, 2007
    76
    4
    South Africa South Africa
    Hi Chemelli,

    tried it now and the result was simple... Mediaportal started :) But how can I manage now that it does when it's coming from Hibernate? Sorry if that sounds strange but I'm not a developer, so sometimes I need a kickin to find out what a solution for a problem could be ;) If there is one for this behaviour I can do myself?
    Somehow the script seems to behave differently when PC wakes up from S3. I was able to reproduce the bug on my HTPC also. Could you test following, seems to work on my HTPC:

    replace the "taskkill..." line in restart.vbs with "shell.Run "tskill Mediaportal", 0, true"

    Hi tourettes,

    tried and... wow :) It works! Mediaportal is starting up again after Hibernation.


    :D a lot :D
    Hi Tourettes

    I tried this fix changing the restart.vbs, did not solve my resume from hibernate issue. I have disabled the "restart MediaPortal on resume" when testing this. Mediaportal is fine, but when I go into MyTV I get the following error: "cannot start timehifting, unknown error occurred", the scheduled recording also did not start and I have to reboot my system for it to start up the TV section again. I will attach logs tonight if needed...

    Thanks for your help thus far:D
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    I tried this fix changing the restart.vbs, did not solve my resume from hibernate issue. I have disabled the "restart MediaPortal on resume" when testing this. Mediaportal is fine, but when I go into MyTV I get the following error: "cannot start timehifting, unknown error occurred", the scheduled recording also did not start and I have to reboot my system for it to start up the TV section again. I will attach logs tonight if needed...

    Thanks for your help thus far:D
    Changes in the restart.vbs cannot ever have any effect on the tv service functionality. So the issue you are seeing is different one. Do you have

    Most likely the one in here (more closely the comment) 0001437: Network RTSP failure after return from stanby/hibernation. - MediaPortal Bugtracker

    In 19889 SVN the 'reinit service onwake-up' option breaks TVE3 even more severely. TVE3 is not able to start tv after resuming from S3.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 0
    A VideoDatabaseV5.db3 lock not released on shutting down PC from MediaPortal Installation, configuration support 0
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    M Add Radio channels and EPG to Mediaportal xmlTV 2
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    doskabouter Installing mediaportal MediaPortal 1 3
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 48
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Similar threads

























    Top Bottom