MediaPortal SVN-Snapshot:-08-09-2008 09-21h - Revision:19876.rar | Page 5

Discussion in 'untested MediaPortal and TV-Server 1.0 RC2 svn-bui' started by MediaPortal-Bot, August 9, 2008.

  1. xanadu1979

    xanadu1979 Portal Pro

    Joined:
    April 15, 2008
    Messages:
    80
    Likes Received:
    2
    Occupation:
    Software Developer
    Location:
    New Orleans, LA
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Is the change to restart.vbs going to be put into the codebase?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
  4. josch.hh
    • Premium Supporter

    josch.hh MP Donator

    Joined:
    March 29, 2008
    Messages:
    476
    Likes Received:
    71
    Occupation:
    Managing Engineer
    Location:
    Hamburg
    Ratings:
    +72 / 6
    Home Country:
    Germany Germany
    I have an alternative to the resume function, based on the work of lkuech.
    A little application to restart MP and TVServer. I know that lkuech did something like this before with his "PowerEventHandler", but i decided to create something that works without scripts or external applications like pskill.exe. So all you need is in the little exe attached to this post.

    Simply start the app and you will find an icon on the right side of the taskbar. Rightclick on it and choose "Configuration" to set it up. Very easy.

    I hope it helps someone here arround. :)
     

    Attached Files:

    • mpsh.png
      mpsh.png
      File size:
      293.4 KB
      Uploaded:
      August 12, 2008
      Views:
      165
    • Like Like x 1
  5. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    I would like to see a possibility to allow MP & TVE3 to be stopped only after resuming has been done. At least for MP as otherwise its creating no video signal on some systems. I have had two PCs / MBs that have had annoying issue when it comes to TVE3 automatically waking up the PC for recording. If MP is closed before the S3 state is enabled

    1) display drivers will disable the video output (unless MP is already running, something to do with DX)
    2) resume S3 even comes only after the user presses a key on keyboard

    as a result the display will stay black for remote control only users.
     
  6. stoked
    • Premium Supporter

    stoked MP Donator

    Joined:
    December 14, 2007
    Messages:
    297
    Likes Received:
    8
    Ratings:
    +8 / 0
    Home Country:
    Canada Canada
    Been having this problem lately, I don`t recall if I had it during the RC1 and svns, but definitely since RC2 and this SVN. Symptom is during channel changing, 35-40% of the time the channel will change but I will only hear the audio. The video will take anywhere from 10-20sec to show up and sometimes MP will timeout and crash. I can`t seem to find anything in the Tvserver logs that match the timing of the video showing up but the tsreader.log from my MP client shows the following:


    12-08-2008 13:05:20.156 [c94]Pes 0-0-1 fail
    12-08-2008 13:05:20.156 [c94]Pes 0-0-1 fail
    12-08-2008 13:05:20.156 [c94]Pes 0-0-1 fail
    12-08-2008 13:05:20.156 [c94]Pes 0-0-1 fail
    12-08-2008 13:05:20.156 [c94]Pes 0-0-1 fail
    12-08-2008 13:05:20.250 [94]Pes 0-0-1 fail
    12-08-2008 13:05:20.250 [94]Pes 0-0-1 fail
    12-08-2008 13:05:20.250 [94]Pes 0-0-1 fail
    12-08-2008 13:05:20.250 [94]Pes 0-0-1 fail
    12-08-2008 13:05:20.359 [c94]Pes 0-0-1 fail
    12-08-2008 13:05:20.359 [c94]Pes 0-0-1 fail
    12-08-2008 13:05:20.359 [c94]Pes 0-0-1 fail
    12-08-2008 13:05:20.453 [94]Pes 0-0-1 fail
    12-08-2008 13:05:20.453 [94]DeMultiplexer::FillVideoVideo pts jump found, flushing video : 29.712479 ed90ca0, ed90ca0
    12-08-2008 13:05:20.500 [c94]vid:set discontinuity
    12-08-2008 13:05:20.500 [c94]vid:set discontinuity

    Those Pes 0-0-1 fail errors repeat many many times from when I hear the audio until the video comes back at the DeMultiplexer line.

    PS. Should I put this in the bugreport forum instead?
     
  7. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    What audio codec you are using? If Cyberlink then try ffdshow.
     
  8. Hetfield

    Hetfield Portal Pro

    Joined:
    March 3, 2007
    Messages:
    69
    Likes Received:
    9
    Ratings:
    +9 / 0
    Home Country:
    Finland Finland
    restart.vbs

    Fix to "restart.vbs" seems to work. Anyway, I have only tried about 5 times to standby and resume. But so far everything seems to work OK. This kind of fix is REALLY important for daily usage. :D

    By the way, the last viewed channel is not saved when setting PC to standby manually from MediaPortal home screen menu selection "sleep". But this is minor issue as compared to stability problems after resume (which are hopefully now solved).
     
  9. stoked
    • Premium Supporter

    stoked MP Donator

    Joined:
    December 14, 2007
    Messages:
    297
    Likes Received:
    8
    Ratings:
    +8 / 0
    Home Country:
    Canada Canada
    Nope, Nvidia audio codec. I'll give the MPA codec a try, on my other client however, the MPA decoder would skip every 10sec or so. Thing is I get audio right away once the channel changed, it's the video that's lagging, I guess you're suspecting a video to audio synch issue.

    MPA because I have it installed, don't want to install ffdshow quite yet.


    Tried AC3filter and ffdshow, still same issue, no video while getting those errors in logs. With ffdshow I get audio, but once I bring up the guide, audio stops. I think it has to do with the MP sound mixed into the audio and it just stops. Back to Nvidia Audio decoders.
     
  10. xanadu1979

    xanadu1979 Portal Pro

    Joined:
    April 15, 2008
    Messages:
    80
    Likes Received:
    2
    Occupation:
    Software Developer
    Location:
    New Orleans, LA
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Regarding the restart after resume problem. I have Vista SP1 Home Premium and I don't seem to have "tskill" anywhere on my computer. If I put the line in restart.vbs it fails saying that the file could not be found. I googled it and found that it should be in my system32 folder but it isn't. Maybe this is something that only Vista Ultimate has?
     
  11. neilk

    neilk Portal Pro

    Joined:
    June 22, 2007
    Messages:
    76
    Likes Received:
    4
    Ratings:
    +4 / 0
    Home Country:
    South Africa South Africa
    Hi Tourettes

    I dont have any clients accessing my TV server, so this is not related. What I did find is in Powerscheduler plugin of TV Server if I disable "reinit TV Cards & TV Service on resume from suspend" under advanced settings, I dont get the error when entering MYTV, so I prosume there might be an issue with Powerscheduler for TVE3?

    Cheers

    Neil
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!