Memory Leak Tvservice (1 Viewer)

infinite.loop

Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Country flag
    Is this still an issue. I am using the RC1 version in a multi-seat situation and noticed my TvService memory usage was just over 1GB on my dedicated server, I thought nothing of it at the time. But, when I actually tried loading the clients they just hung on the "loading window plugins" bit. When I killed the TvService and ran the SetupTv (which restarts it), all was fine again. Also, nothing seemed to record for a while. I did use the radio very briefly a few days before this, so maybe it was that.

    I don't think I have any all channels recordings set up. What is the best way to check that? I've looked in the TV Schedules part of the Setup app and they all say Type=Always, Keep=All

    I'm going to be keeping an eye on the server for the time being.

    Regards.
    well......

    and without logs we should "guess" what the issue is? ;)
     

    sixgun

    MP Donator
  • Premium Supporter
  • March 31, 2008
    80
    12
    United Kingdom United Kingdom
    If I click "View log files" in the Setup app, all but the TsWriter log file are virtually empty. Is there a history of log files kept somewhere?

    Thanks.
     

    the_it_bloke

    Portal Member
    April 22, 2007
    9
    0
    55
    Personally i have not had the same issue since although the issue you describe sounds the same. I have upgraded a few times since 15155 and all has been fine.
    That said i just checked my win2k3 server system and the system its self is using about 1GB (out of 3GB) but the TVService.exe is running at 26MB with nothing much going on. I killed the TVService and it didnt much affect the overall RAM consumption - thats Windows for you!
    Also, SQL2k5 takes about 100MB more than MySQL out of the tin without any tweaking, again good old Microsoft!

    Looks like I am running quite an old engine - TVEngine3 V16134 8/10/07
    One thing i have learnt, if it works stick with it and dont upgrade versions for the sake of it :) Sometimes it can cause more problems tham it solves.

    Good luck!
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom