[fixed] Minidisplay plugin comes with not digitally signed driver hwinterfacex64.sys (2 Viewers)

ajs

Development Group
  • Team MediaPortal
  • February 29, 2008
    13,428
    7,957
    Kyiv
    Ukraine Ukraine
    Country flag
    Yes Mediaportal*zip

    -- Tapatalk | WBR, ajs
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,079
    106
    Switzerland Switzerland
    Country flag
    OK, but I haven't yet finished configuring my new 1.26 installation. Also, I would like to upgrde to v1.27 before installing a v1.28 development version. Please give me a few days.
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,079
    106
    Switzerland Switzerland
    Country flag
    OK, I now have a working v1.27 installation. Is it enough to install the develpoment version as an upgrade, or do I need to perform a clean installation?
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,079
    106
    Switzerland Switzerland
    Country flag
    @ajs, I have installed your test version over my working 1.27 installation, with the result that neither MP nor its configuration will start at all. I am attaching logs, but I fear they won't help much. MP reported no errors in the installation or configuration logs, but the configuration GUI never displays and MP doesn't even get around to creating a log. Event Manager shows errors like this one for MP:
    Faulting application name: MediaPortal.exe, version: 1.27.0.0, time stamp: 0x5ffd7e93
    Faulting module name: KERNELBASE.dll, version: 6.3.9600.19724, time stamp: 0x5ec50c3e
    Exception code: 0xe0434352
    and this one for MP config:
    Faulting application name: Configuration.exe, version: 1.27.0.0, time stamp: 0x5ffd7e8a
    Faulting module name: KERNEL32.dll, version: 6.3.9600.19843, time stamp: 0x5f603fd9
    Exception code: 0xc00000fd
    I will try reinstalling the test version as a fresh install and report back.
    It took me a lot of time to configure MP. Can I import a settings backup after installing, or will this screw things up?
     

    Attachments

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,079
    106
    Switzerland Switzerland
    Country flag
    After a fresh install (without restoring any settings) things seem to be working. I no longer get the unsigned driver error, but I am getting "Unable to load DLL 'C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\LCD2USB.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)" although the specified DLL is in fact present at the specified location. The situation was the same with the release version of 1.27. The display is not responding to a "Test" with the settings I last had working. New logs are attached. Now I will try restoring my previous settings.
     

    Attachments

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,079
    106
    Switzerland Switzerland
    Country flag
    After restoring most of my settings, things seem to work normally, except for the following:
    1. The LCD2USB.DLL error appears as long as MiniDisplay is enabled. The problem is an old one. According to this thread, LCD2USB.DLL depends on libusb0.dll, but I no longer find it at the download URL provided by @azzuro
      According to @BassFan, LCD2USB.DLL isn't even used in MP, but perhaps he missed a reference in the MiniDisplay plugin, since it isn't strictly speaking a part of MP.
    2. Probably an effect of 1 above, but the display (Futaba DM-140GINK) doesn't show anything but the computer name. It used to at least show the test message, MP function in use and the shutdown message.
    3. There is still a problem with MP not waiting long enough for TV Service to become available after reboot (see MediaPortal.log around 5 AM today). However, I will start another thread for this.
    Logs are attached.
     

    Attachments

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,079
    106
    Switzerland Switzerland
    Country flag
    I have found:
    • A download of libusb0 here
    • A version I downloaded in 2015, which appears to be identical
    I have copied the dll into the directory c:\Program Files (x86)\Team MediaPortal\MediaPortal\plugins\process\LCDDrivers\, which is where LCD2USB is, and hope that will be sufficient. More later
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,079
    106
    Switzerland Switzerland
    Country flag
    Adding libusb0.dll v1.2.6 got rid of the "file not found" error, but now I get "An attempt was made to load a program with an incorrect format." in Configuration.log for both LCD2USB and libusb0. Logs are attached.
     

    Attachments

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    S Mini Display MP 1.24 no Volume OSD no action for keys Mini Display 0
    I MiniDisplay Sonstige Hardware 2
    ajs MQTT Plugin MediaPortal 1 Plugins 11
    C Issue with plugin initialisation My TVSeries 7
    morpheus_xx [Finished] "What's New" plugin for MP2 upgrades MediaPortal 2 20
    da3dsoul [Request] An MVP Plugin example for custom settings in MP2 Plugin Development 2
    da3dsoul MP2 Plugin - Getting Started (Directory Tree and Player) Plugin Development 27
    M Installing Plugins Newcomers Forum 2
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 10
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 6
    E aktuelle englische Forums Webseite von - Showtime Plugin v3 Plugins & Erweiterungen 4
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    joecrow MultiShortcut Plugin (Uavailable) in DWHD skin General Support 58
    vapourEyes Building TV Plugin General Development (no feature request here!) 49
    Golf4 Nach Windows-Updates läuft TV-Plugin nicht mehr Allgemeines Support- und Diskussionsforum 0
    joecrow How about a Launcher plugin for MP1? MediaPortal 1 6
    D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
    framug Nouveau plugin XmlTvFR pour récupérer le guide télé français Kazer / ZguideTv (WebEPGfr) 31
    emphatic Allow remote control mapping of all plugins Improvement Suggestions 0
    D Where should plugins be located on hard drive? General Support 0
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    cbr954rr How to disable a pre-configured plugin? General 2
    mrmojo666 [Plugin]Marantz Control Plugin 0.0.0.2 MediaPortal 1 Plugins 4
    mrmojo666 beginner: trying to write a plugin, need help to catch event General Development (no feature request here!) 3
    framug [Rejected] Fix PowerScheduler plugin for MP2 single seat Submit: Code Patches 11

    Similar threads

    Top Bottom