.mkv subtitles default language (1 Viewer)

ChriZ

Portal Pro
March 22, 2008
125
3
Denmark Denmark
TV-Server Version: 1.0 RC3
MediaPortal Version: 1.0 RC3
MediaPortal Skin: Monochrome 2.2
Windows Version: Windows XP SP2
CPU Type: Athlon X2 3800+
HDD: 80 GB Samsung 2,5"
Memory: 2 GB
Motherboard: MSI K9AGM2-FIH
Video Card: ATI Xpress 1250
Video Card Driver: 8.332.0.0
Sound Card: on-board
Sound Card AC3: ATI HDMI audio
Sound Card Driver: 5.10.0.5368
1. TV Card: ASUS MyCinema-P7131 Hybrid
1. TV Card Type: DVB-T only
1. TV Card Driver: 13.3.5.3
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec:
MPEG2 Audio Codec:
h.264 Video Codec: ffdshow tryouts
Satelite/CableTV Provider:
HTPC Case:
Cooling:
Power Supply:
Remote: MCE Remote
TV: LG 32"
TV - HTPC Connection: HDMI

Since this issue hasn't been addressed yet, I'm starting a new thread for RC3...

It looks like there's a bug with the default subtitle track option in MP for .mkv's. MediaPortal always chooses the first track available, so the default tag is ignored, which is kind of a pain when watching a tv show and the default sub language is swahili ;))....

See this thread for further info:
https://forum.team-mediaportal.com/...btitles-default-not-working-43646/#post292828

Hope this is ok for a bug report, otherwise, let me know what more info is needed ;)

/Christian
 

ronilse

Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    This bug has nothing to do with TV-Server / Client, so moved to regular MP, to see if anyone has a answer.

    Regards
    Roy
     

    ChriZ

    Portal Pro
    March 22, 2008
    125
    3
    Denmark Denmark
    I've been trying to get a developer's attention regarding this issue about 3-4 times now in different bugreports and support-forums, but with no luck - is this a taboo, am I just being plain stupid for this not working for me or have I done something wrong in the bugreports?


    /Christian
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Well i dont have such problems, working perfectly for me.
    as far as i know, subtitles which come from anything else then a DVD, require to install "the correct vobsub filter".

    @hoborg maybe you could explain to the thread starter how you did it?

    not using subtitles here, so i dont know about the setup of external filters. :)
     

    ChriZ

    Portal Pro
    March 22, 2008
    125
    3
    Denmark Denmark
    OK.
    If somebody have subtitles trouble - try SAF.
    I'm not sure I fully understand what that filter pack is doing, but are you 100% sure that you're not handling subtitles outside of MediaPortal? Are you able to change subtitle language inside mediaportal?

    As my system is basically running perfect decoding everything, I'd rather keep my system as is and avoid filter/codec packs of any kind ;)

    /Christian
     

    hoborg

    Portal Pro
    June 13, 2008
    4,413
    1,644
    Nový Jičín
    Czech Republic Czech Republic
    OK.
    If somebody have subtitles trouble - try SAF.
    I'm not sure I fully understand what that filter pack is doing, but are you 100% sure that you're not handling subtitles outside of MediaPortal? Are you able to change subtitle language inside mediaportal?

    As my system is basically running perfect decoding everything, I'd rather keep my system as is and avoid filter/codec packs of any kind ;)

    /Christian
    Yes, it is not problem to chance MKV subtitles language "on-the-fly" inside MP.
     

    ChriZ

    Portal Pro
    March 22, 2008
    125
    3
    Denmark Denmark
    So.. what actually does SAF do that a normal Haali Media Splitter, VobSub, FLVsplitter, ffdshow, etc. installation doesn't? In other words - why do you think SAF will help me?

    /Christian
     

    hoborg

    Portal Pro
    June 13, 2008
    4,413
    1,644
    Nový Jičín
    Czech Republic Czech Republic
    So.. what actually does SAF do that a normal Haali Media Splitter, VobSub, FLVsplitter, ffdshow, etc. installation doesn't? In other words - why do you think SAF will help me?

    /Christian
    That is hard to say. I just want to help.
    SAF is working perfectly here, no problem with subtitles.
    But you have similar manual configuration, and it is realy wierd that it is not working for you...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    S [solved] No sound - MKV file MediaPortal 1 Talk 2
    Don_Ald MKV covers Помощь по MediaPortal 9
    B mkv vom NAS laufen zu schnell Video & DVD 0
    HTPCSourcer [solved] Sometimes persistent issues when playing specific h264 mkv files MediaPortal 2 18
    bta489 [solved] Stuttering playback of edited recordings watch/edit Videos 2
    Lehmden Tools and other software Media-Buddy - the MKV Buddy successor. Tools and other software 41
    D Some mkv files do not play General Support 1
    osre Audio issues with MKV Playback in MP2.1.3 General 5
    R How to launch Stereoscopic Player for 3D MKV OffTopic 4
    mickb Subtitles My TVSeries 4
    M.Hulot Blu-ray: Es werden nicht nur Forced Subtitles angezeigt Allgemeines Supportforum 1
    J How to change y position of subtitles General 2
    R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
    S Remote button to change audio and subtitle on / off General 10
    P [solved] ATSC subtitles not fixed yet? General 2
    E Swedish subtitles problem General 2
    ratata Someone stole my subtitles... General Support 0
    Dark Eyes Display subtitles on a separate display or device MediaPortal 1 Plugins 0
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    S Display non english folder name, subtitle, etc. General 23
    S [solved] Movie SRT subtitle didn't display on client 2.2 Archive 18
    S [solved] Live TV subtitle issue if not using 100% font General 31
    D [solved] How to configure subtitle color in MP 2.2.1? General 5
    S [fixed] [MP2-611] Teletext subtitles language selection 2.2 Archive 20
    Similar threads

























    Top Bottom