.mkv subtitles default language (1 Viewer)

jerbob92

Portal Pro
February 29, 2008
57
1
Renswoude
Netherlands Netherlands
I don't get any subs at all with MP, i have to use windows media player to watch mkv files, subs work there....

AND NO, i dont want to screw up my codecs, i use CCCP, and it works VERY good :)
 

ChriZ

Portal Pro
March 22, 2008
125
3
Denmark Denmark
So.. what actually does SAF do that a normal Haali Media Splitter, VobSub, FLVsplitter, ffdshow, etc. installation doesn't? In other words - why do you think SAF will help me?

/Christian
That is hard to say. I just want to help.
SAF is working perfectly here, no problem with subtitles.
But you have similar manual configuration, and it is realy wierd that it is not working for you...
Reading my post again I did sound like a bit of a prick, sorry mate ;) And I'm happy that you want to help, but I don't really want to toy around with too many codecs, filters, etc. in MediaPortal as I'm using MP as my main TV/DVD/Video player, and the girlfriend is a bit of a pain each and everytime I fiddle with something that used to work perfectly ;)

so I really need something specific to look at that I can get rid of easily again if it screws up something, and by experience I know filter/codec packs aren't easy to get rid of...

/Christian
 

hoborg

Portal Pro
June 13, 2008
4,413
1,644
Nový Jičín
Czech Republic Czech Republic
So.. what actually does SAF do that a normal Haali Media Splitter, VobSub, FLVsplitter, ffdshow, etc. installation doesn't? In other words - why do you think SAF will help me?

/Christian
That is hard to say. I just want to help.
SAF is working perfectly here, no problem with subtitles.
But you have similar manual configuration, and it is realy wierd that it is not working for you...
Reading my post again I did sound like a bit of a prick, sorry mate ;) And I'm happy that you want to help, but I don't really want to toy around with too many codecs, filters, etc. in MediaPortal as I'm using MP as my main TV/DVD/Video player, and the girlfriend is a bit of a pain each and everytime I fiddle with something that used to work perfectly ;)

so I really need something specific to look at that I can get rid of easily again if it screws up something, and by experience I know filter/codec packs aren't easy to get rid of...

/Christian
That's OK, i understand.
Can you use MKVmerge to split your problematic MKV and send me a small example? So i can try it here.
 

hoborg

Portal Pro
June 13, 2008
4,413
1,644
Nový Jičín
Czech Republic Czech Republic
Hello ChriZ.
I have good news for you and bad for me, becouse default language selection stops working for me too...
I am not sure why and when this happend, but this was working :(
I think this is realy a MP new version problem/bug.

I found, that in registry, there is an entry "HKEY_CURRENT_USER\Software\Gabest\VSFilter" PreferedLanguages - but it is empty, and in DirectVobSub, there is no way how to setup prefered language.

Second thing is, that MP subtitles setup (MKV files) have highter priority then DirectVobSub settings - i mean you need to setup subtitles color in MP, settings in DirectVobSub are ignored - maybe related?

Did you found a way how to fix it?
 

ChriZ

Portal Pro
March 22, 2008
125
3
Denmark Denmark
Hello ChriZ.
I have good news for you and bad for me, becouse default language selection stops working for me too...
I am not sure why and when this happend, but this was working :(
I think this is realy a MP new version problem/bug.

I found, that in registry, there is an entry "HKEY_CURRENT_USER\Software\Gabest\VSFilter" PreferedLanguages - but it is empty, and in DirectVobSub, there is no way how to setup prefered language.

Second thing is, that MP subtitles setup (MKV files) have highter priority then DirectVobSub settings - i mean you need to setup subtitles color in MP, settings in DirectVobSub are ignored - maybe related?

Did you found a way how to fix it?
No, this still doesn't work for me...
I haven't had time to create a sample mkv for you, sorry about that.. well, the good thing is that it's not only me now, it looks like you have more insight into how things are working with vsfilter, so maybe you can point the devs into the right direction?

/Christian
 

frenzy

Portal Pro
April 29, 2008
228
10
France France
Country flag
Ok I can't reproduce your problem so I'm guessing it's your configurations that are messed up. I muxed an .mkv with two subtitle tracks (first finnish and second english flagged as default. Started playing it in MP and it shows english as it should since it's the default. Since you use ffdshow as well try my subs config: Enable subtitles in ffdshow video decoder settings without enabling vobsub. Go to MP configuration and enable subtitles in movies too. Go to movies-->postprocessing in MP config and add and tick ffdshow subtitles filter. Tell me how it goes.
 

frenzy

Portal Pro
April 29, 2008
228
10
France France
Country flag
and it still shows english? I can't see the problem. Looks like it's a problem with your configurations though. You are sure you are using the same config as I explained?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
S [solved] No sound - MKV file MediaPortal 1 Talk 2
Don_Ald MKV covers Помощь по MediaPortal 9
B mkv vom NAS laufen zu schnell Video & DVD 0
HTPCSourcer [solved] Sometimes persistent issues when playing specific h264 mkv files MediaPortal 2 18
bta489 [solved] Stuttering playback of edited recordings watch/edit Videos 2
Lehmden Tools and other software Media-Buddy - the MKV Buddy successor. Tools and other software 41
D Some mkv files do not play General Support 1
osre Audio issues with MKV Playback in MP2.1.3 General 5
R How to launch Stereoscopic Player for 3D MKV OffTopic 4
mickb Subtitles My TVSeries 4
M.Hulot Blu-ray: Es werden nicht nur Forced Subtitles angezeigt Allgemeines Supportforum 1
J How to change y position of subtitles General 2
R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
S Remote button to change audio and subtitle on / off General 10
P [solved] ATSC subtitles not fixed yet? General 2
E Swedish subtitles problem General 2
ratata Someone stole my subtitles... General Support 0
Dark Eyes Display subtitles on a separate display or device MediaPortal 1 Plugins 0
R [solved] Command / Shortcut for changing subtitles or audio Archive 5
K Multichannel audio and subtitles for TV not properly supported General Support 4
S Display non english folder name, subtitle, etc. General 23
S [solved] Movie SRT subtitle didn't display on client 2.2 Archive 18
S [solved] Live TV subtitle issue if not using 100% font General 31
D [solved] How to configure subtitle color in MP 2.2.1? General 5
S [fixed] [MP2-611] Teletext subtitles language selection 2.2 Archive 20
Similar threads

























Top Bottom