[solved] Movie got merged wrong & Series fanart is missing (1 Viewer)

PrinzValium

Portal Member
December 26, 2010
29
4
Home Country
Germany Germany
On Friday it was time for me to do a fresh installation on my HTPC and I wanted to upgrade to windows 10 anyway. So I decided to give MePo 2 a try once again.
All my movies and series are stored on a server in the LAN. Movies each have a NFO file and fanart + poster. series each have NFO files. So I added the paths to the media stores (I did this one by one) and let the importer do it's thing, which took about two days in total by the way.

After the movie import was finished I checked the count. I got 711 movies on the server and only 704 were shown in the movies view in mepo. After checking the logs I found out that the importer merged some movies together. I have two different versions of Star Wars I-VI, so these were merged together. I can live with that.
So this would mean I should be able to see 705 movies in total which wasn't the case, so I double-checked the logs. I found out that the importer merged "Carnage" (tt1692486) into "The Exorcist" (tt0070047). Both movies are stored in different folders and have the correct NFO file. I even rescraped the movies to verify that no NFO file is corrupted. I tried to remove both of them, reimport and then add the either of them again and reimport once again. Depending on the order I did this, either of them showed up, never both though.
The next step was to stop the service, delete the whole database and do a new import. Unfortunately the outcome was exactly the same.
This wouldn't be a problem if I could edit the database by hand somehow.

Nevertheless I wanted to try the series import. The good thing is every episode was showing up, except for some files which I could identify pretty fast. These have a ".divx" file extension. I assume the importer just doesn't have this extension in the scraper list or something. Is it possible to add extensions to the list? In my case I can just rename the files to ".avi" since these are actually avi-files.
Also there are two series (American Dad, Marvel's Daredevil) where the importer didn't download any fanart and I have no idea why. They got added correctly to the database though. I can provide NFO files if needed.
I found one episode which aired on TV in two separate parts but is listed on thetvdb as one single part. Thus only one of my local files got referenced. I guess I'll have to merge my local files together into one file and there is no other solution right?

Also it's quite a hassle to set a watched state for over 600 movies. In MovingPictures I could just set every movie to "watched" and then it was pretty easy to set ~100 movies to "unwatched" again. I don't want to "hardcode" the watched flag into my NFO files though.

So far I really like the improvements of MePo 2 since the last time I tested it. I'd really appreciate if someone could help me solving these problems, otherwise I'll probably go back to MePo 1 for the time being.

edit: forgot to add the logs, I guess you'll want them
 
Last edited:

HTPCSourcer
Country flag

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,404
    2,329
    Home Country
    Germany Germany
    Hello,

    I found out that the importer merged "Carnage" (tt1692486) into "The Exorcist" (tt0070047).
    The logs that you attached contain no reference to either of the two movies, hence I can't say anything about this.

    Please can you
    • Remove the two movies and reimport
    • Restart the MP2 Server service (to create a completely new log)
    • Set the log level to DEBUG (see WIki)
    • Move the two movie files back into the share and reimport
    Then post a fresh set of logs.

    Also there are two series (American Dad, Marvel's Daredevil) where the importer didn't download any fanart and I have no idea why.
    Unfortunately the log is at INFO level and doesn't contain enough information. Sometimes TheTvDb is overloaded and doesn't deliver the data. You could try again by moving the two series folders away from your share, reimport, move them backl into the share and import again.

    I found one episode which aired on TV in two separate parts but is listed on thetvdb as one single part. Thus only one of my local files got referenced. I guess I'll have to merge my local files together into one file and there is no other solution right?
    If TheTvDb has different information, then you will probbably need to merge the two recordings into one file.

    Also it's quite a hassle to set a watched state for over 600 movies.
    MP2 has a user concept. Currently every client is considered a different "user" hence the behavior is normal. Works is going on to provide a true personalized user management.

    At this time I see two solutions for you:
    1. Use Trakt to synchronize the watched status
    2. Edit the database directly

    Option 2 requires that you install a SQL editor to change data within the database. If you are interested, I can provide more explanation.
     

    PrinzValium

    Portal Member
    December 26, 2010
    29
    4
    Home Country
    Germany Germany
    Hi and thanks for your replies!

    The logs that you attached contain no reference to either of the two movies, hence I can't say anything about this.
    Oh sorry, my bad. The movies I'm talking about have a German name actually.
    "Der Gott des Gemetzels" & "Der Exorzist"

    Please can you
    • Remove the two movies and reimport
    • Restart the MP2 Server service (to create a completely new log)
    • Set the log level to DEBUG (see WIki)
    • Move the two movie files back into the share and reimport
    Then post a fresh set of logs.
    I followed your instructions, unfortunately the problem persists. I added the new DEBUG logs to the post though.

    Unfortunately the log is at INFO level and doesn't contain enough information. Sometimes TheTvDb is overloaded and doesn't deliver the data. You could try again by moving the two series folders away from your share, reimport, move them backl into the share and import again.
    So this actually worked for "American Dad" but "Marvel's Daredevil" still doesn't have any fanart. This should be noticeable in the logs now. I'll probably just try again the remove, reimport, move back, reimport method.

    edit: that's actually not fully corret. Just the series cover and backdrop is missing. season covers are there.
    Also I found out that "The Wire" is missing fanart. It's just the series cover though, the rest seems to be there.

    If TheTvDb has different information, then you will probbably need to merge the two recordings into one file.
    I guess this is the easiest solution then, thank you.

    MP2 has a user concept. Currently every client is considered a different "user" hence the behavior is normal. Works is going on to provide a true personalized user management.

    At this time I see two solutions for you:
    1. Use Trakt to synchronize the watched status
    2. Edit the database directly

    Option 2 requires that you install a SQL editor to change data within the database. If you are interested, I can provide more explanation.
    I'll try to get it working with Trakt then, although that didn't work for me in MP1.

    Maybe there is a third one, if you still have your MovingPictures Database somehow (maybe as a backup). Then you can migrate the watched status from MovingPictures directly into MP 2.1 with:
    MP 2.1 Backup & Restore
    Unfortunately this is not an option for me but good to know!


    One additional question that came to my mind is about the movie collection feature.
    All of my movies which are in a collection have this set in their NFO files (did this with Ember Media Manager). Do I need to store an additional NFO file in the movie share which contains all the movie set info for the importer to recognize?
     
    Last edited:

    HTPCSourcer
    Country flag

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,404
    2,329
    Home Country
    Germany Germany
    I followed your instructions, unfortunately the problem persists. I added the new DEBUG logs to the post though.
    Der Exorzist is correctly added:
    [2017-10-31 10:27:19,680] [171824 ] [55 ] [DEBUG] - Adding media item with name Der Exorzist (1973) (Der Exorzist.mkv)
    [2017-10-31 10:27:19,888] [172033 ] [55 ] [INFO ] - Media item 4ce06461-b231-4272-b03e-508e845fd8ab with name Der Exorzist (1973) (Der Exorzist.mkv) added/updated (208 ms)
    About the other: rename the file to Der Gott des Gemetzels (2011) and wait until the automatic importer kicks in (if you have activated the share watcher) or trigger a manual import.

    Do I need to store an additional NFO file in the movie share which contains all the movie set info for the importer to recognize?
    Movie collection information can be retrieved from the online source. NFO collection data should also be read from the indiividual files.

    Just the series cover and backdrop is missing. season covers are there.
    Also I found out that "The Wire" is missing fanart. It's just the series cover though, the rest seems to be there.
    Then moving the series out of the share and later back won't cure the problem. You will also need to delete the cached information. To do so, after moving the series out of the share, look up the corresponding series number on TheTvDb, then delete the respective sub-folder in C:\ProgramData\Team MediaPortal\MP2-Server\TvDB. Then move the files back into the share and reimport.
     

    PrinzValium

    Portal Member
    December 26, 2010
    29
    4
    Home Country
    Germany Germany
    Movie collection information can be retrieved from the online source. NFO collection data should also be read from the indiividual files.
    Movies that are in a collection have a tag like this in their respective NFO files:

    <tmdbcolid>135483</tmdbcolid>

    So this should actually be enough for the importer?

    About the other: rename the file to Der Gott des Gemetzels (2011) and wait until the automatic importer kicks in (if you have activated the share watcher) or trigger a manual import.
    01-11-_2017_12-59-19.png

    I renamed it as you said, but according to the log files it got merged again :(

    Then moving the series out of the share and later back won't cure the problem. You will also need to delete the cached information. To do so, after moving the series out of the share, look up the corresponding series number on TheTvDb, then delete the respective sub-folder in C:\ProgramData\Team MediaPortal\MP2-Server\TvDB. Then move the files back into the share and reimport.
    • Moved the folders for "Marvel's Daredevil" and "The Wire" out of the share
    • Looked up their TvDb numbers
    • deleted the respective sub-folders under "C:\ProgramData\Team MediaPortal\MP2-Server\TvDB"
    • did a reimport
    • moved the folders back in and started a reimport again
    Didn't solve the problem sadly.
    What seems strange to me is that the particular series get recognized correctly, since the importer has downloaded at least some fanart.

    1.jpg 2.jpg 3.jpg 4.jpg


    I've attached the logs from last night.
    Is there any other workaround for me? Like manually editing? I really hope we can solve this somehow.
     

    HTPCSourcer
    Country flag

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,404
    2,329
    Home Country
    Germany Germany
    I renamed it as you said/QUOTE]
    Are you sure? I see this in the log:
    [2017-11-01 00:18:06,935] [50019080] [250 ] [INFO ] - Refreshed media item 4ce06461-b231-4272-b03e-508e845fd8ab (Der Gott des Gemetzels.mkv) (366 MS)[/quote]

    Movies that are in a collection have a tag like this in their respective NFO files:
    <tmdbcolid>135483</tmdbcolid>
    So this should actually be enough for the importer?
    I am not sure. What happens if you filter your movies by "Collection"

    What seems strange to me is that the particular series get recognized correctly, since the importer has downloaded at least some fanart.
    Could be an issue with the TvDb not delivering the information. Since many people are off these days, I would suggest that you retry this again tomorrow or even next week only.

    An error was logged while downloading fanart:
    [2017-10-31 12:07:37,935] [6190079] [FanArt Downloader 1] [DEBUG] - SeriesTvMazeMatcher Download: Finished saving images for ID [721F357E-C391-4E4A-8221-29964A9F16B3 (Marvel's Daredevil S01)]
    [2017-10-31 12:07:37,914] [6190058] [FanArt Downloader 2] [ERROR] - TvDbWrapper: Error getting fan art for scope SeriesSeason
    System.IndexOutOfRangeException: Der Index war außerhalb des Arraybereichs.
     

    PrinzValium

    Portal Member
    December 26, 2010
    29
    4
    Home Country
    Germany Germany
    I did this a little bit later last night, sorry for the confusion

    [2017-11-01 00:47:05,129] [51757273] [285 ] [DEBUG] - MediaLibrary: Delete sub path {03dd2da6-4da8-4d3e-9e55-80e3165729a3}:////HOMESERVER/Filme/Der Gott des Gemetzels/
    [2017-11-01 00:47:05,136] [51757280] [285 ] [DEBUG] - MediaLibrary: Set media item 0a1943e3-1e70-4e9c-93e6-9fbf6d30c170 virtual
    [2017-11-01 00:47:05,145] [51757289] [285 ] [DEBUG] - MediaLibrary: Delete media item 0a1943e3-1e70-4e9c-93e6-9fbf6d30c170 and 0 relations
    [2017-11-01 00:47:05,272] [51757416] [285 ] [DEBUG] - Scheduling FanArt deletion for 0a1943e3-1e70-4e9c-93e6-9fbf6d30c170
    [2017-11-01 00:47:05,282] [51757426] [285 ] [DEBUG] - MediaLibrary: Delete sub path {03dd2da6-4da8-4d3e-9e55-80e3165729a3}:////HOMESERVER/Filme/Der Gott des Gemetzels/Der Gott des Gemetzels.mkv
    [2017-11-01 00:47:14,835] [51766980] [228 ] [DEBUG] - Adding media item with name Der Gott des Gemetzels (2011) (Der Gott des Gemetzels (2011))
    [2017-11-01 00:47:14,880] [51767025] [228 ] [INFO ] - Media item 0efedc19-1f78-4ee7-a4be-e95cb838df19 with name Der Gott des Gemetzels (2011) (Der Gott des Gemetzels (2011)) added/updated (45 ms)
    [2017-11-01 00:47:38,999] [51791144] [273 ] [INFO ] - Media item with name Der Gott Des Gemetzels (2011) (Der Gott des Gemetzels (2011).mkv) was merged into 4ce06461-b231-4272-b03e-508e845fd8ab (232 ms)


    I am not sure. What happens if you filter your movies by "Collection"
    It just doesn't show anything.
    But this could be because I've set the importer to only download movie fanart and no online data. That's not that big of an issue for me right now, I can fiddle around with it later.

    Could be an issue with the TvDb not delivering the information. Since many people are off these days, I would suggest that you retry this again tomorrow or even next week only.
    Alright, I can do that, thanks!
     

    HTPCSourcer
    Country flag

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,404
    2,329
    Home Country
    Germany Germany
    I did this a little bit later last night, sorry for the confusion
    I stopped to early reading the log ;)

    @henso. please could you take a look at the above movie merge? The movie "Der Gott des Gemetzels (2011)" is for some reason merged into "De Exorzist" for no apparent reason.
     

    henso
    Country flag

    Development Group
  • Team MediaPortal
  • February 16, 2012
    2,135
    718
    Home Country
    Denmark Denmark
    <tmdbcolid>135483</tmdbcolid>
    This is not currently supported. I will add support.
    @henso. please could you take a look at the above movie merge? The movie "Der Gott des Gemetzels (2011)" is for some reason merged into "De Exorzist" for no apparent reason.
    The merge probably happens because the 2 movies appear to have the same ID. Could I have the nfo files for the 2 movies and the file "MovieMatches.xml" in the "C:\ProgramData\Team MediaPortal\MP2-Server\TheMovieDB" folder?
    An error was logged while downloading fanart:
    I also added a possible fix for this.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom