Moving Pictures Public Beta 0.5.5c (1 Viewer)

Status
Not open for further replies.

marvenius

Portal Pro
September 3, 2008
523
47
Belgium
Netherlands Netherlands
lighter greystar.png

I just wanted to whip up a fast solution, NOT maintained in the SVN!
It's just a tint lighter then the original.
Outlined version will just have to wait a bit longer. Was fiddling with the pxel with of the outline and didn't have the right AA applied.
Basically this is of course up to the skin design, but I have the same issue anyways and these are distributed with MovPic also.

I'll see what I can do for further enhancements.
(btw, let me know if this is a sufficient modification!)
 

Attachments

zicoz

MP Donator
  • Premium Supporter
  • September 3, 2006
    896
    63
    Norway Norway
    Anyone else that's pressing F5 alot now that all the 0.6 issues are gone from the issuelist? :)

    Great job!
     

    marvenius

    Portal Pro
    September 3, 2008
    523
    47
    Belgium
    Netherlands Netherlands
    Anyone else that's pressing F5 alot now that all the 0.6 issues are gone from the issuelist? :)

    Great job!
    Just don't, you'll just hurt your fingers. ;) It's ready when it's ready.
    Last time (with 0.5.5) the issue list was done, but it took some time to test and verify the quality of the plugin. This will probable be the case now as well.
     

    fforde

    Community Plugin Dev
    June 7, 2007
    2,666
    1,699
    39
    Texas
    United States of America United States of America
    I think it's not about a check wheter the record is there or not, but simultaneous (write) access to the database. SQLite does not support this.
    The logic for all clients is the same:
    Changes are picked up by all clients and they try to lock the database. Which isn't supported.
    Now I'm not a developer, but this how I understood it.
    OK - perhaps a future version could be based on a real database like MS SQL Server, MySQL, PostgreSQL or the like ;)

    (Oh, just dreaming, I know)
    SQLite actually does support multiple clients accessing the same database, it just doesn't allow simultaneous writing. This basically just means that when a process is writing, the database is effectively locked to all other clients. With a setup like MediaPortal, even with five or ten seats connecting to the same database this really wouldn't be a big deal, but you still have a problem with all the clients knowing what everyone else is doing. This is a simplified example, but imagine a situation like this:

    Client1 check is file A exists in DB. It does not.
    Client1 starts processing file A.
    Client2 checks if file A exists in DB. It still does not.
    Client2 starts processing file A.
    Client 1 finishes processing File A.
    Client 1 writes File A to the DB.
    Client 2 finishes processing File A.
    Client 2 writes File to the database. OOPS.

    Situations like this will quickly corrupt your database, and it gets much more complicated than this. So there are many ways to fix this, but a different database implementation would not resolve the problem. And for what it's worth SQLite is a "real" relational database. It just has a different feature set than the others you mentioned. Specifically it's tailored for purposes exactly like what we are using it for. :p

    So to get around the problem of multiple clients writing to the database, there are a few solutions. I have a pretty good idea of how I will implement it but it will of course take time. There are other issues that will unfortunately have to come first.

    Anyone else that's pressing F5 alot now that all the 0.6 issues are gone from the issuelist? :)

    Great job!
    All the issues are resolved but it still may be a few days until release. We are doing some internal testing right now to make sure nothing breaks with the new version.There are a lot of changes so we just want to make sure it's as stable as we can make it before we send it out to the world. Just be patient. :p It's coming soon.
     

    Johnny-D

    Portal Member
    August 11, 2006
    31
    0
    I just wanted to whip up a fast solution, NOT maintained in the SVN!
    It's just a tint lighter then the original.
    Outlined version will just have to wait a bit longer. Was fiddling with the pxel with of the outline and didn't have the right AA applied.
    Basically this is of course up to the skin design, but I have the same issue anyways and these are distributed with MovPic also.

    I'll see what I can do for further enhancements.
    (btw, let me know if this is a sufficient modification!)
    Well it seems to have done the trick! It's very clear how many stars there are in total now. The soft gold outline around the previous grey star is definitely the way to go long term, but for a quick fix this is perfect!

    Now I know how easy it is to change I'll have a play around myself and post the results.

    Thanks Marvenius!
     

    i2ambler

    Portal Member
    February 4, 2008
    36
    0
    United States of America United States of America
    Maybe this is a stupid question, or has been asked before but... Does Moving Pictures use a common database that all my machines can access?

    I have set this up on my server, and took a lot of time to make sure all the graphics were imported & such. I have three other clients I would like to extend this to, but that would take a lot of time to set each one up if each has their own respective database.

    And :D for the work on this guys! I look forward to using this plugin with the upcoming MediaStream or StreamMP (whichever they call it) skin....
    Moving Pictures does not officially support multi-seat setups right now, but there are ways you can get it working. If you try though I would highly recommend you backup your database on a regular basis. It's easy for things to get screwed up playing with this sort of thing. You will want to take a look at this guide. Also, reposted from earlier in this thread, here are a few additional tips:

    I would follow the guide to centralize my databases, artwork, config, etc, then setup the first system with Moving Pictures. I would get all my movies loaded to my satisfaction. At this point on all of your other systems, you should just be able to drop the movingpictures.dll file into your plugins folder and they should automatically connect to your centralized SQLite database, and you should be good to go.

    When you want to add or remove movies to or from your collection though, I would shut down all but one instance of Media Portal, otherwise you might get multiple additions or removals, causing problems. Once you have made changes to your watch folder, start up the first instance of Media Portal (or restart, either way is fine), give it a couple of minutes to make sure any import tasks are complete, then power up each of your other systems.

    I guess the important point is make sure that, whenever you are making changes to your settings, you have only one system online. Let me know how things go.

    I just installed moving pictures - it was able to find most of my movies without too much difficulty. And I browsed in mediaportal - no problem. However, I shut mediaportal down, then went back into the config - and now its not able to load the plugin at all. It says it is imcompatiable suddenly. Im using rc2, and it WAS working. Now it wont. :( Could the database be corrupt?
    i2ambler, I am very sorry but this is a known issue with the current version. Basically your database is probably screwed and you will need to rebuild. This normally is caused by a runaway sub process of Moving Pictures not shutting down fast enough. If you launch the GUI, close it quickly and then launch the config quickly (or vice versa) in some situations there will be two processes accessing the database at the same time. And this can sometimes cause database corruption.

    You have two options. First, 0.6 is about to come out and there is a good possibility that it will correct your problem and repair your database for you. I can't guarantee this, but if you spent a lot of time setting your system up you may want to wait for 0.6 to see if it resolves your issues. It is feature complete and in testing now, so it should be available for download within two or three days.

    Your second option of course is to rebuild your database. Unpleasant. If you go this route, over the next few days until you upgrade to 0.6, just make sure you wait a few minutes between closing MP and open the config (or vice versa). Especially if you have a large movie collection.

    Sorry for the trouble. :( I should have created a bug fix release to correct this problem, there have been more than a few reports of this bug and it is a bad one. We shouldn't have let it just sit...
    No worries - I had worked on it for about an hour or two - half of which was figuring out how it worked, since i had never used the MP-TV plugin either. This is pretty nice, although it doesnt seem to find DVD covers as successfully as the built in movie manager. All in all - good stuff!
     

    fforde

    Community Plugin Dev
    June 7, 2007
    2,666
    1,699
    39
    Texas
    United States of America United States of America
    No worries - I had worked on it for about an hour or two - half of which was figuring out how it worked, since i had never used the MP-TV plugin either. This is pretty nice, although it doesnt seem to find DVD covers as successfully as the built in movie manager. All in all - good stuff!
    The new version coming out in a few days has much better cover retrieval.
     

    WileECoyote

    MP Donator
  • Premium Supporter
  • October 14, 2008
    1,156
    220
    Cary, NC
    United States of America United States of America
    Maybe this is a stupid question, or has been asked before but... Does Moving Pictures use a common database that all my machines can access?

    I have set this up on my server, and took a lot of time to make sure all the graphics were imported & such. I have three other clients I would like to extend this to, but that would take a lot of time to set each one up if each has their own respective database.

    And :D for the work on this guys! I look forward to using this plugin with the upcoming MediaStream or StreamMP (whichever they call it) skin....
    Moving Pictures does not officially support multi-seat setups right now, but there are ways you can get it working. If you try though I would highly recommend you backup your database on a regular basis. It's easy for things to get screwed up playing with this sort of thing. You will want to take a look at this guide. Also, reposted from earlier in this thread, here are a few additional tips:

    I would follow the guide to centralize my databases, artwork, config, etc, then setup the first system with Moving Pictures. I would get all my movies loaded to my satisfaction. At this point on all of your other systems, you should just be able to drop the movingpictures.dll file into your plugins folder and they should automatically connect to your centralized SQLite database, and you should be good to go.

    When you want to add or remove movies to or from your collection though, I would shut down all but one instance of Media Portal, otherwise you might get multiple additions or removals, causing problems. Once you have made changes to your watch folder, start up the first instance of Media Portal (or restart, either way is fine), give it a couple of minutes to make sure any import tasks are complete, then power up each of your other systems.

    I guess the important point is make sure that, whenever you are making changes to your settings, you have only one system online. Let me know how things go.

    I just installed moving pictures - it was able to find most of my movies without too much difficulty. And I browsed in mediaportal - no problem. However, I shut mediaportal down, then went back into the config - and now its not able to load the plugin at all. It says it is imcompatiable suddenly. Im using rc2, and it WAS working. Now it wont. :( Could the database be corrupt?
    i2ambler, I am very sorry but this is a known issue with the current version. Basically your database is probably screwed and you will need to rebuild. This normally is caused by a runaway sub process of Moving Pictures not shutting down fast enough. If you launch the GUI, close it quickly and then launch the config quickly (or vice versa) in some situations there will be two processes accessing the database at the same time. And this can sometimes cause database corruption.

    You have two options. First, 0.6 is about to come out and there is a good possibility that it will correct your problem and repair your database for you. I can't guarantee this, but if you spent a lot of time setting your system up you may want to wait for 0.6 to see if it resolves your issues. It is feature complete and in testing now, so it should be available for download within two or three days.

    Your second option of course is to rebuild your database. Unpleasant. If you go this route, over the next few days until you upgrade to 0.6, just make sure you wait a few minutes between closing MP and open the config (or vice versa). Especially if you have a large movie collection.

    Sorry for the trouble. :( I should have created a bug fix release to correct this problem, there have been more than a few reports of this bug and it is a bad one. We shouldn't have let it just sit...
    Thanks for the information fforde! I will try that tonight!
     

    i2ambler

    Portal Member
    February 4, 2008
    36
    0
    United States of America United States of America
    No worries - I had worked on it for about an hour or two - half of which was figuring out how it worked, since i had never used the MP-TV plugin either. This is pretty nice, although it doesnt seem to find DVD covers as successfully as the built in movie manager. All in all - good stuff!
    The new version coming out in a few days has much better cover retrieval.
    Eggcellent.. I have a question - maybe I missed something - if I toss movies into my movies directories - does the plugin automatically add them to the database without my having to go into the configuration?
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M.Hulot Moving Pictures lässt sich nach Windows-Update nicht mehr öffnen Plugins & Erweiterungen 1
    cerberus Moving Pictures zeigt Film Spezifikationen nicht richtig Plugins & Erweiterungen 12
    P Configuration Moving Pictures Support d'installation et de configuration 0
    R [solved] Moving pictures importer wont add files from a removable drive. Is there a work around ? Moving Pictures 8
    badboyxx [solved] Moving Pictures and MediaPortal 1.23 Regeszter Edition Moving Pictures 93
    caveman [solved] Moving Picture 97% CPU Moving Pictures 9
    T Moving Pictures...seem to have 'lost' ability to display Movie info. (eg Resolution/Audio) Moving Pictures 2
    raffe [solved] Export tool and import support from MP-TVSeries & Moving Pictures to MP2 General 22
    M.Hulot Moving pictures startet nur im hintergrund und falscher version Allgemeines Supportforum 5
    T Neuinstalation - Moving Pictures probleme Installationsprobleme? 19
    S Problem wit .ISO files in Moving Pictures Moving Pictures 3
    olli14 Inhalt der Moving Pictures Datenbank in die Plex Datenbank kopieren MediaPortal Café 69
    T Moving Pictures Icon disappeared...and the program....??? Watch / Listen Media 1
    T Moving Pictures error after update to 1.19 Final...logs included! Watch / Listen Media 6
    J [solved] Moving Pictures vs. родной граббер, кинопоиск Помощь по MediaPortal 21
    R [solved] Files moved to new location - Easy way to update database? My TVSeries 7
    R Files moved to different location - Easy way to update database? Moving Pictures 2
    ge2301 [Finished] [MP2-782] Show mouse cursor only if it was moved more than 10 pixels MediaPortal 2 13
    O Want to move 21:9 video down to the screen bottom Watch / Listen Media 1
    horned_reaper [solved] Mixed artist pictures Fanart Handler 397
    F Picture on folder Feature Requests 9
    emphatic Pictures in the cloud - would a plugin be possible for services like Google Photos MediaPortal 1 Plugins 1
    A Video clips do not work in the Pictures folder General Support 10
    N [Finished] [MP2-789] MCE remote control Recorded TV and My Pictures buttons do not work MediaPortal 2 17
    Cowboy Playback Problem with CTD or sometimes BSOD watch/edit Videos 0
    Similar threads

























    Top Bottom