MP Freezes at end of song when now playing is selected

Discussion in 'Listen Music' started by gwatkins, February 2, 2014.

  1. gwatkins

    gwatkins Portal Pro

    Joined:
    December 8, 2013
    Messages:
    81
    Likes Received:
    2
    Gender:
    Male
    Location:
    Richardson, Texas
    Ratings:
    +6 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    MP is freezing at the end of any song when "Now Playing" is selected. It will play the song until about the last 4 seconds. Then it will freeze and go to not responding in the task manager. Debug logs attached.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. gwatkins

    gwatkins Portal Pro

    Joined:
    December 8, 2013
    Messages:
    81
    Likes Received:
    2
    Gender:
    Male
    Location:
    Richardson, Texas
    Ratings:
    +6 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
  4. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    You have a lot of plugins that could be interfering. Please disable all plugins and attempt to reproduce again.
    Other than that, there is nothing obvious in the log files. You could try disabling cross-fading... but after that I'd be out of ideas.

    PS: Lots of threads take longer than two days to get an answer. Also, our music lead developer decided to retire in the last few weeks. A little patience would go a long way. ;)
     
  5. gwatkins

    gwatkins Portal Pro

    Joined:
    December 8, 2013
    Messages:
    81
    Likes Received:
    2
    Gender:
    Male
    Location:
    Richardson, Texas
    Ratings:
    +6 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    Thanks for the reply. I ran it in debug mode to generate the log files which, if I am correct, disables all additional plugins except what are installed by default so I don't think that is the problem. I also already have cross-fading disabled.

    I didn't mean to be impatient. I just wondered if anyone saw my post.
     
  6. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    I asked because it looked like plugins were loaded:
    Show Spoiler

    [2014-02-02 08:11:11,168] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\Geckofx-Core.dll' (non threaded)
    [2014-02-02 08:11:11,172] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\Geckofx-Core.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,176] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\Geckofx-Winforms.dll' (non threaded)
    [2014-02-02 08:11:11,180] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\Geckofx-Winforms.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,184] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\hulu.dll' (non threaded)
    [2014-02-02 08:11:11,188] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\hulu.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,192] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\libspotify.dll' (non threaded)
    [2014-02-02 08:11:11,196] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\libspotify.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,200] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\MailTip.dll' (non threaded)
    [2014-02-02 08:11:11,204] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\MailTip.dll' (4.0003 ms running time)
    [2014-02-02 08:11:11,207] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\Micropolis.CMCore.dll' (non threaded)
    [2014-02-02 08:11:11,211] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\Micropolis.CMCore.dll' (4.0003 ms running time)
    [2014-02-02 08:11:11,215] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\Micropolis.MPCore.dll' (non threaded)
    [2014-02-02 08:11:11,219] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\Micropolis.MPCore.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,223] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\MovingPictures.dll' (non threaded)
    [2014-02-02 08:11:11,227] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\MovingPictures.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,231] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\MPEIPlugin.dll' (non threaded)
    [2014-02-02 08:11:11,235] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\MPEIPlugin.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,239] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\MP-TVSeries.dll' (non threaded)
    [2014-02-02 08:11:11,243] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\MP-TVSeries.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,247] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\MyLyrics.dll' (non threaded)
    [2014-02-02 08:11:11,251] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\MyLyrics.dll' (4.0003 ms running time)
    [2014-02-02 08:11:11,255] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\NetflixAlphaPlugin.dll' (non threaded)
    [2014-02-02 08:11:11,259] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\NetflixAlphaPlugin.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,263] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\OnlineVideos.MediaPortal1.dll' (non threaded)
    [2014-02-02 08:11:11,267] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\OnlineVideos.MediaPortal1.dll' (4.0003 ms running time)
    [2014-02-02 08:11:11,271] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\Rockstar.dll' (non threaded)
    [2014-02-02 08:11:11,276] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\Rockstar.dll' (5.0003 ms running time)
    [2014-02-02 08:11:11,280] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\SkinInfo.dll' (non threaded)
    [2014-02-02 08:11:11,284] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\SkinInfo.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,288] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\TitanSkinUpdater.dll' (non threaded)
    [2014-02-02 08:11:11,292] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\TitanSkinUpdater.dll' (4.0002 ms running time)
    [2014-02-02 08:11:11,296] [Log ] [MPMain ] [DEBUG] - PluginManager: Begin loading '\windows\TraktPlugin.dll' (non threaded)
    [2014-02-02 08:11:11,300] [Log ] [MPMain ] [DEBUG] - PluginManager: End loading '\windows\TraktPlugin.dll' (4.0003 ms running time)


    In case you weren't aware, plugins are only disabled if you run the watchdog with option 1. Option 2 leaves plugins enabled; option 3 exports existing log files (not relevant here).

    I could be wrong. Just seemed odd to me.

    Before or after producing the log files?
    Again:
    ...and that is the last entry in the log aside from PowerScheduler entries.
    Configuration says:
    In short, it really looks like you have or at least had cross fade enabled.
     
  7. gwatkins

    gwatkins Portal Pro

    Joined:
    December 8, 2013
    Messages:
    81
    Likes Received:
    2
    Gender:
    Male
    Location:
    Richardson, Texas
    Ratings:
    +6 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    Interesting I could have sworn that I disabled it. I may have sent the wrong set of log files because I tried debugging it several times. I will make sure it is disabled and check it again. Thanks.[DOUBLEPOST=1391600926][/DOUBLEPOST]You were right. The problem was the cross-fading. I had disabled the volume fade-out and in instead. Thanks.(y)
     
    Last edited: February 5, 2014
    • Like Like x 1
  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    • Like Like x 1
    • Thank You! Thank You! x 1
  9. gwatkins

    gwatkins Portal Pro

    Joined:
    December 8, 2013
    Messages:
    81
    Likes Received:
    2
    Gender:
    Male
    Location:
    Richardson, Texas
    Ratings:
    +6 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    I don't care about using the cross-fading but should that be considered a bug?
     
  10. gwatkins

    gwatkins Portal Pro

    Joined:
    December 8, 2013
    Messages:
    81
    Likes Received:
    2
    Gender:
    Male
    Location:
    Richardson, Texas
    Ratings:
    +6 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    I thought this issue was resolved but it has suddenly come back however the symptom is slightly different. When cross-fading was enabled it would freeze a few seconds before the end of the song. Now it will play all the way to the end and then freeze. If I don't jump to the now playing screen then it works fine. I even tried deleting music database and rescanning, same result. I also ran it in debug mode 1 (titan skin and plugins disabled) and still happened. I am attaching debug logs.
     
  11. lisag
    • Premium Supporter

    lisag Retired Team Member

    Joined:
    March 3, 2012
    Messages:
    457
    Likes Received:
    115
    Gender:
    Female
    Occupation:
    Social Work
    Location:
    Essex
    Ratings:
    +183 / 1
    Home Country:
    United Kingdom United Kingdom
    This is a bit of a guess, but I think I had a similar problem to this and it was due to wi-fi remote. Do you have that installed?
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!