MP Freezes at end of song when now playing is selected (2 Viewers)

B

BassFan

Guest
I had the same problem after upgrading from MP 1.3. After a couple of hours trying different things, I found disabling visualizations fixed it.

work by me with and without ...
@Sebastiii @BassFan :)
Any idea or maybe WIP fix already ok for this ?


from the log i can see only..
[2014-04-23 21:20:19,544] [Log ] [MPMain ] [INFO ] - BASS: Creating visualization...
[2014-04-23 21:20:19,548] [Log ] [MPMain ] [INFO ] - Visualization Manager: Closing current visualization plugin...
[2014-04-23 21:20:19,549] [Log ] [MPMain ] [INFO ] - Visualization Manager: Visualization plugin close not required - nothing loaded
[2014-04-23 21:20:19,550] [Log ] [MPMain ] [INFO ] - Visualization Manager: Creating new Windows Media Player visualization...
[2014-04-23 21:20:19,553] [Log ] [MPMain ] [INFO ] - Visualization Manager: Initializing WMP visualization...
[2014-04-23 21:20:19,589] [Log ] [MPMain ] [INFO ] - Visualization Manager: WMP visualization initialization succeeded.

i will check this after 1.8 Pre-released are available.
i will not work on a build where my fixed for WMP not include.

and in Error Log..
[2014-04-23 21:20:18,940] [Error ] [MPMain ] [ERROR] - MiniDisplay:Error while loading driver C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\LCD2USB.dll: Impossibile caricare la DLL 'C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\LCD2USB.dll': Impossibile trovare il modulo specificato. (Eccezione da HRESULT: 0x8007007E).

Also use other Visualization instead of WMP Plugin then it should work.

greets
 
Last edited by a moderator:

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,559
    10,377
    France
    Home Country
    France France
    Country flag
    Sure this is why I ask you if it can be fixed when the wmp fix ;) best will be to provide an installer for test
     
    B

    BassFan

    Guest
    Sure this is why I ask you if it can be fixed when the wmp fix ;) best will be to provide an installer for test


    my Problem..

    i never used *.flak files with MP
    i never use any of LCD.. Drivers (DLL)
    i can not see is this Problem appears only with WMP or with other Visualization also
    i can not see this Problem appears without LCD Plugins also..
    i can not see is this a Problem with wrong Resolution of any SkinEngine for Visualization Container to.
    and so on! ;)

    greets
     
    Last edited by a moderator:

    nicsergio

    MP Donator
  • Premium Supporter
  • April 27, 2010
    161
    155
    Home Country
    Italy Italy
    Country flag
    Sure this is why I ask you if it can be fixed when the wmp fix ;) best will be to provide an installer for test


    my Problem..

    i never used *.flak files with MP
    i never use any of LCD.. Drivers (DLL)
    i can not see is this Problem appears only with WMP or with other Visualization also
    i can not see this Problem appears without LCD Plugins also..
    i can not see is this a Problem with wrong Resolution of any SkinEngine for Visualization Container to.
    and so on! ;)

    greets

    If you can help, add some info:
    • I also tried to disable MiniDisplay plugin, but nothing changed
    • I have almost all files .flac on the NAS, but I can try to see if it also happens with other formats (mp3, wav)
    • as Visualization I use only "Alchemy" of WMP.. In fullscreen should be fine, but from MP1.6 I noticed that in some skin, where it is displayed in a frame (eg. with the control ID=112 in MyMusicPlayingNow.xml or with controls type VideoWindow in MusicOverlay.xml) the visualization does not respect the size of the control and displayed in full screen o_O

    thanks for your help
     
    B

    BassFan

    Guest
    @nicsergio respect the size of the control and displayed in full screen
    that is fixed not used in current 1.7 release, should then be in 1.8 pre-release
    no understand, what has this to do with freeze of MP at end of song.


    greets
     
    Last edited by a moderator:
    B

    BassFan

    Guest
    I had the same problem after upgrading from MP 1.3. After a couple of hours trying different things, I found disabling visualizations fixed it.

    Thank you very much!!!
    disabling only check "Show visualization" everything seems to work fine! :):)

    View attachment 149403

    I thought the check would serve to enable the visualization in fullscreen, however I see that this continues to work.. :D


    Forget it! that has nothing to do with Visualization :D:D:D:D :ROFLMAO::ROFLMAO: :p LOL ;)

    greets
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,559
    10,377
    France
    Home Country
    France France
    Country flag
    Hi :)
    Attached is the fix from BassFan with other playback change.
    Could you try with regression testing (stop/start song/internet stream etc.) with viz enable/disable ?
    Thanks :)

    Ps : the bin is against 1.7.0 Final.
     

    Attachments

    • Common.GUIPlugins_MP_Freeze.zip
      63.1 KB · Views: 96
    B

    BassFan

    Guest
    Hi :)
    Attached is the fix from BassFan with other playback change.
    Could you try with regression testing (stop/start song/internet stream etc.) with viz enable/disable ?
    Thanks :)

    Ps : the bin is against 1.7.0 Final.


    works by me no freeze or other probem..

    greets
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,559
    10,377
    France
    Home Country
    France France
    Country flag
    On my side i can trigger the freeze even with the change, so need to look more deeply :)
     

    Users who are viewing this thread

    Similar threads

    "Sometimes" when I am playing a playlist with the TV on I notice that the screen becomes frozen. The on screen playlist doesn't show the songs advancing through the list. i.e. the currently playing song doesn't match the name of the on screen song. MP still plays the playlist ok but the screen just stops showing the correct song...
    "Sometimes" when I am playing a playlist with the TV on I notice that the screen becomes frozen. The on screen playlist doesn't...
    "Sometimes" when I am playing a playlist with the TV on I notice that the screen becomes frozen. The on screen playlist doesn't...
    Replies
    0
    Views
    650
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up a running mediaportal setup. Without the logs however, I don't have a clue on what exactly is wrong...
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up...
    Hi there, I'm a happy long time user and am currently using MP 1.25. Up until now I had no issues with my setup. Yesterday...
    Replies
    1
    Views
    246
    Your feedback is very important to us. Have a nice day. :) -- Tapatalk | WBR, ajs
    Your feedback is very important to us. Have a nice day. :) -- Tapatalk | WBR, ajs
    This happens since 1.27 pre - just tried 1.27 "a new hope" sadly also there :( - no hope left :ROFLMAO: Steps to reproduce - and...
    Replies
    154
    Views
    3K
    After upgrading from version 1.24 to 1.26, I could no longer use the MP on one of my computers because it freezes. The task manager showed "stopped". New upgrade - from 1.24 to 1.27. Doesn't freeze that often anymore. But it always happens. Then the MP can no longer be operated. It seems to happen when a video directory is read in...
    After upgrading from version 1.24 to 1.26, I could no longer use the MP on one of my computers because it freezes. The task manager...
    After upgrading from version 1.24 to 1.26, I could no longer use the MP on one of my computers because it freezes. The task manager...
    Replies
    0
    Views
    510
    https://issues.team-mediaportal.com/browse/MP1-5078 and added to the next release of MediaPortal
    https://issues.team-mediaportal.com/browse/MP1-5078 and added to the next release of MediaPortal
    Hi there, Every now and then, when playing a video no image is rendered. The audio plays fine, but the screen stays black. Not...
    Replies
    49
    Views
    2K
    Top Bottom