[solved] - MP freezing and crashing

Discussion in 'General Support' started by bta489, December 13, 2016.

  1. bta489

    bta489 Portal Pro

    Joined:
    March 17, 2013
    Messages:
    110
    Likes Received:
    23
    Gender:
    Male
    Ratings:
    +48 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hi there,

    The last couple of days my MediaPortal is acting up. The usual statement: I didn't change anything :rolleyes: .
    I perceived the first noticeable signs when I tried to switch from Music-Database-View to Folder-View and the listView was not showing any entries. Now, when I try to enter any Folder-View (Music, MyVideos) MP freezes. After killing MediaPortal.exe in the Task-Manager, the Window disappears, but the Process remains in the task-manager. Sometimes -after a couple of minutes- the process finally is completely gone and I can restart MP (but when entering MyVideos for instance it freezes again).

    A couple of days ago during video-playback MediaPortal then exited without any error-messages. I was able to collect Logs from that incident, but since then the watchdog returned an error-message like this (and doesn't collect the logs):
    MP_Error.JPG
    (roughly translated to english : "unhandled exception in application", the file "...\tvserver_Gentle.config" already exists.)

    I tried reinstalling MediaPortal, updated the graphics-card driver and started MP with an empty database-folder, but the problem persists. Occasionally though, at least myVideos is working.

    I did delete the tvserver_Gentle.config and now at least the watchdog is working again. The second set of logs is from just now, where MP crashed and froze.

    Any help would be appreciated.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,448
    Likes Received:
    4,664
    Ratings:
    +8,101 / 17
    Home Country:
    New Zealand New Zealand
    Hello

    Thanks for the log files. (y)

    For this part I have no comment. I can't identify/see the problem happening in the log files. I suggest you reproduce the problem using Watchdog option 1 or 2 ("report a bug...") and provide the log files. That should show the problem more clearly.

    For this exit-without-error-message, it looks like your NVidia GPU driver was having problems. The Windows system log shows:
    Show Spoiler

    "11.12.2016 00:08:29";"Display";"(0)";"Warning";"Der Anzeigetreiber "nvlddmkm" reagiert nicht mehr und wurde wiederhergestellt.";"4101"
    "11.12.2016 00:08:29";"Service Control Manager";"(0)";"Information";"Dienst "Diagnosesystemhost" befindet sich jetzt im Status "Ausgeführt".";"1073748860"
    "11.12.2016 00:08:32";"nvlddmkm";"(0)";"Error";"Die Beschreibung für Ereignis-ID -1062600691 in Quelle nvlddmkm wurde nicht gefunden. Der lokale Computer hat möglicherweise nicht die notwendigen Registrierungsinformationen oder Meldungs-DLL-Dateien, um die Meldung anzuzeigen, oder Sie sind nicht berechtigt, darauf zuzugreifen. Die folgenden Informationen sind Teil des Ereignisses:'\Device\Video7', 'NVRM: Graphics TEX Exception on (GPC 0, TPC 0): TEX LAYOUT'";"3232366605"
    "11.12.2016 00:08:32";"nvlddmkm";"(0)";"Error";"Die Beschreibung für Ereignis-ID -1062600691 in Quelle nvlddmkm wurde nicht gefunden. Der lokale Computer hat möglicherweise nicht die notwendigen Registrierungsinformationen oder Meldungs-DLL-Dateien, um die Meldung anzuzeigen, oder Sie sind nicht berechtigt, darauf zuzugreifen. Die folgenden Informationen sind Teil des Ereignisses:'\Device\Video7', 'Variable String too Large'";"3232366605"


    I can only guess this is related to the new NVidia driver (v376.19) which seems to have been installed on 10 December (before this problem).

    The Windows system event log shows the same messages as above:
    Show Spoiler

    "13.12.2016 15:15:24";"Display";"(0)";"Warning";"Der Anzeigetreiber "nvlddmkm" reagiert nicht mehr und wurde wiederhergestellt.";"4101"
    "13.12.2016 15:15:24";"Service Control Manager";"(0)";"Information";"Dienst "Diagnosesystemhost" befindet sich jetzt im Status "Ausgeführt".";"1073748860"
    "13.12.2016 15:15:25";"nvlddmkm";"(0)";"Error";"Die Beschreibung für Ereignis-ID -1062600691 in Quelle nvlddmkm wurde nicht gefunden. Der lokale Computer hat möglicherweise nicht die notwendigen Registrierungsinformationen oder Meldungs-DLL-Dateien, um die Meldung anzuzeigen, oder Sie sind nicht berechtigt, darauf zuzugreifen. Die folgenden Informationen sind Teil des Ereignisses:'\Device\Video7', 'NVRM: Graphics TEX Exception on (GPC 0, TPC 0): TEX LAYOUT'";"3232366605"
    "13.12.2016 15:15:25";"nvlddmkm";"(0)";"Error";"Die Beschreibung für Ereignis-ID -1062600691 in Quelle nvlddmkm wurde nicht gefunden. Der lokale Computer hat möglicherweise nicht die notwendigen Registrierungsinformationen oder Meldungs-DLL-Dateien, um die Meldung anzuzeigen, oder Sie sind nicht berechtigt, darauf zuzugreifen. Die folgenden Informationen sind Teil des Ereignisses:'\Device\Video7', 'Variable String too Large'";"3232366605"


    ...so again I can only assume this is related to your NVidia driver update.
    This time the MP log shows that MP stopped due to a problem with DirectX/D3D (the GPU):
    Show Spoiler

    [2016-12-13 15:15:41,803] [Error ] [MPMain ] [ERROR] - MediaPortal stopped due to an exception Fehler in der Anwendung. Microsoft.DirectX.Direct3D bei Microsoft.DirectX.Direct3D.Device.EvictManagedResources()
    bei MediaPortal.D3D.RecreateSwapChain(Boolean useBackup)
    bei MediaPortal.D3D.RecoverDevice()
    bei MediaPortalApp.OnProcess()
    bei MediaPortal.D3D.OnIdle(Object sender, EventArgs e)
    bei System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
    bei System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
    bei System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
    bei System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
    bei System.Windows.Forms.Application.Run(Form mainForm)
    bei MediaPortalApp.Main(String[] args)


    So it really does look like a problem with the new GPU driver.

    Regards,
    mm
     
    • Thank You! Thank You! x 1
  4. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,554
    Likes Received:
    445
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +668 / 2
    Home Country:
    England England
    Show System Specs
    In addition to this I had a problem recently too
    I did this:
    1. Disabled all plugins - added them i 3 at a time and tested
      I kept a .txt file of all the plugins I added at which point just to keep track
    2. Removed all the DBs and rescanned everything
      This took forever, but resolved my issue
     
    • Thank You! Thank You! x 1
  5. bta489

    bta489 Portal Pro

    Joined:
    March 17, 2013
    Messages:
    110
    Likes Received:
    23
    Gender:
    Male
    Ratings:
    +48 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Thank you both for the responses.

    Weirdly, today there was no sign of the problems, everything works fine (for now). However, It looks as if MediaPortal is not the cause of the problems. There have been little glitches all over the place the past few days.
     
  6. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,554
    Likes Received:
    445
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +668 / 2
    Home Country:
    England England
    Show System Specs
    • Thank You! Thank You! x 1
  7. bta489

    bta489 Portal Pro

    Joined:
    March 17, 2013
    Messages:
    110
    Likes Received:
    23
    Gender:
    Male
    Ratings:
    +48 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Now that I had a little time to tackle this, I followed @SpudR 's advice and cleaned my system from the Video-card driver with DDU in safe mode and installed the latest driver. Since then no crashes or weird behaviour(y).
    It seems like everything is back to normal. Thanks again for the support.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!