[solved] - MP1-4585 Generic HID input device support for MCE buttons | Page 7

Discussion in 'Area 51 - Testing Area' started by Stéphane Lenclud, December 20, 2014.

  1. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,275
    Likes Received:
    6,223
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,235 / 9
    Home Country:
    France France
    Show System Specs
    I remember that force/rebase the branch can trigger something wrong with BOT, not often or very rarely :)


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    Can we merge that stuff to master then?
     
  4. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,275
    Likes Received:
    6,223
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,235 / 9
    Home Country:
    France France
    Show System Specs
    Nope for now :) until good result / Doc ready etc. :)
    But you surely can build the branch and upload full installer ? :p
     
  5. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    Almost forgot about the docs. The installer issue was fixed and the latest installer is available from the first post on that thread.
     
    • Thank You! Thank You! x 1
  6. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Stephane,

    Sorry. its a bit late, but I do see an issue.

    When using General HID, the [exit] [pause] [<<] [>>] are sent double. Tested this in multiple times switching between General HID and MCE. MCE remote doesnt show this behaviour.

    I created the logs for both situations.

    Second thing I noticed.
    When in Debug mode 1 or 2, the behavior between both is different. Maybe even both incorrect. :p
    General HID remote does not respond to any command.
    MCE remote only replies to the GUIDE button, but no directions or ok/back etc.

    Can you reproduce and does this make sense?
     
  7. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    Thanks for the extra testing.

    The pause issue is only affecting the music player, right? Could be a config issue.

    I'm not sure what you mean with Debug mode 1 or 2. The issue your are describing happened to me quite a lot during development but to me it looked like a Windows driver issue. Things got messed after a while swapping between USB IR devices.
    It's happening on my production system.
     
    • Like Like x 1
  8. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    yes that could be.
    Will try and sort it out.

    in the mean time, its good if some can reproduce the OK behavior. :)
     
    • Like Like x 1
  9. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Yep you were right. for some reason issue is gone again.. LOL

    Sorry for scaring us :)
     
  10. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    Takes more than that to scare me :)

    I fixed the double keys issue. One can now specify if a button supports repeat in the XML file.
    Try if play/pause is fixed. I did not mark previous/next and exit as not supporting repeat.
    I'll try and fix that next. Meanwhile you could also fix it yourself in Generic-HID.xml.
    I'll publish the new build as soon as the bot is ready.

    As far as I can tell this issue is either caused by a lag in the application which appears to be my case with music play/pause.
    If it takes more than half a second for the app to process the request I guess you could have repeat sneaking in.
    Anyway my changes works around those issues nicely.
     
    • Like Like x 1
  11. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    @high bot build seems broken again
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!