MP2 - V2.1 [MP2-554] Installer recognizes Spring '16 as newer (1 Viewer)

Status
Not open for further replies.

tlhackque

Portal Member
June 3, 2015
42
1
Home Country
United States of America United States of America
I have a working MP2 (Spring 2016) installation, and tried to install the MP2.1 preview.

I opened the zip download (released on 29th December 2016) and ran the setup.exe.

The install fails:
Error 0x80070666: Cannot install a product when a newer version is installed.

The installer suggests going to control panel and removing the existing installation - I'm not anxious to lose my configuration.

In any case, installing an upgrade should 'just work'...

Here is the full install log:
[53EC:515C][2017-01-01T07:32:42]i001: Burn v3.10.2.2516, Windows v10.0 (Build 14393: Service Pack 0), path: C:\Users\timothe\AppData\Local\Temp\{88817451-910F-48DB-969C-21433747D639}\.cr\MP2-Setup.exe
[53EC:515C][2017-01-01T07:32:42]i009: Command Line: '-burn.clean.room=C:\Users\timothe\AppData\Local\Temp\MP2-Setup.exe'
[53EC:515C][2017-01-01T07:32:42]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\timothe\AppData\Local\Temp\MP2-Setup.exe'
[53EC:515C][2017-01-01T07:32:42]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'C:\Users\timothe\AppData\Local\Temp\'
[53EC:515C][2017-01-01T07:32:42]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\timothe\AppData\Local\Temp\MediaPortal_2_20170101073242.log'
[53EC:515C][2017-01-01T07:32:42]i000: Setting string variable 'WixBundleName' to value 'MediaPortal 2'
[53EC:515C][2017-01-01T07:32:42]i000: Setting string variable 'WixBundleManufacturer' to value 'Team MediaPortal'
[53EC:253C][2017-01-01T07:32:42]i000: Setting numeric variable 'WixStdBALanguageId' to value 1033
[53EC:253C][2017-01-01T07:32:42]i000: Setting version variable 'WixBundleFileVersion' to value '2.1.1612.9730'
[53EC:515C][2017-01-01T07:32:42]i100: Detect begin, 8 packages
[53EC:515C][2017-01-01T07:32:42]i000: Setting version variable 'D3DX9_41_Version' to value '9.26.952.2844'
[53EC:515C][2017-01-01T07:32:42]i000: Setting version variable 'D3DX9_43_Version' to value '9.29.952.3111'
[53EC:515C][2017-01-01T07:32:42]i000: File search: Dokan_1000_Version, did not find path: C:\WINDOWS\system32\DOKAN1.DLL
[53EC:515C][2017-01-01T07:32:42]i000: Setting version variable 'MFC100_Version_x86' to value '10.0.40219.332'
[53EC:515C][2017-01-01T07:32:42]i000: Setting version variable 'MFC120_Version_x86' to value '12.0.21005.1'
[53EC:515C][2017-01-01T07:32:42]i000: Setting version variable 'MFC140_Version_x86' to value '14.0.23918.0'
[53EC:515C][2017-01-01T07:32:42]i000: Setting string variable 'MFC90_Version_x86' to value '9.0.30729'
[53EC:515C][2017-01-01T07:32:42]i000: Setting string variable 'NETFRAMEWORK45' to value '394802'
[53EC:515C][2017-01-01T07:32:42]i102: Detected related bundle: {668276dd-cd2d-4d76-9e94-f03451bff477}, type: Upgrade, scope: PerMachine, version: 2.16.4.7790, operation: Downgrade
[53EC:515C][2017-01-01T07:32:42]i052: Condition 'NETFRAMEWORK45 >= 378675' evaluates to true.
[53EC:515C][2017-01-01T07:32:42]i103: Detected related package: {030C5302-CDB4-40A3-990A-F5FDD108C3A8}, scope: PerMachine, version: 2.16.4.7790, language: 0 operation: MajorUpgrade
[53EC:515C][2017-01-01T07:32:42]i101: Detected package: NetFx451Web, state: Present, cached: None
[53EC:515C][2017-01-01T07:32:42]i101: Detected package: VC2008SP1_x86, state: Absent, cached: None
[53EC:515C][2017-01-01T07:32:42]i101: Detected package: VC2010_x86, state: Absent, cached: None
[53EC:515C][2017-01-01T07:32:42]i101: Detected package: VC2013_x86, state: Absent, cached: None
[53EC:515C][2017-01-01T07:32:42]i101: Detected package: VC2015_x86, state: Absent, cached: None
[53EC:515C][2017-01-01T07:32:42]i101: Detected package: directx9, state: Absent, cached: None
[53EC:515C][2017-01-01T07:32:42]i101: Detected package: dokan, state: Absent, cached: None
[53EC:515C][2017-01-01T07:32:42]i101: Detected package: MainPackage, state: Absent, cached: None
[53EC:515C][2017-01-01T07:32:42]i199: Detect complete, result: 0x0
[53EC:253C][2017-01-01T07:32:53]e000: Error 0x80070666: Cannot install a product when a newer version is installed.
 

BlueMax1916

Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    702
    125
    Home Country
    Germany Germany
    Country flag
    Hi,

    I had that as I had run weekly releases of MP2. Are you sure you do not have a weekly of MP2 running? I am asking because the weeklys after Spring 16 release still have the Spring 16 release text on the start screen.

    Cheers

    Blue Max
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,366
    3,804
    Lehmden
    Home Country
    Germany Germany
    Country flag
    I'm not anxious to lose my configuration.
    The configuration is not removed by uninstalling. But your Media Library is no longer compatible so you have to rebuild it from scratch nevertheless. This includes all media sources and all metadata. If you want to preserve the watched status you may have a look at:
    https://forum.team-mediaportal.com/threads/mp-2-1-backup-restore.135660/

    Aside the watched flags I would recommend to save only the TVE-Database to not setup the TV Part again. It is compatible to 2.1 After you've saved this, you best uninstall MP 2.0 and then delete all MP2 related folders from Program Files and ProgramData folder. So you don't have any obsolete data laying around on your disk... Depending on the size of your media library this can be something around some GB (especially the old fanart cache is of big size and no longer used)...
     

    tlhackque

    Portal Member
    June 3, 2015
    42
    1
    Home Country
    United States of America United States of America
    Thank you for the quick responses.

    Bluemax1916,

    Yes, I am certain that I'm not running a weekly. I installed Spring 2016 in June, migrating from WMC due to Win10. I haven't updated or installed anything since. In any case, 2.1-pre should be newer than any 2.0+ weekly...

    Lehmden,

    The process that you suggest is too complicated for ordinary users. It should be incorporated into the installer before the pre-release is finalized...

    I understand the need to upgrade metadata formats and delete old caches, but the process should be automated. I don't know (or care) where MP2 stores its files; I install it, I use it as a TV/DVR, and I don't want to understand how it works. (Which is a little bit strange, as I'm an engineer. But I treat MP as an appliance, not a project.)

    At an absolute minimum, step-by-step instructions must be available to upgraders.
     

    tlhackque

    Portal Member
    June 3, 2015
    42
    1
    Home Country
    United States of America United States of America
    Also, deleting ProgramData\Team MediaPortal\MP2-Server would remove

    \ProgramData\Team MediaPortal\MP2-Server\SlimTVCore\v3.0\WebEPG\grabbers\US\www_imdb_com_*.xml, which is the (painfully created) EPG mapping used here.

    That would not be good. So it is really important to have an automated upgrade process that does what is necessary, but no more.
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    Yes, I am certain that I'm not running a weekly. I installed Spring 2016 in June, migrating from WMC due to Win10. I haven't updated or installed anything since.
    We will happily take your word for that.;) However, please provide full logs, and we will then be able to see the build number.

    In any case, 2.1-pre should be newer than any 2.0+ weekly...
    Weekly's are provided as development builds. They cannot be upgraded.

    The process that you suggest is too complicated for ordinary users. It should be incorporated into the installer before the pre-release is finalized...
    Considerably time has been spent to achieve exactly this behavior. Unfortunately it turned out that it is not working as expected and was therefore abandoned.

    At an absolute minimum, step-by-step instructions must be available to upgraders.
    It is difficult if not impossible to address every single possible environment. Somebody like you, who is everything but the classical computer dummy, probably knows about the possibilities of renaming or copying folders.

    I believe that your issues stem from not upgrading from the classical Spring 16 - awaiting your logs of the old install to verify this assumption.
     

    tlhackque

    Portal Member
    June 3, 2015
    42
    1
    Home Country
    United States of America United States of America
    When it comes to MP, I am indeed a "classical computer dummy", and trying to stay that way :). Otherwise, I'm reasonably competent.

    Where would I find the old install log? I looked in Program Data\Team MediaPortal ... and while there are lots of logs, none appeared to be an install log.

    To identify the build, I looked at Program Files (x86)\Team MediaPortal\MP2-Server\MP2-Server.exe, which has the following properties:

    File version 2.16.4.7790
    Product version origin/SpringRelease 16-1c352a Date modified 05-Apr-16 19.14

    I saved the original install kit:
    MP2-Setup-Spring16.zip 8f42d720e00e7ff18741ad81e4c9f071 (MD5)
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    Where would I find the old install log?
    Just use the LogCollector to zip everything that you have together. Hopefully old logs still exist.

    which has the following properties
    My intention is not to prove you wrong. We tested this installation procedure thoroughly and the fact that you receive the 0x80070666 error is a sign that there are file versions not belonging to the original Spring '16 package. The important thing for us would be to prove if this is wrong or right and possibly analyze this in more depth.

    Step-by-step instructions for your particular case would be:
    • Open the TV configuration and under Import/Export go to the Export tab, tick all entries and export your TV settings to a file.
    • Rename your C.\ProgramData\Team MediaPortal folder to something else.
    • Uninstall MP2 Spring '16
    • Uninstall Dokan 0.5.3
    • Install MP 2.1pre
    • Open the TV Configuration and import the previously saved setting file
    • Restart MP2 TV Service
    • Do the MP 2.1 setup from the client GUI
    Now start copying any information such as the grabber files into the new Team MediaPortal folder.
     
    Last edited:

    tlhackque

    Portal Member
    June 3, 2015
    42
    1
    Home Country
    United States of America United States of America
    I do understand that you are trying to help. I didn't know about log collector, so I provided what info I could. (As I said, I'm a MP dummy.) I found it. logs attached.

    I provided the entire MP2.1-pre install log - I don't see where it reported what file it thinks is "new". Perhaps I'm missing it, but if not it would be helpful if the log reported the file...

    I'm happy to gather any other data that you need.

    Besides struggling with the EPG mapping I haven't modified any MP files since installation. I did install some plugins back then, though I don't remember exactly what they were...

    Do you want to track down this issue before I attempt to install 2.1? Upgrading isn't time-critical for me, so it doesn't make sense to uninstall if that would preclude further analysis.
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    I did install some plugins back then, though I don't remember exactly what they were...
    That could be the reason.

    Do you want to track down this issue before I attempt to install 2.1?
    No, please go ahead. We haven't had any other report of your kind so far. Some issues might be better resolved by a simple reinstall. It will be fairly quick in your case.
     
    Status
    Not open for further replies.

    Users who are viewing this thread

    Similar threads

    Der DirectX-WebInstaller wird nicht richtig ausgeführt. Lade und installiere das DX9-Runtime separat (Link). Danach MP2 erneut installieren.
    Der DirectX-WebInstaller wird nicht richtig ausgeführt. Lade und installiere das DX9-Runtime separat (Link). Danach MP2 erneut...
    0xfffffff7 unbekannter Fehler log file:
    Replies
    1
    Views
    593
    got it, and it worked. Thanks!
    got it, and it worked. Thanks!
    MP1 installs and runs with no problem, But MP2 errors out - seems to exit at the Direct X9 install. System is a newer comp w/win...
    Replies
    3
    Views
    949
    • Locked
    Indeed. My concern was that neither 2.1.3 Pre-Release, nor 2.2 development currently result in a successful installation in this situation, and that people may preferentially view 2.1.3 as the current stable.
    Indeed. My concern was that neither 2.1.3 Pre-Release, nor 2.2 development currently result in a successful installation in this...
    Hello all, I would like to try MediaPortal 2, but have run into a show stopping installation bug. The installation fails with...
    Replies
    19
    Views
    3K
    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my keyboard just fine (also lightspeed wireless). Suggestions?
    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my...
    Good evening, having just fresh installed media portal 2.3.2. Looking at trialing again as it now seems to support what I am...
    Replies
    1
    Views
    193
    MP1 MP2 Error on install DE
    Yes, but it is not found: Manual installation should solve it directly. I'm not sure, if 4.7.1 will work. MP2 expects 4.7. I checked and we have not updated yet.
    Yes, but it is not found: Manual installation should solve it directly. I'm not sure, if 4.7.1 will work. MP2 expects 4.7. I...
    cant install on a new Windows 10 PC Log is [0E98:1734][2018-04-08T19:17:59]i001: Burn v3.11.0.1701, Windows v10.0 (Build 10240...
    Replies
    3
    Views
    2K
    Top Bottom