MP2 - V2.3 MP2 Server stürzt immer nach kurzer Zeit ab (1 Viewer)

rainbowforest

Portal Pro
June 30, 2010
82
15
Vienna
Austria Austria
Country flag
Wichtig: MP2.2.3 hatte noch keine x64 Unterstützung, deswegen wird der Client wohl auch nur in x86 laufen nach dem Austausch.
Das ist witzig, weil es sehr wohl mit dem 64 Bit Client einwandfrei lief :)

Dennoch, den Server ließ ich dann ohne aktiven Client laufen um eben gegenseitige Beeinflussungen auszuschließen.

Werde das mit den Client Dateien nun probieren
 

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,321
    2,612
    Stuttgart
    Germany Germany
    Country flag
    Das ist witzig, weil es sehr wohl mit dem 64 Bit Client einwandfrei lief
    Jetzt bin ich durcheinander, war die Info irgendwo erwähnt vorher?
    • 2.3 Server mit x64 2.3 Client läuft durch?
    • 2.3 Server mit x86 2.3 Client stürzt nach 30 Minuten ab?
     

    rainbowforest

    Portal Pro
    June 30, 2010
    82
    15
    Vienna
    Austria Austria
    Country flag
    sorry, hab mich verlesen. MP Version: 2.3.1
    Ohne TVE (server): läuft
    Mit TVE 2.3.1 crash
    mit TVE 2.2.3 crash

    gestestet mit 64 Bit GUI Client (und ohne)

    Hab jetzt die Client Plugins ausgetauscht (TVE Server ist noch immer 2.2.3).
    Aufruf mit 32 Bit GUI Client -> Kein TV mehr (in der Oberfläche und auch direkt Aufruf mit Live TV an der IR funktioniert nicht)
    Ob der Server durchhält (was aber nur für euch interessant ist, weil für mich ohne TV useless), weiß ich in ca. 20min

    Update: crasht genauso (kein Client aktiv)

    Die Vermutung liegt für mich nahe, dass es der MP Server selbst ist
     
    Last edited:

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,321
    2,612
    Stuttgart
    Germany Germany
    Country flag
    sorry, hab mich verlesen. MP Version: 2.3.1
    Ohne TVE (server): läuft
    Mit TVE 2.3.1 crash
    mit TVE 2.2.3 crash

    gestestet mit 64 Bit GUI Client (und ohne)

    Hab jetzt die Client Plugins ausgetauscht (TVE Server ist noch immer 2.2.3).
    Aufruf mit 32 Bit GUI Client -> Kein TV mehr (in der Oberfläche und auch direkt Aufruf mit Live TV an der IR funktioniert nicht)
    Ob der Server durchhält (was aber nur für euch interessant ist, weil für mich ohne TV useless), weiß ich in ca. 20min

    Update: crasht genauso (kein Client aktiv)

    Die Vermutung liegt für mich nahe, dass es der MP Server selbst ist
    Der Server selbst ist es nicht, der läuft ja ohne TV-Plugin durch.
    @morpheus_xx kannst du eine 2.3.1 erstlellen ind der das Update der TVE3 von 3.0.23.100 auf 3.0.21.2 zurückgestellt wird?
    Das manuelle Austauschen der Plugins hat wohl nicht ganz funktioniert.
    Oder hast du eine andere Idee?
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,308
    3,778
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Auch auf die Gefahr hin, mich zu wiederholen... Bei mir (und vielen Anderen) stürzt der Server nicht ab, egal ob mit oder ohne TVE Plugin... Ein generelles Problem scheidet meiner Ansicht nach deswegen aus. Es muss etwas sein, was mit der Hardware, sonstigen Software oder den Einstellungen der Leute zusammenhängt, welche dieses Problem haben...

    Ich starte meinen TV Server einmal pro Tag (um ca 4:00 Uhr nachts) automatisch neu. Sonst läuft er 24/7 durch, und das seitdem ich die MP 2.3 Version installiert habe. Währenddessen habe ich neben meinem SAT>IP Tuner, der ständig aktiv ist, auch mal verschiedene DVB-S2 Tuner- Karten (DD und DVBSky) eingebaut und wieder ausgebaut. Nichts davon hat den Server irgendwie erschüttert... Selbst das parallele Installieren von NextPVR hat kein bisschen gestört... Schließlich habe ich jetzt ein 8-Fach Unicable System, da kann man ja auch mal mehr als 4 Tuner verwenden...

    Ich hatte (zu) viele Probleme beim Installieren der 2.3. Der Installer ist dieses Mal nicht wirklich gelungen. Ich musste sowohl DirectX 9 als auch mehrere VC Runtimes von Hand installieren, bevor ich MP2 überhaupt auf meinem frisch aufgesetzten Win 10 Pro 20H2 x64 installieren konnte. Außerdem musste ich noch die media.dll austauschen. Etwas zu viel Handarbeit, wenn du mich fragst... Aber seitdem das Ding endlich läuft, war und ist es wirklich stabil, zumindest hier. Und ich nutze MP2 ausschließlich für TV, habe aber auch ein paar Medien importiert, rein aus Test- Gründen...
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,321
    2,612
    Stuttgart
    Germany Germany
    Country flag
    Da es mit 2.2.3 keine Probleme gibt ist es zu einfach es nur auf die Hardware zu schieben. Es gab eine Änderung im TV Plugin und diese scheint die Probleme zu verursachen. Es sind auch schon 2 User, die das Problem melden, statistisch rückblickend, wird es dadurch bestimmt viele User betreffen. Ich wiederhole mich da auch gerne, wir sollten das TV-Plugin einmal zu Testzwecken zurücksetzen auf die vorherige Version und es dort belassen, wenn es wieder funktioniert. Aber das überlasse ich unseren Devs, die sich hoffentlich mal melden. Ich kann hier leider nichts mehr beisteuern.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,308
    3,778
    Lehmden
    Germany Germany
    Country flag
    Da es mit 2.2.3 keine Probleme gibt ist es zu einfach es nur auf die Hardware zu schieben.
    Das lag mir fern. Das Problem kommt aber eben nur selten vor, denn sonst hätten wir sicher viel mehr als 2 User gehabt, die sich darüber beklagen. Wenn etwas problemlos läuft, meldet sich niemand. Nur wenn es nicht funktioniert, dann meldet sich so ziemlich jeder. An eine sehr hohe "Dunkelziffer" glaube ich deswegen nicht wirklich. Also muss bei diesen Usern irgendwas speziell und anders sein, als bei den meisten anderen Nutzern... Das gilt es nun herauszufinden und dafür zu sorgen, dass dass neue TVE Plugin diese Probleme nicht mehr hat. Wenn wir davon ausgehen, das alle das gleiche Plugin verwenden, muss es nun mal bei den Usern mit Problemen irgendwas Externes (Hard- oder Software) geben, was unglücklich mit dem neuen Plugin interagiert. Wäre es ein generelles Problem, würde das Plugin (fast) nirgends laufen...
    Das "Externe" kann so ziemlich alles sein, von AV und anderen "Sicherheitsprogrammen" über Treiber (muss nicht zwingend der Treiber des Tuners sein, kann auch die Maus oder Soundkarte sein...) bis hin zu Wartungsaufgaben von Windows, die hier anders eingestellt sind, als bei den Usern, bei denen es läuft. Daneben natürlich alles an Diensten und Programmen, die permanent laufen oder ggfs gerade nach 30 Minuten im Hintergrund gestartet werden. Davon gibt es leider unzählige, so das es recht schwierig wird, den tatsächlichen Verursacher bzw. den Task, der nicht mit dem TVE Plugin kann, zu identifizieren.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,321
    2,612
    Stuttgart
    Germany Germany
    Country flag
    Das Problem kommt aber eben nur selten vor, denn sonst hätten wir sicher viel mehr als 2 User gehabt, die sich darüber beklagen. Wenn etwas problemlos läuft, meldet sich niemand. Nur wenn es nicht funktioniert, dann meldet sich so ziemlich jeder. An eine sehr hohe "Dunkelziffer" glaube ich deswegen nicht wirklich.
    Das glaube ich nicht. Die nicht funktionierende x64 Version galt für alle Nutzer und wurde auch nur von 3 gemeldet.
    Wenn 2 Nutzer den Fehler früh melden, dann kommen meist wenige Meldungen nach, da viele Leute zum glück doch erst die Suchfunktion verwenden und dann im Thread folgen. Die meisten Nutzer verfahren eh nach dem Prinzip: Installieren, geht nicht, deinstallieren und MP2 ist abgeschrieben. Die Mühe sich einen Account im Forum machen sind nur wenige Leute.
    Wie auch immer, das Problem muss erkannt und verbessert werden.
     

    rainbowforest

    Portal Pro
    June 30, 2010
    82
    15
    Vienna
    Austria Austria
    Country flag
    Möchte die Diskussion nicht unnötig anheizen, aber es wurden zwei Threads zusammengeführt und wenn ich mich richtig erinnere, waren es zumindnest 5 (mich eingeschlossen) User, die das Problem haben/hatten.

    Und ja, ein Unterschied muss sein da ja (wie bei den anderen auch), 2.2.3 tadellos läuft.

    Dann kommt noch dazu, dass die 2.3 sehr neu ist und sich viele dessen nicht bewusst sind oder scheuen, auf eine neue Version upzugraden. Und ja, MP ist halt nicht so einfach im Handling, wie es zB ein WMC war, daher ist hier an einem funktionierenden System zu drehen, nicht jedermanns Sache.

    Morpheus hat sich ein Stunde lang auf meine Rechner umgesehen und Logs studiert, aber nichts gefunden was die Abstürze außerhalb MP's erklären könnte. Nur so nebenbei.

    Wiewohl ich natürlich auch langsam überlege zurück zur 2.2.3 zu gehen da im Moment halt gar nichts geht
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,321
    2,612
    Stuttgart
    Germany Germany
    Country flag
    Verwendet jemand mit den Serverabstürzen das TvWishList plugin?
    Könnte bitter jeder mit den Problemem, sofern noch nicht getan, bitte log files hochladen? Bislang ist das nur von einer Person geschehen, vielleicht ergeben sich daraus neue Erkenntnisse.
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    N [solved] MP2 TV-Server DD cine 2 V6, Astra keine deutschen Sender mehr General 4
    Lehmden [WiP] [MP2-824] DLNA Server functionality MediaPortal 2 27
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    J [fixed] [MP2-833] 2.2.2 server crash during import Submit: Bug Reports 50
    P MP2 TV Server crashes when starting - throws error remoting exception General 2
    raffe How do I setup MP2 as an UPnP server? General 3
    Tim [further infos missing] MP2 Server crashes on channel scan 2.2 Archive 9
    A Help! MP2 - DVB-T Not recognised (DRIVERS?) General 12
    joecool70 [solved] Installationsprobleme: MP2-Server failed to start Allgemeines Support- und Diskussionsforum 25
    BlueMax1916 [Question] What does MP2 Server Service have to do with ...microsoft.com/filestreamingservice...? MediaPortal 2 3
    J [solved] Clients do not see available MP2 server in the network General 3
    Patrik-See Win 10 Benutzer bei verschiedenen Clients Betriebssysteme 4
    ge2301 MP2 - V2.4 [MP2-867] Dynamic font scaling for EPG programs in relation to number of rows MediaPortal 2 2
    ge2301 MP2 - V2.4 [MP2-866] Optimize Nereus for touch displays MediaPortal 2 20
    J MP2 - V2.3.2 MP2 service keeps crashing within a few seconds of startup Submit: Bug Reports 10
    S External player in MP2 and see videos made with my cam? General 8
    P MP2 TV Recording Logs General 1
    T MP2 - V2.3 MP2 Won't Restart, Requires System Reboot Submit: Bug Reports 2
    ge2301 MP2 - V2.4 [MP2-863] Extend View Mode Settings MediaPortal 2 8
    porky996t Outdated Tuning Parameters in MP2 TVServer Config TV-Server 0
    B IRSS shows button presses, nothing happening out-of-the-box in MP2 Newcomers Forum 1
    D MP2 DLNA status? General 10
    H MP2 - V2.4 [MP2-855] Extend Nereus HomeMenuEditor to allow configuration of HomeContent features MediaPortal 2 23
    M MP2 - V2.3 MP2 & USB Problems Submit: Bug Reports 43
    L MP2 - V2.3 Troubles upgrading from MP2 2.2.3 to 2.3 General 0

    Similar threads

    Top Bottom