Music playback hangs (4 Viewers)

ajs

Development Group
  • Team MediaPortal
  • February 29, 2008
    11,844
    6,694
    Kyiv
    Ukraine Ukraine
    Country flag
    Try turning off settings one at a time:
    • Gapless playback
    • Fade in / Fade out
    • Replay gain
    I can’t find it, but it seems to me which of these settings is not supported normally in WASAPI mode.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,631
    1,231
    Germany Germany
    Country flag
    With the following steps I can reproduce the issue:
    1. Enable WASAPI
    2. Add the previously attached track and another track to the playlist and play it
    3. Wait for the first track to end
    That worked ok for me too, see attached screenshot, at the end of the first track the Bon Jovi track played to end.
    music3.jpg

    Try turning off settings one at a time:
    • Gapless playback
    • Fade in / Fade out
    • Replay gain
    I can’t find it, but it seems to me which of these settings is not supported normally in WASAPI mode.
    Yes that is interesting.. If Fade in / Fade out is enabled and you then set Gapless playback, the Fade in / Fade out is disabled automatically (like it is either or) but it is then possible to re-enable Fade in / Fade out so not sure.:unsure:
     

    horned_reaper

    Test Group
  • Team MediaPortal
  • January 7, 2011
    914
    348
    Munich
    Germany Germany
    Country flag
    Now I had the same error with another audio file (see attached file), although all mixing options were disabled:
    1585848831964.png


    Although Fade-in / Fade-out is disabled, MediaPortal fades in and fades out when I skip to the next track.

    It looks like MediaPortal ignores the setting:
    <entry name="crossfade">4003</entry>
    <entry name="buffering">10</entry>
    <entry name="useSkipSteps">no</entry>
    <entry name="fadeOnStartStop">no</entry>
    <entry name="gaplessPlayback">no</entry>
    <entry name="enableReplayGain">no</entry>
    <entry name="enableAlbumReplayGain">no</entry>
    <entry name="streamOutputLevel">80</entry>
    <entry name="asiobalance">0</entry>
    <entry name="wasapiExclusive">no</entry>
    <entry name="upMixMono">0</entry>
    <entry name="upMixStereo">0</entry>
    <entry name="upMixQuadro">0</entry>
    <entry name="upMixFiveDotOne">0</entry>
    <entry name="enableResume">no</entry>
    <entry name="resumeAfter">10</entry>
    <entry name="resumeSelect">
    </entry>

    Setting Buffering to low or max levels doesn't help.
     

    Attachments

    Last edited:

    horned_reaper

    Test Group
  • Team MediaPortal
  • January 7, 2011
    914
    348
    Munich
    Germany Germany
    Country flag
    If I set the Cross-fading value to 0 there's no fading on track skip but the error remains nevertheless.

    The "Fade-in on start / fade-out on stop" option takes no effect at all, also in normal BASS mode. Regardless if enabled or disabled, the volume always fades in at start but never fades out on stop.

    "GCHandle of Musicstream not found in Dictionary -2147483346 The key was not specified in the directory." What does that mean? What's GCHandle?

    I still have the suspicion that there's a dependency between WASAPI mode, the Fade-in/out option and/or the cross-fading option.
    Can we do a test and completely disable these options in the code?
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 4)

    OP Similar threads Forum Replies Date
    M Music playback stops after certain files 1.19 0
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    horned_reaper [Music] 5012: Start current music track from the beginning Improvement Suggestions 21
    horned_reaper [solved] 5012: Restart current music track General Support 13
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    globaldonkey Music Database Error Listen Music 1
    joecrow Music on Headphones Listen Music 7
    2BitSculptor MP 1.23.. music stops playing General Support 6
    Sarxas What Music Are You Listening To? OffTopic 0
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    G [fixed] [MP2-786] Party Music Player can only play playlists with less than 1000 items 2.2 Archive 7
    KlausWirn Music crash Bass crash no change to play music Installation, configuration support 2
    BlueMax1916 [confirm] Music: Every 2nd track skipped MediaPortal 2 30
    N Music player help Listen Music 4
    N How to shuffle all my music, and how to sort by album artist General 4
    R MP 2.2 client spielt audio-titel kurz an und springt dann zum nächten Allgemeines Support- und Diskussionsforum 9
    joecrow Music: Fade Out not working 1.20 Pre Release 0
    E [Pending] Handling Multifile Cue Submit: code patches (MediaPortal/TV-Server/etc.) 56
    X Music : WASAPI only plays one track then stops General Support 1
    K Flickering live TV playback Newcomers Forum 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    doskabouter [Help Me!] Playback of iTunes Movie Trailers Developer Discussions 0
    I Video Playback Stuttering General Support 45
    Similar threads

























    Top Bottom