Music playback hangs (1 Viewer)

doskabouter

Development Group
  • Team MediaPortal
  • September 27, 2009
    3,519
    1,719
    Nuenen
    Netherlands Netherlands
    Country flag
    Is this comething related to the new bass version? If so, perhaps we should get in contact with the bass developers, because this seems like something internally in the bass-lib is really going wrong
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    12,056
    6,845
    Kyiv
    Ukraine Ukraine
    Country flag
    Is this comething related to the new bass version?
    I have other glitches with music, and they last a long time and have not found a solution. I don’t think that even here something can be radically solved. I do not know the music engine and how it works. Maybe @hwahrmann will tell something :coffee:
    If so, perhaps we should get in contact with the bass developers, because this seems like something internally in the bass-lib is really going wrong
    Perhaps the matter is in the engine, in the C# library or in the BASS library or in the BASS itself. I dont know. But we need to find a 100% error for the appeal, and so that it repeats on any computer. :)
     

    horned_reaper

    Test Group
  • Team MediaPortal
  • January 7, 2011
    917
    348
    Munich
    Germany Germany
    Country flag
    Can someone else try to reproduce this issue following these steps?
    1. Enable WASAPI in the MP configuration
    2. Start MediaPortal
    3. Add attached track to the first position and another track to the second position of the playlist
    4. Play the playlist (if not already playing)
    5. Wait for the first track to end

    Result: The music playback stops at the end of the first track and the second track isn't played.
     

    Attachments

    horned_reaper

    Test Group
  • Team MediaPortal
  • January 7, 2011
    917
    348
    Munich
    Germany Germany
    Country flag
    @joecrow Could you please try to reproduce this issue with this attachment, when all mixing options (replay gain, fade-in/fade-out, gapless playback) are disabled?
    1. Enable WASAPI in the MP configuration
    2. Start MediaPortal
    3. Add attached track to the first position and another track to the second position of the playlist
    4. Play the playlist (if not already playing)
    5. Wait for the first track to end

    Result: The music playback stops at the end of the first track and the second track isn't played.
     

    horned_reaper

    Test Group
  • Team MediaPortal
  • January 7, 2011
    917
    348
    Munich
    Germany Germany
    Country flag
    Will do but may not be till later today, other things to do.;)
    Thanks!

    I just found out that it's even easier to reproduce the issue. Just the this file needs to be played.
    Result: The playback stops six seconds before end of the track, the Playing Now screen hangs and the following error is logged:
    [ERROR] - BASS: GCHandle of Musicstream not found in Dictionary

    This happens regardless if mixer options (replay gain, fade-in/fade-out, gapless playback) are enabled or not.
    And it also happens with BASS engine player, not only with WASAPI player!

    With other media players like Windows Media Player the file is played without issues.

    This issue was reported by another user as well:

    And this error message was already handled by @Sebastiii and @hwahrmann:
    Apparently this issue has not been completely fixed.

    @ajs Can you reproduce this issue with BASS engine player?
     

    Attachments

    Last edited:

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,639
    1,233
    Germany Germany
    Country flag
    I just found out that it's even easier to reproduce the issue. Just the this file needs to be played.
    Result: The playback stops six seconds before end of the track, the Playing Now screen hangs and the following error is logged:
    [ERROR] - BASS: GCHandle of Musicstream not found in Dictionary
    The same result for me but that track does seem to be corrupt in some way. It should play 5.21 but as you noticed it finishes, early, for me 10 or so seconds, following some kind of skip on the 5 .00 minute point and it does exactly the same when played with Windows Groove Music and MPC-BE though I have not yet tested with those player in a playlist.
    Ongoing.

    UPDATE:- If that BJH track is included in a playlist in both MPC-BE and Groove Music next track does play so yes something flaky/over sensitive in MP music player.:eek:
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M Music playback stops after certain files 1.19 0
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    horned_reaper [Music] 5012: Start current music track from the beginning Improvement Suggestions 21
    horned_reaper [solved] 5012: Restart current music track General Support 13
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    globaldonkey Music Database Error Listen Music 1
    joecrow Music on Headphones Listen Music 8
    2BitSculptor MP 1.23.. music stops playing General Support 6
    Sarxas What Music Are You Listening To? OffTopic 0
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    G [fixed] [MP2-786] Party Music Player can only play playlists with less than 1000 items 2.2 Archive 7
    KlausWirn Music crash Bass crash no change to play music Installation, configuration support 2
    BlueMax1916 [confirm] Music: Every 2nd track skipped MediaPortal 2 30
    N Music player help Listen Music 4
    N How to shuffle all my music, and how to sort by album artist General 4
    R MP 2.2 client spielt audio-titel kurz an und springt dann zum nächten Allgemeines Support- und Diskussionsforum 9
    joecrow Music: Fade Out not working 1.20 Pre Release 0
    E [Pending] Handling Multifile Cue Submit: code patches (MediaPortal/TV-Server/etc.) 56
    S Resume Playback Annoyance Newcomers Forum 3
    K Flickering live TV playback Newcomers Forum 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    doskabouter [Help Me!] Playback of iTunes Movie Trailers Developer Discussions 0
    I Video Playback Stuttering General Support 45
    Similar threads

























    Top Bottom