My Anime 2 | Page 34

Discussion in 'MediaPortal 1 Plugins' started by lwerndly, June 2, 2009.

  1. Thade

    Thade New Member

    Joined:
    June 8, 2009
    Messages:
    2
    Likes Received:
    0
    Ratings:
    +0 / 0
    Lost a series

    Hello,

    first, thanks for the good work. This plugin really rocks.



    Then I have a little Problem. I have been in the episode view of a series and mediaportal crashed.
    Now this series is missing completly. It is just gone (Files are not gone, but ther series is not listed in the plugin). Run Import did't help either.

    I surely could add the series again manually, but would like to know if there is a way to get it back with automated scanning.

    Cheerz,
    Thade
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. HimuraX03

    HimuraX03 Portal Member

    Joined:
    June 28, 2008
    Messages:
    7
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Bert_R,

    I went ahead and pulled down the new DLL and copied it to the MediaPortal folder. I ran the DLL registration for the MediaInfo_InfoTip.dll and everything registered correctly. I still get nothing imported/listed on MyAnime2 within MediaPortal. When I run an import or cleanup I see the queue for the AniDB build up, but then it reverts back to 0 and displays "OTHER:LoginFailed:" as it was doing before.

    I'm attaching the latest logs (MediaPortal and MyAnime2).

    Thanks for all the help so far,

    HimuraX03
     
  4. mpiva

    mpiva Portal Member

    Joined:
    June 29, 2009
    Messages:
    20
    Likes Received:
    4
    Ratings:
    +4 / 0
    Home Country:
    HimuraX03:

    Does you AniDB User or Password have some special characters (not letters or numbers). Also what charset/language are you using in Windows? (Example: French, Spanish, German, English, Chinese, Japanese)
     
  5. HimuraX03

    HimuraX03 Portal Member

    Joined:
    June 28, 2008
    Messages:
    7
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Anime DB User and password use only letters (uppercase and lowercase) and numbers only.

    Windows is using English as the character set. I've not installed anything new or different....pretty much basic install of Windows 7.

    I archived the latest release of My Anime 2 that I had installed and decided to try and use an older version of the My Anime 2 plugin (v2.0.7). The import runs as it usually does but the error still occurs when it tries to get info from AniDB. The error in the MediaPortal.log (assuming this version didn't yet implement a separate log file) and it reads:


    2009-08-10 22:38:09.910498 [Info.][12]: socketResponse: 505 ILLEGAL INPUT OR ACCESS DENIED​


    I just verified the user ID and password to my AniDB account and everything works fine there....my account doesn't appear to be locked out or banned.

    Thanks,

    HimuraX03
     
  6. bert_r

    bert_r Portal Pro

    Joined:
    April 7, 2009
    Messages:
    110
    Likes Received:
    16
    Ratings:
    +16 / 0
    Home Country:
    Belgium Belgium
    I'm sorry HimuraX03, I've directed my post to the wrong person, it was actually as a solution to tgxiii's problem to load blue-ray files ... and regarding that, just replacing the MediaInfo.dll should be enough. No extra dlls are necessary and no extra action is necessary (like dll registration).
     
  7. mpiva

    mpiva Portal Member

    Joined:
    June 29, 2009
    Messages:
    20
    Likes Received:
    4
    Ratings:
    +4 / 0
    Home Country:
    Pretty strange behavior HimuraX03, i'll continue to do blind shoots to try to isolate your problem.

    Try disable temporary the Windows and other possible firewalls in your machine, including some anti-virus that have internet protection. I don't see any problem in the udp login request, my first thought was you're using some reserved char like '&' in your user or password. Do you use any other AniDB.NET client?
     
  8. Raytestrak
    • Premium Supporter

    Raytestrak MP Donator

    Joined:
    April 12, 2008
    Messages:
    497
    Likes Received:
    21
    Occupation:
    IT Engineer
    Location:
    Honselersdijk
    Ratings:
    +21 / 0
    Home Country:
    Netherlands Netherlands
    I just reinstalled my htpc and kept a copy of my old database. For some reason, after running an import, all my entries are shown twice, but all to the same path.
    It looks like the registration in the database is case sensitive. I have entries pointing to \\Opteron185\Anime\etc and to OPTERON185\Anime\etc. The target is identical, but the registration is shown twice, for every episode. Can I fix this myself easily or can you ignore upper- and lowercase differences in the new version?
     
  9. bert_r

    bert_r Portal Pro

    Joined:
    April 7, 2009
    Messages:
    110
    Likes Received:
    16
    Ratings:
    +16 / 0
    Home Country:
    Belgium Belgium
    When reinstalling the PC name is probably changed from lower- to uppercase or the opposite. This seems indeed to be bug (see Issue #65).

    Seeing you can access the database yourself, I think it would be best to delete the duplicate entries manually. Make sure you delete the old entries (otherwise the other ones will be re-inserted). This query for example will delete everything starting with \\0PTERON185\:
    delete from FileLocal where sub_str(FileNameFull,0,13)='\\0PTERON185\'​
    (Replace the 'sub_str' with 'substr'; The forum was choking on my post otherwise ... some anti-sql-injection tactic?)
    Note that we can't use the sql LIKE syntax because that's case insensitive, while '=' is case sensitive.


    Could you try running 'cleanup database' in the utilities screen, and then try 'run import' again? That should fix any inconsistencies in the database caused by the crash.
    Also, do you have any logs/dumps from the crash? It appears as if the plugin might have caused the crash, so I'd like to see if we can fix that.
     
  10. els

    els Portal Pro

    Joined:
    May 9, 2009
    Messages:
    89
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Brazil Brazil
    Trouble in Run Import: AniDB = OTHER: LoginFailed!?

    Hi.
    Trouble in Run Import: AniDB = OTHER: LoginFailed

    Always displays the error message: OTHER: LoginFailed. Username and Password are correct and functional in AniDB.net.

    Any tips?

    More information:
    MediaPortal: 1.0.2.22555
    Windows: Vista SP1
    My Anime: 2.0.12.0
    AniDB: Username: only words - Password: only words and numbers (not *&()- etc.)
    Anime2 Config (MAIN/Folders): D:\HTPC - VIDEOS\ANIMES
    Anime2 Config (UTILITIES/Drop Folder): D:\HTPC - PLUGINS\My Anime\Drop Folders
    Anime2 Config (UTILITIES/Root Destination Folder): D:\HTPC - PLUGINS\My Anime\Root Destination Folder

    ...els...

    :D
    Obs.: I read previous post, but did not understand correctly ...
     
  11. FdL

    FdL Portal Pro

    Joined:
    April 17, 2009
    Messages:
    99
    Likes Received:
    0
    Ratings:
    +0 / 0
    Weird thing happened, ran an import on my burned dvd with Higurashi no nako koro ni kai (the second series, I already had the first series properly into the database). It doesn't appear anywhere. Not imported, not as additional season to the first one, not as unrecognized files, not as unrecognized series.
    Rescan does nothing. No traces of it ever having been scanned show anywhere. I wasn't there when I scanned it, so I don't know if it ever did. The files are there, readable and stuff.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!