No HD picture with MP 1.0 | Page 8

Discussion in '1.0 final and SVN Builds' started by wjw, January 5, 2009.

  1. sshaikh

    sshaikh Portal Member

    Joined:
    May 11, 2009
    Messages:
    14
    Likes Received:
    0
    Ratings:
    +0 / 0
    Is there a definitive list of codecs which work with TsReader.ax and all channels then? Or even on a per-channel basis? Assuming this isn't a HW specific problem - I've tried with ffdshow and MPC-HC filters and neither work.



    Maybe a table of (codec, HWdecode on/off, confirmed channels) will do? What codecs are the development team using?

    Is rolling back to the TsReader in this thread still an acceptable/recommended solution? What features do we lose?
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. sshaikh

    sshaikh Portal Member

    Joined:
    May 11, 2009
    Messages:
    14
    Likes Received:
    0
    Ratings:
    +0 / 0
    I'm having trouble registering the TSreader.ax - regsvr32 reports that it registered okay, but it then refuses to be used in MP. Only video processed via haali is shown. When registering this, are there any other files that should be registered too at the same time?
     
  4. wjw

    wjw Portal Pro

    Joined:
    July 13, 2008
    Messages:
    320
    Likes Received:
    20
    Ratings:
    +34 / 0
    Home Country:
    United Kingdom United Kingdom
    I can't give you a definitive answer because I've never seen one, only what has worked for me.

    I am currently using 1.0, together with the TSReader provided earlier in this thread. The TSReader installed with 1.0 didn't work for me - it simply would not display HD (in my case the h264 stream provided by BBC HD from the Astra satellite). If you use the replacement you don't need to register it, just install 1.0 then rename the TSReader.ax file in the C:/Program Files/TeamMediaPortal folder and copy in the new one. For me, this works with all the codecs on my system - including the Cyberlink codec which I find provides the best picture (I have a copy of Powercinema 5 acquired earlier where there are none of the restrictions that new versions of Cyberlink software impose on use of their codecs). If you don't have a Cyberlink codec then ffdshow worked fine, amongst others.

    I don't have hardware acceleration on my system.

    I have upgraded both to 1.0.1 and 1.0.2. Neither worked successfully for me. 1.0.1 wouldn't produce any HD picture and 1.0.2 would only work with the "PCM H.264/AVC Decoder" - which for me, at least, didn't produce as good an image as the Cyberlink one. 1.0.2 wouldn't work with anything else on HD.

    I have therefore reverted to 1.0 - although I have another problem on which I am about to try and get help in a new thread.
     
  5. infinite.loop
    • Team MediaPortal

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
    i have no troubels at all with HD LiveTV, recorded TV (h264) using a plain MediaPortal 1.0.2 installation.

    divx7-h264, coreavc 1.9.5 and cyberlink PDVD9 codecs are working nicely without any issues.
    using an oudated tsreader will _not_ work inside MediaPortal 1.0.2 because of other changes it relies on.
     
  6. sshaikh

    sshaikh Portal Member

    Joined:
    May 11, 2009
    Messages:
    14
    Likes Received:
    0
    Ratings:
    +0 / 0
    DIVX doesn't seem to work for me either:

    [​IMG]
     
  7. infinite.loop
    • Team MediaPortal

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
    is that a graph created by mediaportal?

    if yes, use the "MediaPortal Debug" shortcut inside your start menu, then reproduce the issue and attach the created *.zip file.
     
  8. wjw

    wjw Portal Pro

    Joined:
    July 13, 2008
    Messages:
    320
    Likes Received:
    20
    Ratings:
    +34 / 0
    Home Country:
    United Kingdom United Kingdom
    I can confirm that DIVX didn't work for me either in 1.0.2. This was after a completely clean install of 1.0.2 as well as an upgrade. I can also confirm that the old TSReader will not work in either 1.0.1 or 1.0.2. It does work in 1.0.

    I will be interested to see the outcome of this as I read in another thread on this forum that TSReader has problems with many codecs
     
  9. infinite.loop
    • Team MediaPortal

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
    hrmm.... i just tried that here myselfe, and indeed. the divx h.264 codec is nolonger able to connect to the tsreader for some reason.

    it did work nicely with MP 1.0.0.

    but coreavcm powerdvd 8, powerdvd9, and windvd9 codecs are still working nicely for mpeg2 and h.264 in MP 1.0.2.
     
  10. sshaikh

    sshaikh Portal Member

    Joined:
    May 11, 2009
    Messages:
    14
    Likes Received:
    0
    Ratings:
    +0 / 0
    Unfortunately I don't have access to any of those codecs (installed the trial PDVD9 and it didn't appear in MP config). I'm going to use MCE for television for the moment, with MP for local files (renaming the odd TS to mkv to offload to Haali), but I'm interested in getting this working if any help is needed in testing etc.
     
  11. infinite.loop
    • Team MediaPortal

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
    reason for this is that Cyberlink started to hide their codec from EVERY other application in the last update. :mad:

    so you either get an old PowerDVD 9 or even 8. Or install the demo of WinDVD9. :(

    just did some testig here and maybe found the reason why divx h264 is nolonger connecting to TsReader.
    fix could take some time though.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!