Okay, I'm stumped. XML woes.

Discussion in 'MediaPortal 1 Skins' started by grassynoel, January 28, 2007.

  1. grassynoel
    • Team MediaPortal

    grassynoel Retired Team Member

    Joined:
    September 6, 2006
    Messages:
    434
    Likes Received:
    49
    Occupation:
    Director of animation
    Location:
    Melbourne
    Ratings:
    +49 / 0
    Home Country:
    In an effort to bring mepo and simplify up to date, I have been reworking many of the animated sequences (that is, .PNG sequences and not zoomong buttons). I have now totally lost my plugins animation and the weather animation plays the first few frames, then displays nothing. All the others are fine. It's a complete mystery as they are all pretty much the same .XML code with the exception of the file names used. I have reloaded the .PNG files into photoshop and resaved them, I have even generated a completely new sequence of frames of a box tipping over and the .XML still cuts out at the same spot. ?????

    Here is my 'hover_my weather.xml'




    <?xml version="1.0" encoding="UTF-8"?>
    <window>
    <controls>
    <control>
    <description>seperator animation</description>
    <type>animation</type>
    <textures>Animations\we\we0001.png;Animations\we\we0002.png;Animations\we\we0003.png;Animations\we\we0004.png;Animations\we\we0005.png;Animations\we\we0006.png;Animations\we\we0007.png;Animations\we\we0008.png;Animations\we\we0009.png;Animations\we\we0010.png;Animations\we\we0011.png;Animations\we\we0012.png;Animations\we\we0013.png;Animations\we\we0014.png;Animations\we\we0015.png;Animations\we\we0016.png;Animations\we\we0017.png;Animations\we\we0018.png;Animations\we\we0019.png;Animations\we\we0020.png;Animations\we\we0021.png;Animations\we\we0022.png;Animations\we\we0023.png;Animations\we\we0024.png</textures>
    <Duration>0:0:2.0</Duration>
    <RepeatBehavior>1</RepeatBehavior>
    <FillBehavior>HoldEnd</FillBehavior>
    </control>
    </controls>
    </window>

    Any help would be appreciated.

    Grassy (lost all his holiday cheer tonight) Noel.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mirk
    • Team MediaPortal

    mirk Retired Team Member

    Joined:
    June 2, 2006
    Messages:
    863
    Likes Received:
    64
    Occupation:
    Technical engineer
    Location:
    Växjö, Sweden
    Ratings:
    +64 / 0
    Home Country:
    Sweden Sweden
    Maybe im stuped to :) but you have alot of spaces between w and e, maybe there are the problem ?

    Should it not bee like this.

    Animations\we\we0001.png;Animations\we\we0002.png;Animations\we\we0003.png;Animations\we\we0004.png;
    Animations\we\we0005.png;Animations\we\we0006.png;Animations\we\we0007.png;Animations\we\we0008.png;
    Animations\we\we0009.png;Animations\we\we0010.png;Animations\we\we0011.png;Animations\we\we0012.png;
    Animations\we\we0013.png;Animations\we\we0014.png;Animations\we\we0015.png;Animations\we\we0016.png;
    Animations\we\we0017.png;Animations\we\we0018.png;Animations\we\we0019.png;Animations\we\we0020.png;
    Animations\we\we0021.png;Animations\we\we0022.png;Animations\we\we0023.png;Animations\we\we0024.png</textures>

    If it had something to do with the copying process to the post, then never mind.
     
  4. grassynoel
    • Team MediaPortal

    grassynoel Retired Team Member

    Joined:
    September 6, 2006
    Messages:
    434
    Likes Received:
    49
    Occupation:
    Director of animation
    Location:
    Melbourne
    Ratings:
    +49 / 0
    Home Country:
    Yep, that's only the copy paste.

    Grassy
     
  5. madsrh

    madsrh Portal Pro

    Joined:
    July 15, 2006
    Messages:
    130
    Likes Received:
    1
    Occupation:
    Student
    Location:
    Denmark
    Ratings:
    +1 / 0
    Home Country:
    Denmark Denmark
    This is offtopic, (sorry) but WOW cool stuff on your homepage Glenn! :eek:
    You are really talented. Keep up the good work.
     
  6. baloubic

    baloubic Portal Member

    Joined:
    June 10, 2006
    Messages:
    32
    Likes Received:
    1
    Ratings:
    +1 / 0
    Hate it when it happens, and the error is so small it's impossible to spot...

    Here's what I'd do (the way for us people who can't wait for someone smarter to figure out the solution):

    * Since you already have a couple of working XML animation scripts, replace the faulty weather and plugins xml with, say, the working Music script (just copy and rename).

    Now you have MePo doing his music thingy as you watch the weather, right? Step two:

    * Replace _one_ of the weather (music) animation images with the correct file, say, Animations\we\we0008.png;.

    Did the weather-mepo image now show briefly when you ran the weather/music script? If no, something is wrong with the path/file naming. If yes, replace the rest (one by one to be on the safe side).
     
  7. grassynoel
    • Team MediaPortal

    grassynoel Retired Team Member

    Joined:
    September 6, 2006
    Messages:
    434
    Likes Received:
    49
    Occupation:
    Director of animation
    Location:
    Melbourne
    Ratings:
    +49 / 0
    Home Country:
    I already tried that. I copied another XML and renamed it weather. t ran okay. I then copy/pasted the sting of PNG files from the original weather into the nw one and it failed. I deleted the actual PNG filed and rendered a box falling (using the same name structure) and it failed so I'm assuming there is something wrong with the string.

    Glenn
     
  8. baloubic

    baloubic Portal Member

    Joined:
    June 10, 2006
    Messages:
    32
    Likes Received:
    1
    Ratings:
    +1 / 0
    So don't copy the whole string - somewhere in there is the error..!

    Change one .png-path at the time manually, and check if the xml is still working for each path change you do. Tedious, I know, but at least you'll be able to pinpoint or bypass the problem.
     
  9. mzemina
    • Team MediaPortal

    mzemina Retired Team Member

    Joined:
    February 23, 2005
    Messages:
    2,065
    Likes Received:
    13
    Occupation:
    Project Manager
    Location:
    Tulsa, OK
    Ratings:
    +13 / 0
    Home Country:
    United States of America United States of America
    Could it be that one of the png files is not named as you have it in your xml page? Could it be that one of te png files has a strange attribute, like system (not sure if that may cause the problem). To see all the files and to see the attributes (using Windows XP in an explorer window) just change your view to details (menu: View->Details) then right click on the column heading (typically: Name, Size, Type, Date Modified) at the top then select attributes. Then you can compare easily if one file may have a different attribute than another and it possibly maybe holding up the animation.
     
  10. SOUNDYTIM

    SOUNDYTIM Portal Pro

    Joined:
    February 5, 2006
    Messages:
    81
    Likes Received:
    0
    Ratings:
    +0 / 0
    i think this is the problem "\w e0024.png</textures" i think it should be "\we0024.png</textures" its at the end !
     
  11. mzemina
    • Team MediaPortal

    mzemina Retired Team Member

    Joined:
    February 23, 2005
    Messages:
    2,065
    Likes Received:
    13
    Occupation:
    Project Manager
    Location:
    Tulsa, OK
    Ratings:
    +13 / 0
    Home Country:
    United States of America United States of America
    I copied and pasted into Word and turned on all formatting marks and there were no spaces between the foldernames, slash, filenames. Only after everyother semicolon.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!