Online Videos fails after MP 1.23 upgrade. (1 Viewer)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Look my MvCentral (based on Movpics code) commit - Update for 1.22 Pre · andrewjswan/mvcentral@3dd9e95 - Wrong in the figure when describing a commit, read not 1.22 but 1.23.
    In a nutshell. I threw a wrapper for media info (which repeated the media portal code) from the plugin, and replaced all the wrapper calls with a new media portal. And it's all..
    View attachment 202004
    About movpic, i have try to change some code but not fully working :
    upload_2019-7-17_11-56-13.png


    Code:
    17-Jul-2019 08:26:41 Error [             DBField]: Error parsing DBLocalMedia.FileSize Property: Input string was not in a correct format.
    17-Jul-2019 08:26:41 Error [             DBField]: Error parsing DBLocalMedia.FileSize Property: Input string was not in a correct format.
    17-Jul-2019 08:26:41 Error [             DBField]: Error parsing DBLocalMedia.FileSize Property: Input string was not in a correct format.
    17-Jul-2019 08:27:11 Error [             DBField]: Error parsing DBMovieInfo.Year Property: Input string was not in a correct format.
    But some other files look OK :
    upload_2019-7-17_12-0-18.png


    OK movpic crash lol, so the change is not good !
     
    Last edited:

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,702
    7,087
    Sydney
    Australia Australia
    Country flag
    Hey @Sebastii, I tried applying your patch and got an error:
    Code:
    git.exe am --3way --ignore-space-change --keep-cr "C:\Development\moving-pictures\317159_0001-Master-Trying-to-make-new-MediaInfo.Wrapper.dll-work (1).patch"
    Applying: Master : Trying to make new MediaInfo.Wrapper.dll working for MovingPictures.
    Patch failed at 0001 Master : Trying to make new MediaInfo.Wrapper.dll working for MovingPictures.
    The copy of the patch that failed is found in: .git/rebase-apply/patch
    When you have resolved this problem, run "git am --continue".
    If you prefer to skip this patch, run "git am --skip" instead.
    To restore the original branch and stop patching, run "git am --abort".
    error: sha1 information is lacking or useless (MovingPictures/MovingPictures.csproj).
    error: could not build fake ancestor
    Fail
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hey @Sebastii, I tried applying your patch and got an error:
    Code:
    git.exe am --3way --ignore-space-change --keep-cr "C:\Development\moving-pictures\317159_0001-Master-Trying-to-make-new-MediaInfo.Wrapper.dll-work (1).patch"
    Applying: Master : Trying to make new MediaInfo.Wrapper.dll working for MovingPictures.
    Patch failed at 0001 Master : Trying to make new MediaInfo.Wrapper.dll working for MovingPictures.
    The copy of the patch that failed is found in: .git/rebase-apply/patch
    When you have resolved this problem, run "git am --continue".
    If you prefer to skip this patch, run "git am --skip" instead.
    To restore the original branch and stop patching, run "git am --abort".
    error: sha1 information is lacking or useless (MovingPictures/MovingPictures.csproj).
    error: could not build fake ancestor
    Fail
    Hey :)
    Attached is a clean repo patched (along with all patches I have on my side) but the MediaInfo one is the last one ofc :p
    Thanks
     

    Attachments

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hey
    Yep the patch is not working and need help to make it works :)
    Maybe @ajs can help too
    Thanks

    Tapatalk
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Steve.Rayner61 Online Videos - Automatic Updates fails 'Automatic update disabled. Check your internet connection' OnlineVideos 10
    N [not reproducible] Online videos not working at all Submit: Bug Reports 1
    Rob Hexenmeister Skinning Online Videos question OnlineVideos 2
    J Debug OnlineVideos, How To? OnlineVideos 1
    cbr954rr Issue BOOTSUWRNQ with online videos? Plugin Development 1
    M Online Video Plugin V.2.32 keine Installtion unter MediaPortal 1.22 ? TV / Streaming 3
    C where is the Online Videos plugin General Support 1
    LeeKelly Online Videos Breaks IPTV channels and scanning Installation, configuration support 1
    cbr954rr How to setup only german channels in online videos Plugin Development 13
    G Amazon Prime (Online Videos) Issue Plugin Development 6
    N [Rejected] Include BBC Sounds (radio catch up) in the Online Videos plugin Feature Requests 4
    E How can I add some site to Online Video Plugin ? OnlineVideos 4
    S IPTV from online m3u8 for Aussie Live TV General Support 10
    T Missing sound in online streaming service (SVTPlay) General Support 3
    olli14 Power scheduler settings for no shutdown as long as kodi client is online TV-Server 1
    J A question regarding Slingbox-like capability online General 3
    R Bug: Video Folders disappear General Support 11
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    B some music videos stutter Watch / Listen Media 0
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    O 1.25.0 Codecs and Video Format for PlayStation 2 Codecs, External Players 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    I Video Playback Stuttering General Support 45
    Similar threads

























    Top Bottom