OnlineVideos 2.3.1.0 [15.05.2017] (1 Viewer)

Ministerk

Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    @zaubermaus75, if I understand you correctly you would like to open the Netflix BrowserPlayer on your secondary monitor (the TV) and not on your main screen? @Jason Pyke implemented a way to switch between monitors (I've never tried it myself since I only have one monitor). I think you do the switch by pressing the context-menu button (i on remote or F9 on keyboard) while watching Netflix. If this doesn't work, close MP and edit the OnlineVideos.WebAutomation.BrowserHost.exe.config file (found in [MP-INSTALL-PATH]l\plugins\Windows\OnlineVideos). Look for this:
    XML:
    <setting name="CurrentScreenId" serializeAs="String">
        <value>0</value>
    </setting>
    And change the value to 1.

    And as @mrbonsen mentioned there is a Netflix for OnlineVideos thread for further support (I "never" look in this thread or forum - no german skills...).
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    I'll try this in the afternoon.. I'll let you know the result
    Yes, please do (y). Could you please try both with remote/keyboard and edit the config file, I would like to know how and if it works so I could add it to the FAQ in the Netflix thread.
     

    zaubermaus75

    Portal Member
    April 30, 2012
    20
    6
    Niedersachsen, Germany
    Germany Germany
    Country flag
    When I start Netflix via MP the fullscreen stream starts on on the primary monitor .
    When I press "i" on the remote I can choose between the active windows on the primary monitor, but everything remains on the primary monitor .
    When I press F9 the Fullscreen stream changes to the TV. After that the remote only controls the volume.
    I can then close the stream by esc. After that the remote no longer reacts in MP, only when I restart my MP .
    In the config I have changed nothing. I can try it tomorrow, my timetable is late today - family problems :notworthy:
    The browser will remain on the primary screen.
    Do you have a solution for the non-functioning remote?;)

    Thanks so far :)
     

    zaubermaus75

    Portal Member
    April 30, 2012
    20
    6
    Niedersachsen, Germany
    Germany Germany
    Country flag
    Ok, I just tested what happens when I edit the config. For me it seems to be no difference in the behaviour.
    Pressing F9 seems to be the solution. Then I have my Netflix on my TV, my browser on the primary monitor and after restarting it keeps being there.

    Only the remote control does not work.

    You just helped me a lot! Thanks @Ministerk :) Danke @mrbonsen :)
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    Sorry for late reply (n). I don't know why the remote doesn't work (the remote control part of the browser player is very hard to get to work for every user) . You could try to toggle the value of this property in the config-file:
    XML:
    <add key="EnableMP1SpecificRemoteHandling" value="true"/>
    Try true and false.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom