[OnlineVideos] MediaPortal has stopped working | Page 2

Discussion in 'OnlineVideos' started by snatz, October 12, 2011.

  1. lsf3og
    • Premium Supporter

    lsf3og MP Donator

    Joined:
    October 15, 2010
    Messages:
    108
    Likes Received:
    5
    Gender:
    Male
    Location:
    Berlin
    Ratings:
    +5 / 0
    Home Country:
    Germany Germany
    Show System Specs
    AW: [OnlineVideos] MediaPortal has stopped working

    Actually it doesn't have anything to do with the splitter. It seems to have something to do with ffdshow. When chossing the dxva version, hd videos play, When choosing the normal ffdshow, mp crashes.
    The logs don't show anything interesting on the error, but as far as i remember the problem occured for the first time after updating to the most recent mp-version.
    I know this doesn't really have to do with the Online Videos plugin, but it doesn't fit in any other category, because the crash only occurs when starting an HD-stream.

    Edit: Just found out something really strange (at least to me). When starting an HD-stream -> crash. When downloading the file and playing it -> no problem.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. vpupkin

    vpupkin Portal Pro

    Joined:
    March 26, 2011
    Messages:
    84
    Likes Received:
    4
    Ratings:
    +5 / 0
    Re: AW: [OnlineVideos] MediaPortal has stopped working

    Has this been resolved? I've got very similar issue - after updating OnlineVideos to 1.0.0.0 (no codec changes), some of the sites crash MP in ffdshow. For instance, full episodes of Jon Stewart show on The Comedy Network crash it as soon as playback is supposed to start; the same episodes used to work just fine before the update. YouTube works fine (all formats). Interestingly, if I download the same episodes of Jon Stewart and play them back this way there are no problems with playback.

    I am wondering if there can be an issue with the new HTTP source filter?
     
  4. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    And how are we supposed to know that without logs?
     
  5. vpupkin

    vpupkin Portal Pro

    Joined:
    March 26, 2011
    Messages:
    84
    Likes Received:
    4
    Ratings:
    +5 / 0
    Here you go - indeed, as far as I can tell, it crashes on DS graph construction, trying to connect source filter...
     
  6. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    I'm guessing you have some other filter installed than LAV that is trying to connect in the graph first and somehow crahes. OnlineVideos does not use the default MP way of building the graph (it's not really possible as we often do not know the video type)-but rather Automatic graph building by merits.
     
  7. vpupkin

    vpupkin Portal Pro

    Joined:
    March 26, 2011
    Messages:
    84
    Likes Received:
    4
    Ratings:
    +5 / 0
    Is there any way to debug OV's graph construction? I did some more digging, and the crash is definitely related to connection to ffdshow (if I disable ffdshow in its properties, OV works). More interesting is the fact that only small proportion of sites in OV crash - most do work (I tried couple of dozens), but 2 that I did find are The Comedy Network (Jon Stewart) and CTV Local News (Toronto).

    If it's automatic, is there any way to replicate graph construction outside of MP (i.e. in GraphEdit/GraphStudio)?
     
  8. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    GraphStudio's "Render Url" or "Render File" should also use the system default ways (merits) to build the graph.
     
  9. vpupkin

    vpupkin Portal Pro

    Joined:
    March 26, 2011
    Messages:
    84
    Likes Received:
    4
    Ratings:
    +5 / 0
    I've tried this with rtmpe:// URL I did find in the log, but the source filter was unable to load this up in GraphStudio for whatever reason... Is it expected to work, just adding filter by filter manually?
     
  10. corporate_gadfly

    corporate_gadfly Portal Pro

    Joined:
    May 17, 2011
    Messages:
    396
    Likes Received:
    68
    Ratings:
    +72 / 0
    Home Country:
    Canada Canada
    I tried The Comedy Network (Jon Stewart) last night and it never crashed. I'm not up and up on the codec technicalities, however. I have StreamedMP skin and SAF 6.0.5 installed (with the recommended settings).

    Disclaimer: I contributed the C# SiteUtil for the 2 sites that you mention that crashed (The Comedy Network and CTV Local News).
     
  11. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    Only MPUrlSource can handle the rtmp protocol. Adding it manually might work, but GraphStudio has a bug that it only takes limited amount of letters in the input box where can can specify the url, so you are out of luck. But you can download the video and then render the file - should have the same effect for chosen codecs.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!