Oulala Je M'arrache Les Cheveux Pour La Config De Mes Films V4.7.8

Discussion in 'Mes Films' started by Dondiego, December 8, 2008.

  1. Dondiego

    Dondiego New Member

    Joined:
    December 7, 2008
    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0
    Bonjour, j'esperais pouvoir me présenter autrement qu'avec un probleme comme premier message, mais on ne fait pas toujours ce que l'on veut <_<

    Voilà je suis ce forum depuis 3 jours environ et j'ai fait une petite config informatique comme HTPC.

    j'ai installé media portal 1RC4, et le plugin mes films en mpi (version 4.7.8).



    je l'ai installé en cliquant 2x dessus et ça s'est fait il me semble sans problemes.. mais j'ai peut etre pas tout vu!

    j'ai ensuite téléchargé amc 3.5.1.1 et l'ai installé. j'avais pas trop pigé comment rentrer les films de mon disque étant habitué à dvd profiler, mais j'ai fini par trouver un excellent tuto pour les noobs comme moi ! J'ai realisé ma base, sauvegardé en xml.

    j'ai lu qu'il faudrait l'exporter dans Mp, mais je n'ai pas encore compris où. Ca parrait pourtant évident , mais je sèche completement!

    Lorsque je tente de configurer en suivant ce modèle, et au moment de valider, j'ai ce message d'erreur :

    "Your XML file is valid with 0 movie in your database, but no movie to display, you have to change the selected enregs or fill your databse with AMCUpdater, AMC or your compatible software"

    lorsque je clique sur Ok, j'obtiens "configuration saved"

    j'ai fais donc l'update avec amc updater (je n'ai que 3 films entrés pour aller plus vite et voir si ça fonctionne) et ils me trouve les films correspondants dans sa base : par exemple j'ai iron man.mkv et il va trouver iron man (2008), je selectionne tout, il me fait pareil pour les 2 autres films, et ensuite il me dit configuration complete ou bien update (je ne sais plus trop) bref c'est un succes!

    il me cree aussi à chaque fois un fichier XML avec le meme nom de base que le mien, avec la date du jour et un numero!

    Si je retourne dans la config de myfilms, que je rentre mon fichier xml original ou ceux que amc updater m'a fournit, jai toujours le même message d'erreur : "Your XML file is valid with 0 movie in your database, but no movie to display, you have to change the selected enregs or fill your databse with AMCUpdater, AMC or your compatible software"

    Donc la je pige plus rien!

    mais ce n'est pas tout ! :!@$£%%:

    Lorsque quand même je tente de lancer Mes films a partir de media portal il me dit qu'il ne trouve pas mesfilms.xml dans le repertoire du skin, ensuite il crash avec un message d'erreur .zip.
    Le probleme c'est que je ne les ai jamais eu ces fichiers! j'ai lu qu'ils se trouvent dans le fichier rar, et qu'il faut les mettre dans le repertoir avec mesfilmsdetail (ou qqch comme ça) ainsi que mesfilms hoover.png.. le probleme c'est que j'ai le fichier mpi, et bien que je pense qu'il est sensé les installer tout seul, il ne le fait pas ça doit planter!

    j'ai tenté une réinstalle a partir de mpinstaller et il plante apres la copie des fichiers en me disant que grabber.dll est utilisé!

    (il faudrait que je redemarre le pc... bon comme j'attends la fin d'un download) je ne peux pas encore!

    En attendant j'ai plusieurs problemes embriqués :

    1) Apres avoir enregistré le fichier XML dans Ant movie catalog.. on doit l'exporter où exactement?
    2) comment faire pour eviter l'erreur a partir de Mp ("Your XML file is valid with 0 movie in your database, but no movie to display, you have to change the selected enregs or fill your databse with AMCUpdater, AMC or your compatible software")
    il a ptet un probleme pour trouver les fichier xvid, mais j'ai pourtant bien renseigné le repertoire.
    3) s'il ne s'agit pas d'un probleme de redemarrage de pc.. est il possible d'avoir le fichier rar de mesfilms v 4.7.8 afin de mettre les fichiers manuellement dans les repertoires spéciéfiés?

    <div class='quotetop'>CITATION</div>
    merci beaucoup! avec vos réponses je vais y arriver! chui pas si noob que ça en général lol :EM2:
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. HTK

    HTK Ex-Moderateur en touriste

    Joined:
    May 13, 2007
    Messages:
    189
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    France France
    Tout d'abord, bienvenu parmi nous :)

    Ensuite,

    Si tu as suivi les instructions du tuto de -ltb-, tu ne devrais pas obtenir de message d'erreur concernant l'import de ta base AMC au fromat xml.
    Bien que ce tuto soit pour une version plus ancienne du plugin, les renseignements obligatoires sont bien indiqués :
    - AntMovie Catalog File (XML) : Indiquer le filepath
    - AntPicture Path : Indiquer le file path si celui indiqué automatiquement ne correspond pas
    - Ant Item For Storage info : URL

    Bref, peux-tu nous faire une copie d'écran de ta config de plugin (uniquement le premier onglet)

    Ton deuxième problème semble lié à une absence de fichiers xml dans ton répertoire skin. 2 solutions :
    - Tu n'as pas cocher le skin à installer lors de l'installation du plugin
    --> Tu vas dans "C:\Program Files\Team MediaPortal\MediaPortal\skin\le_nom_de_ton_skin" et tu vérifies que tu as bien les fichiers "mesfilms.xml" et "mesfilmsdetails.xml".
    - Le skin que tu utilises n'est pas supporté par le plugin
    --> Peux-tu nous préciser quel skin tu utilises. Souvent il est possible d'appliquer les xml prévus pour un autre skin.

    @+

    HTK
     
  4. Dondiego

    Dondiego New Member

    Joined:
    December 7, 2008
    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0
    salut HTK

    merci pour ta réponse rapide!

    j'ai reconfiguré mes films avec a nouveau le tuto -ltb- j'avais fait une erreur dans le search path for file read! j'avais mis le chemin sur le disque dur vers le dossier des films au lieu de le mettre vers AMC. la config s'est bien réalisée donc mon premier probleme est résolu!
    Je te remercie deja de m'avoir mis serieusement sur la voie! :super:

    Par contre je tiens a signaler que la façon qu'a AMC Updater de remplir n'ets pas pareilque celle proposée par -ltb-.

    voici comment il l'a remplit pour des films enregistrés sur le DD.

    [​IMG]

    Concernant le second probleme, je viens tout juste de le résoudre en me demandant si le logiciel avait copié les fichiers pour les autres skins! il n'a fait pour blue3 et pas les autres donc j'ai simplement copié les fichiers dans Xmas3 (celui que j'utilise actuellement)

    pas plus compliqué que ça! merci beaucoup pour tout car tu m'as mis sur la bonne voie!

    on peut donc fermer le sujet ;)
     
  5. HTK

    HTK Ex-Moderateur en touriste

    Joined:
    May 13, 2007
    Messages:
    189
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    France France
    De rien, on est là pour ça.

    Par contre, as-tu essayé de lire un film ?

    Car je pense que tu vas rencontrer un problème ... :)

    Effectivement, le champs "Adresse web" de AMC correspond au champs "Ant Item For Storage info" du setup du plugin. Donc dans AMC, tu dois indiquer le filepath de ton film. Par exemple : \\serveur\movies\Nom_du_film\Nom_du_film.avi

    Sans quoi, MP te donnera un message d'erreur du type "media not found, please insert disc" ou un truc dans le genre.

    @+

    HTK
     
  6. zebons

    zebons Portal Pro

    Joined:
    January 2, 2006
    Messages:
    1,484
    Likes Received:
    114
    Ratings:
    +114 / 0
    <div class='quotetop'>CITATION(Don Diego @ 8 Dec 2008, 20:11 ) <{POST_SNAPBACK}></div>
    Tu devrais prendre la dernière version du plugin (la 4.7.8 avait encore quelques bug) que tu trouveras ici. Pour l'installer double clic simplement le le ficheir .mpi que tu auras récupéré.
    Puis tu installe la dll que tu trouveras ici à copier dans le répertoire C:\Program Files\Team MediaPortal\MediaPortal\plugins\Windows
    Je sais c'est pas très simple mais je crérai bientôt un fichier mpi pour la 4.7.9f

    Avec ton fichier AMC, tu devrais avoir une config du genre :
     
  7. HTK

    HTK Ex-Moderateur en touriste

    Joined:
    May 13, 2007
    Messages:
    189
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    France France
    <div class='quotetop'>CITATION(zebons @ 9 Dec 2008, 00:18 ) <{POST_SNAPBACK}></div>
    Ah bin là ! j'ai appris quelque chose ... Je ne savais pas qu'on pouvait le gérer comme ça.

    Merci Zebons !!!
     
  8. -ltb-

    -ltb- Portal Pro

    Joined:
    April 10, 2006
    Messages:
    4,204
    Likes Received:
    21
    Ratings:
    +21 / 0
    Home Country:
    France France
    Désolé le tuto n est pas tres a jour, j'essaierai de le mettre a jour des que j aurai 5 min
     
  9. zebons

    zebons Portal Pro

    Joined:
    January 2, 2006
    Messages:
    1,484
    Likes Received:
    114
    Ratings:
    +114 / 0
    <div class='quotetop'>CITATION(HTK @ 9 Dec 2008, 00:22 ) <{POST_SNAPBACK}></div>
    Qu'est ce que tu ne savais pas ?
     
  10. HTK

    HTK Ex-Moderateur en touriste

    Joined:
    May 13, 2007
    Messages:
    189
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    France France
    <div class='quotetop'>CITATION(zebons @ 9 Dec 2008, 08:47 ) <{POST_SNAPBACK}></div>
    Et bien qu'il existe une autre façon de paramétrer ton plugin que celle que j'utilise.
    Je m'explique, pour ma part je renseigne l'URL dans AMC comme suit : \\Server\Movies\Nom_du_film\Nom_du_film.avi
    et dans le setup de MesFilms, "Ant Item For Storage info : URL". Alors que apparement, on peut indiquer "source" à la place de "URL".

    Bien que je préfère la première option car elle me parait plus pérenne dans le cas d'un changement de config de mon serveur, je trouve cette solution intéressante car l'emplacement n'a pas besoin d'être renseigné à la pogne.

    Bref, toujours bon à savoir,

    @+

    HTK
     
  11. zebons

    zebons Portal Pro

    Joined:
    January 2, 2006
    Messages:
    1,484
    Likes Received:
    114
    Ratings:
    +114 / 0
    <div class='quotetop'>CITATION(HTK @ 9 Dec 2008, 12:07 ) <{POST_SNAPBACK}></div>
    Je pense qu'il y a confusion :
    Ant Item for Storage Info correspond au champ de ta database qui contient le nom du ficher correspondant au film. Si le nom de ton fichier Films est stocké dans le Champ 'Adresse Web' de l'interface AMC, tu indiques 'URL'. Par contre si cette info est stockée dans le champ de l'interface AMC 'Origine' ce qui semble être la cas pour Don Diego, il faut indiquer ici 'Source' .
    Par contre le nom que tu stockes dans la base AMC peut indifféremment être comme tu l'indiques \\nom_serveur\... ou X:\.... en fonction de ton utilisation Pour ma part j'utilise la seconde notation en prenant soin que tous mes PC en réseau mappent avec les même lettres mes lecteurs réseau...
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!