[Plugin] MPSync - MediaPortal multi-seat Synchronization (1 Viewer)

roedler86

MP Donator
  • Premium Supporter
  • August 25, 2015
    91
    15
    Germany Germany
    Country flag
    Hey guys,

    I really love this plugin. I just set it up and its working very well...

    I can't figure out I point:
    I set up to sync a folder including all sub folder... but here, only the files from the sub folder are copied not the file from the actually folder...

    MPSync.png


    What am I missing?

    Thanks in advanced....
     

    m3rcury

    Development Group
  • Team MediaPortal
  • August 12, 2010
    962
    707
    Malta Malta
    Country flag
    Hey guys,

    I really love this plugin. I just set it up and its working very well...

    I can't figure out I point:
    I set up to sync a folder including all sub folder... but here, only the files from the sub folder are copied not the file from the actually folder...

    View attachment 187210

    What am I missing?

    Thanks in advanced....
    @roedler86. You need to select the parent folder, in your case MediaPortal. Then select specific folders and only select scripts. This should work.

    I will have a look into the plugin to see whether with your current setup, you can obtain same result as explained above.
     

    roedler86

    MP Donator
  • Premium Supporter
  • August 25, 2015
    91
    15
    Germany Germany
    Country flag
    Thanks a lot. That's working. And I need only one folder-synchronization for all my sub folder. Thanks.

    But I recognized another strange behavior:
    After starting MediaPortal I can't do anything for a couple of minutes, until the sync job is done. The system doesn't freeze but the CPU is at 100%. Because of this sometime the movie player or records, which are recorded while starting MediaPortal, hang.

    Is there any possibility to reduce the CPU load?

    Thanks again!
     

    m3rcury

    Development Group
  • Team MediaPortal
  • August 12, 2010
    962
    707
    Malta Malta
    Country flag
    Thanks a lot. That's working. And I need only one folder-synchronization for all my sub folder. Thanks.

    But I recognized another strange behavior:
    After starting MediaPortal I can't do anything for a couple of minutes, until the sync job is done. The system doesn't freeze but the CPU is at 100%. Because of this sometime the movie player or records, which are recorded while starting MediaPortal, hang.

    Is there any possibility to reduce the CPU load?

    Thanks again!
    @roedler86. You can select the check-box "Pause when player active". It will pause the synchronisation whilst you are watching a movie or playing music. Sometimes it still needs a minute or two to pause, but it works :)
     

    nightwar

    Portal Member
    March 11, 2013
    13
    1
    46
    United States of America United States of America
    I need help with this, It is a new moving pictures data base, and syncing to an empty network path, so its a clean slate, the log file is attached
     

    m3rcury

    Development Group
  • Team MediaPortal
  • August 12, 2010
    962
    707
    Malta Malta
    Country flag
    I need help with this, It is a new moving pictures data base, and syncing to an empty network path, so its a clean slate, the log file is attached
    @nightwar. Can you open file MPSync.xml found in C:\ProgramData\Team MediaPortal\MediaPortal and change the date in the following line to a date in the past.
    XML:
    <entry name="last sync">2017-04-25 19:29:55</entry>
    In the above example set the last sync date to 2017-04-24. Then start the sync process again. If you sync manually, you cal launch the MPSync_Launcher.exe or else if you sync from within MediaPortal, restart MediaPortal.
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,524
    1,722
    Nuenen
    Netherlands Netherlands
    Country flag
    Hi since some time I'm having trouble (again) in retaining the watched status for moving pictures, is there anything that I could check at my end?
    My setup is as follows:
    main pc is set up to sync from main pc to main server
    htpc is set up to sync from main server to htpc (using triggers, watched="no")
    If I watch a movie on htpc, after a while (after syncing with server) the watched status is reset again.
    checking the log I see this:
    Code:
    22/09/2017 11:42:53 - [INFO ] MPSync: process plugin version 1.0.0.17 initialisation with DEBUG.
    22/09/2017 11:42:53 - [INFO ] MPSync: DB - C:\ProgramData\Team MediaPortal\MediaPortal\database <-- \\dionysus\LocalShare\MediaPortal\databases
    22/09/2017 11:42:53 - [INFO ] MPSync: DB synchronization method - Propagate both additions and deletions
    22/09/2017 11:42:53 - [INFO ] MPSync: DBs selected - movingpictures.db3|
    22/09/2017 11:42:53 - [INFO ] MPSync: watched/resume not selected
    22/09/2017 11:42:53 - [INFO ] MPSync: Objects selected - ALL
    ...
    22/09/2017 11:43:44 - [INFO ] MPSync: [db_worker] synchronization of table user_movie_settings in database C:\ProgramData\Team MediaPortal\MediaPortal\database\movingpictures.db3 started.
    22/09/2017 11:43:44 - [INFO ] MPSync: [Synchronize_DB] synchronization of table user_movie_settings in database C:\ProgramData\Team MediaPortal\MediaPortal\database\movingpictures.db3 in progress...
    22/09/2017 11:43:44 - [DEBUG] MPSync: [DeleteRecords] deleting extra entries on target for table user_movie_settings in database C:\ProgramData\Team MediaPortal\MediaPortal\database\movingpictures.db3
    22/09/2017 11:43:45 - [DEBUG] MPSync: [Process_DB_folder] waiting for background threads to finish... 1 threads remaining processing {movingpictures.db3}.
    22/09/2017 11:43:47 - [DEBUG] MPSync: [DeleteRecords] DELETE FROM target.user_movie_settings WHERE id IN (SELECT id FROM (SELECT * FROM target.user_movie_settings EXCEPT SELECT * FROM user_movie_settings))
    22/09/2017 11:43:47 - [DEBUG] MPSync: [DeleteRecords] 3 records deleted from user_movie_settings in database C:\ProgramData\Team MediaPortal\MediaPortal\database\movingpictures.db3
    [/CODE[
    
    so somehow it does synchronize the user_movie_settings despite the watched="no"
     

    m3rcury

    Development Group
  • Team MediaPortal
  • August 12, 2010
    962
    707
    Malta Malta
    Country flag
    Hi since some time I'm having trouble (again) in retaining the watched status for moving pictures, is there anything that I could check at my end?
    My setup is as follows:
    main pc is set up to sync from main pc to main server
    htpc is set up to sync from main server to htpc (using triggers, watched="no")
    If I watch a movie on htpc, after a while (after syncing with server) the watched status is reset again.
    checking the log I see this:
    Code:
    22/09/2017 11:42:53 - [INFO ] MPSync: process plugin version 1.0.0.17 initialisation with DEBUG.
    22/09/2017 11:42:53 - [INFO ] MPSync: DB - C:\ProgramData\Team MediaPortal\MediaPortal\database <-- \\dionysus\LocalShare\MediaPortal\databases
    22/09/2017 11:42:53 - [INFO ] MPSync: DB synchronization method - Propagate both additions and deletions
    22/09/2017 11:42:53 - [INFO ] MPSync: DBs selected - movingpictures.db3|
    22/09/2017 11:42:53 - [INFO ] MPSync: watched/resume not selected
    22/09/2017 11:42:53 - [INFO ] MPSync: Objects selected - ALL
    ...
    22/09/2017 11:43:44 - [INFO ] MPSync: [db_worker] synchronization of table user_movie_settings in database C:\ProgramData\Team MediaPortal\MediaPortal\database\movingpictures.db3 started.
    22/09/2017 11:43:44 - [INFO ] MPSync: [Synchronize_DB] synchronization of table user_movie_settings in database C:\ProgramData\Team MediaPortal\MediaPortal\database\movingpictures.db3 in progress...
    22/09/2017 11:43:44 - [DEBUG] MPSync: [DeleteRecords] deleting extra entries on target for table user_movie_settings in database C:\ProgramData\Team MediaPortal\MediaPortal\database\movingpictures.db3
    22/09/2017 11:43:45 - [DEBUG] MPSync: [Process_DB_folder] waiting for background threads to finish... 1 threads remaining processing {movingpictures.db3}.
    22/09/2017 11:43:47 - [DEBUG] MPSync: [DeleteRecords] DELETE FROM target.user_movie_settings WHERE id IN (SELECT id FROM (SELECT * FROM target.user_movie_settings EXCEPT SELECT * FROM user_movie_settings))
    22/09/2017 11:43:47 - [DEBUG] MPSync: [DeleteRecords] 3 records deleted from user_movie_settings in database C:\ProgramData\Team MediaPortal\MediaPortal\database\movingpictures.db3
    [/CODE[
    
    so somehow it does synchronize the user_movie_settings despite the watched="no"
    @doskabouter. Apologies for not replying before but was quite tied with other work.

    The plugin will still synchronise the episode/movie seen value through the table sync. and not the watched status function. The watched status function is there to provide possibility to go on another client and continue playing from the same position you stopped on the previous client. Also keep in mind that the episode/movie seen value is also synchronised by the Trakt plugin.
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,524
    1,722
    Nuenen
    Netherlands Netherlands
    Country flag
    Thanks for your time!
    So do I understand it correctly that it's not possible to keep the watched status?
    Mind you, I don't use trakt for this
     

    m3rcury

    Development Group
  • Team MediaPortal
  • August 12, 2010
    962
    707
    Malta Malta
    Country flag
    Thanks for your time!
    So do I understand it correctly that it's not possible to keep the watched status?
    Mind you, I don't use trakt for this
    @doskabouter. A change can be implemented to split current flag into 2, namely resume sync and status sync. Resume sync will do what the flag is doing today, whilst the new status sync will handle your request.

    What do you think?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 4
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    E aktuelle englische Forums Webseite von - Showtime Plugin v3 Plugins & Erweiterungen 4
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    joecrow MultiShortcut Plugin (Uavailable) in DWHD skin General Support 58
    vapourEyes Building TV Plugin General Development (no feature request here!) 49
    Golf4 Nach Windows-Updates läuft TV-Plugin nicht mehr Allgemeines Support- und Diskussionsforum 0
    joecrow How about a Launcher plugin for MP1? MediaPortal 1 6
    D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
    framug Nouveau plugin XmlTvFR pour récupérer le guide télé français Kazer / ZguideTv (WebEPGfr) 11
    emphatic Allow remote control mapping of all plugins Improvement Suggestions 0
    D Where should plugins be located on hard drive? General Support 0
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    cbr954rr How to disable a pre-configured plugin? General 2
    mrmojo666 [Plugin]Marantz Control Plugin 0.0.0.2 MediaPortal 1 Plugins 2
    mrmojo666 beginner: trying to write a plugin, need help to catch event General Development (no feature request here!) 3
    framug [Rejected] Fix PowerScheduler plugin for MP2 single seat Submit: Code Patches 9
    doskabouter [Question] Stale plugins Developer Discussions 9
    M MP1 stops responding after Starting Plugins General Support 14
    Terra LAVFilter Plugin cannot be updated (MP1.23) MediaPortal 1 Plugins 10
    L Mediaportal 1.21 and Windows 10: user schedules de-activated when powerscheduler plugin is selected General Support 1
    C Can the XmlTv Plugin handle 600+ channels? General 3
    M Online Video Plugin V.2.32 keine Installtion unter MediaPortal 1.22 ? TV / Streaming 3
    emphatic Pictures in the cloud - would a plugin be possible for services like Google Photos MediaPortal 1 Plugins 1
    C where is the Online Videos plugin General Support 1
    Similar threads

























    Top Bottom