[other] - Problems with dropping frames with EVR | Page 4

Discussion in 'MediaPortal 1.1.0 BETA 1' started by MPUserFromGER, December 6, 2009.

  1. VASkO

    VASkO Portal Member

    Joined:
    September 18, 2008
    Messages:
    48
    Likes Received:
    2
    Ratings:
    +2 / 0
    Home Country:
    Slovenia Slovenia
    at this point, tearing with no dropping and freezing under VMR is acceptable while dropping and finally freezing under EVR isn't... I'm the helpdesk support line for my parents, where the ION330 HTPC with MP lives.

    Somebody will also find the root cause for EVR issues with MP and fix it sooner or later...



    edit:
    while playing the LiveTV source in MP and connecting to it's graph in GraphStudio, I saw something unusual. The PowerDVD filter's VideoOut AvgTimePerFrame is 400000 whereas when building the same graph just in GraphStudio and starting it, the AvgTimePerFrame is like in the attached screenshot. The source is interlaced PAL signal. So the deinterlace does work OK running the graph under GraphStudio giving constant 50Hz (EVR statistics). In MP the ! method reports the fps jumping arround all from 30-50fps. What's going on here?
     

    Attached Files:

    • screenshot.jpg
      screenshot.jpg
      File size:
      155.2 KB
      Uploaded:
      December 23, 2009
      Views:
      126
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Justchill

    Justchill Portal Pro

    Joined:
    February 25, 2008
    Messages:
    247
    Likes Received:
    1
    Location:
    Brugge
    Ratings:
    +1 / 0
    Home Country:
    Belgium Belgium
    How exactly can we test for dropped frames using the EVR? For instance, while playing a x.264 MKV file.
     
  4. VASkO

    VASkO Portal Member

    Joined:
    September 18, 2008
    Messages:
    48
    Likes Received:
    2
    Ratings:
    +2 / 0
    Home Country:
    Slovenia Slovenia
    Start the playback of any source of your liking and 1) press the keys "SHIFT+1" to show the statistics of the EVR renderer or 2) with the program called GraphEdit connect to the MediaPortal's graph, rendering your media and see the statistics in the properties of the EVR structure in the built graph.
     
  5. Justchill

    Justchill Portal Pro

    Joined:
    February 25, 2008
    Messages:
    247
    Likes Received:
    1
    Location:
    Brugge
    Ratings:
    +1 / 0
    Home Country:
    Belgium Belgium
    I play an episode of dexter inside MP , then I press SHIFT - 1

    => I just see the timeline and a 1 appears on that bar, and then disappears..

    Could you help me a bit more here?
     
  6. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Press the SHIFT and 1 keys at the same time - this is the ! character on an English keyboard.

    Tony
     
  7. Justchill

    Justchill Portal Pro

    Joined:
    February 25, 2008
    Messages:
    247
    Likes Received:
    1
    Location:
    Brugge
    Ratings:
    +1 / 0
    Home Country:
    Belgium Belgium
    It is not working, do you have install something?
    Is there a remote key, can I map the function to a button?
     
  8. Laban

    Laban Portal Pro

    Joined:
    July 1, 2007
    Messages:
    206
    Likes Received:
    18
    Occupation:
    Software engineer
    Location:
    Luleå
    Ratings:
    +18 / 0
    Home Country:
    Sweden Sweden
    Same problem here:

    24-12-2009 10:38:33.180 [d48]Dropping frame, behind 0 ms, last sleep time 31 ms.
    24-12-2009 10:38:33.220 [d48]Dropping frame, behind 0 ms, last sleep time 31 ms.
    24-12-2009 10:38:33.260 [d48]Dropping frame, behind 0 ms, last sleep time 31 ms.
    24-12-2009 10:38:33.300 [d48]Dropping frame, behind 0 ms, last sleep time 24 ms.
    24-12-2009 10:38:33.340 [d48]Dropping frame, behind 0 ms, last sleep time 31 ms.
    24-12-2009 10:38:33.380 [d48]Dropping frame, behind 0 ms, last sleep time 31 ms.
    24-12-2009 10:38:33.421 [d48]Dropping frame, behind 0 ms, last sleep time 31 ms.
    24-12-2009 10:38:33.461 [d48]Dropping frame, behind 0 ms, last sleep time 31 ms.
    24-12-2009 10:38:33.900 [d48]Dropping frame, behind 0 ms, last sleep time 26 ms.

    Tried with ffdshow and mpa codec, same problem. Not sure how to enable analogue out, tried with wave out in the ffdshow configuration , same problem there too.
     
  9. Jay_UK
    • Team MediaPortal

    Jay_UK Test Group

    Joined:
    October 6, 2009
    Messages:
    1,781
    Likes Received:
    250
    Occupation:
    Enterprise Architect
    Location:
    Derby
    Ratings:
    +271 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi there,

    Has anyone managed to progress this?

    I am getting dropped frames with W7x64 with EVR - not all the time though

    Shift 1 reports a frame every second is being dropped, the number with glitches is increasing at an incredible speed more than 10 a second (with frequency set to 50Hz)

    I am only getting 41 - 42FPS

    This is with EVR and PDVD on SD Live TV

    I have changed my TV to 25Hz to see if that helps - which it has slightly

    EVR.log is reporting:

    31-12-2009 21:46:12.340 [76c]Dropping frame, behind 3.80 ms, last sleep time 19.37 ms.
    31-12-2009 21:46:12.539 [76c]Dropping frame, behind 2.67 ms, last sleep time 15.94 ms.
    31-12-2009 21:46:12.601 [76c]Dropping frame, behind 4.67 ms, last sleep time 9.50 ms.
    31-12-2009 21:46:13.678 [76c]Dropping frame, behind 1.74 ms, last sleep time 10.48 ms.
    31-12-2009 21:46:14.879 [76c]Dropping frame, behind 3.06 ms, last sleep time 15.70 ms.
    31-12-2009 21:46:15.001 [76c]Dropping frame, behind 4.88 ms, last sleep time 18.91 ms.
    31-12-2009 21:46:15.062 [76c]Dropping frame, behind 5.83 ms, last sleep time 11.30 ms.
    31-12-2009 21:46:16.637 [76c]Dropping frame, behind 0.52 ms, last sleep time 9.59 ms.
    31-12-2009 21:46:18.561 [76c]Dropping frame, behind 5.34 ms, last sleep time 16.12 ms.
    31-12-2009 21:46:18.625 [76c]Dropping frame, behind 9.30 ms, last sleep time 10.96 ms.
    31-12-2009 21:46:18.800 [76c]Dropping frame, behind 4.02 ms, last sleep time 8.79 ms.
    31-12-2009 21:46:18.960 [76c]Dropping frame, behind 4.25 ms, last sleep time 20.08 ms.
    31-12-2009 21:46:19.490 [76c]Dropping frame, behind 13.85 ms, last sleep time 16.34 ms.
    31-12-2009 21:46:19.565 [76c]Dropping frame, behind 8.79 ms, last sleep time 16.34 ms.
    31-12-2009 21:46:19.757 [76c]Dropping frame, behind 0.91 ms, last sleep time 15.91 ms.
    31-12-2009 21:46:26.155 [76c]Dropping frame, behind 0.03 ms, last sleep time 15.65 ms.
    31-12-2009 21:46:26.636 [76c]Dropping frame, behind 0.22 ms, last sleep time 18.18 ms.

    I have just restarted MP (after I altered some ATI settings - 3D/Avivo) - It is now reporting ~50FPS, only a total of 13 dropped frames after 15 minutes of TV (256 sync glitches)

    J.
     
  10. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    11,024
    Likes Received:
    4,750
    Ratings:
    +6,797 / 11
    Home Country:
    Germany Germany
    Show System Specs
    AW: Problems with dropping frames with EVR

    I experienced the same issue, even after I changed my HTPC to up-to-date hardware.

    I modified the dshowhelp a small bit, the result is quite better.

    • disabled the frame dropping (maybe causes other side effects)
    • removed a 3 msec sleep call

    Not sure if one of them or both reduce the problem.

    Please test these changes also...
     
  11. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    Re: AW: Problems with dropping frames with EVR

    That one will bring up the issue with audio and video sync.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!