1.10.0 - Problems with specific Webradio-Streams

Discussion in 'Archive' started by Requiem, February 21, 2015.

  1. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +174 / 2
    Home Country:
    Germany Germany
    Show System Specs
    MediaPortal Version: 1.10.0



    Description
    Hi,

    I have a problem since at least MP 1.4 with Deluxe Lounge Radio and Deluxe Radio. Other Web-Radiostreams work perfectly.

    No matter if I add the station from a plylist file or add it manually -> Cannot play mp3.
    This is in a multiseat setup.

    The strange thing is: Today after deleting the channel, reimporting it from the .pls from the offiicial website - played fine. Once. Rebooted, same error again.

    Deleted again, reimported...to no avail.

    Reproducible over several installations and complete fresh setups of as well the server as the client.

    Plays perfectly in other players.

    Attachments: .pls files, Serverlogs, Clientlogs

    Steps to Reproduce:
    1. Open TV Server config, import attached .pls and save
    2. Restart Server or Service
    3. Restart MP on CLient
    4. Try to listen the newly added station
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Looks like a BASS (music engine) timeout.
    [2015-02-21 20:08:46,977] [Log ] [MPMain ] [INFO ] - BASS: Creating BASS audio stream
    [2015-02-21 20:08:56,990] [Error ] [MPMain ] [ERROR] - BASS: Unable to create Stream for http://am.audio1.fr.ipercast.net/deluxemusic.tv/lounge_web/mp3. Reason: BASS_ERROR_TIMEOUT.

    Note that TV Server has almost nothing to do with radio web stream playback. It simply stores the URL. So, the PC running MP needs direct access to the internet in order to play the stream successfully.

    What happens if you try to open the URL in a browser on the client PC?
     
    • Like Like x 1
  4. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +174 / 2
    Home Country:
    Germany Germany
    Show System Specs
    In a browser or VLC - playing fine. I am using WASAPI, though. But no difference when switching to BASS.
    Other web radios playing fine in MePo on this client.

    Switching off the WIndows Firewall completely for testing purposes - also no change.
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
  6. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,295
    Likes Received:
    6,247
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,268 / 9
    Home Country:
    France France
    Show System Specs
    upload_2015-2-21_20-34-44.png

    Working on my side, no clue why it failed for you :(
     
    • Thank You! Thank You! x 1
  7. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +174 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Here is a link to an older thread with this problem.

    @Sebastiii I know. Others in the linmked thread also seemed to have no problems. I'd really like to listen to that radio, but for a long while - no way. And as I said, completely fresh setups of server and client meanwhile.
     
  8. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,295
    Likes Received:
    6,247
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,268 / 9
    Home Country:
    France France
    Show System Specs
    No clue why it reach timeout :
    BASS_ERROR_TIMEOUT : The server did not respond to the request within the timeout period, as set with the BASS_CONFIG_NET_TIMEOUT config option.
    The default timeout is 5 seconds (5000 milliseconds).

    So it seems to take more than 5 sec to init the stream.
     
    • Agree Agree x 1
  9. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,295
    Likes Received:
    6,247
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,268 / 9
    Home Country:
    France France
    Show System Specs
    • Agree Agree x 1
  10. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Maybe try to debug with Wireshark?
    Do you have any "fancy" network configuration for the client PC? ...proxy, VPN, non-standard DNS...?
     
    • Like Like x 1
  11. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,295
    Likes Received:
    6,247
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,268 / 9
    Home Country:
    France France
    Show System Specs
    This is what you should expect :
    upload_2015-2-21_20-41-54.png
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!