[fixed] - Random slideshow in pictures can repeat some pictures and miss others [Mantis #4472]

Discussion in '1.4.0 Pre-Release' started by Sebastiii, June 3, 2013.

  1. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,184 / 9
    Home Country:
    France France
    Show System Specs
    Instead of shuffling all pictures of a slideshow 1.4 Pre Release selects a picture at random when the next picture is to be selected. This results in pictures being repeated and others to be omitted.

    Correct behaviour is to shuffle all available pictures and to show them in this new random order without omissions or duplicates (either shuffle the list or shuffle a list of numbers and select from that, shuffling for recursive should probably be per folder as loading all folders will probably take too long).

    When running a random slideshow the picture selected after exiting (ESC or back) the slideshow MP will select the picture at the position equal to the number of pictures shown instead of the last shown picture/film.



    EDIT : 2013.06.06-2 Updated current link to full installer : -->> HERE <<--

    We need regression test for potential issue :

    • Recursive/not recursive slideshow
    • With option random (on/off)
    • With repeat (on/off)
    • With/without music playing
    • With/without folder.m3u (inside folder)
    • With/without playing video in slideshow.
    • Doing F7/F8 (to skip video/picture)
    • See what happen when folder reach the end.
    • Doing ESC and see if it's the correct latest item played etc.
    Thanks :)
     
    Last edited: June 7, 2013
    • Like Like x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mbuzina
    • Team MediaPortal

    mbuzina Retired Team Member

    Joined:
    April 11, 2005
    Messages:
    2,839
    Likes Received:
    627
    Location:
    Germany
    Ratings:
    +723 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Hi Seb, back again.

    As I stated in PM, Random works great. But ESCing out of SlideShow and/or Fullscreen does not return me to the currently selected picture. Steps:
    1. 14-33-34.png
    2. 14-33-42.png
    3. 14-33-45.png

    P.S.: Strange not only opening a picture shows the hidden menu, also pressing F11 for Screenshot opens the hidden menu. Strange bug
     
  4. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,184 / 9
    Home Country:
    France France
    Show System Specs
    Hi :)

    That really strange, it works for me, i will try on Titan this evening but i not why it failed.

    Thanks :)

    Ps : You are in Share view right ?
     
  5. mbuzina
    • Team MediaPortal

    mbuzina Retired Team Member

    Joined:
    April 11, 2005
    Messages:
    2,839
    Likes Received:
    627
    Location:
    Germany
    Ratings:
    +723 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Yes in Share view - tried Default & Titan - both the same. Also tried the 1.4 Pre-Release + current patches planned for 1.4 from the Team forums.
     
  6. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,184 / 9
    Home Country:
    France France
    Show System Specs
    Can you send me your mediaportal.xml ?
    It's surely due to how folder are setup like it works here :)
    Thanks.
     
  7. mbuzina
    • Team MediaPortal

    mbuzina Retired Team Member

    Joined:
    April 11, 2005
    Messages:
    2,839
    Likes Received:
    627
    Location:
    Germany
    Ratings:
    +723 / 4
    Home Country:
    Germany Germany
    Show System Specs
    I used default folder settings. I did not change anything after clean install. Right now not at my notebook. Jus uninstall mp completely (remove all settings) & test
     
    • Like Like x 1
  8. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,184 / 9
    Home Country:
    France France
    Show System Specs
    Why it's working for me !!!
    Can you try show/enable extension setting ?

    There is surely some setting that change the wheel :)
     
  9. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,184 / 9
    Home Country:
    France France
    Show System Specs
    Hi, it seems related to titan (skin bug ?) (@ncoH maybe has an idea)
     
    Last edited: June 4, 2013
  10. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,184 / 9
    Home Country:
    France France
    Show System Specs
    Updated first post with new installer :)
    It was related to hide extension of files, it should be ok now :)
     
    • Like Like x 1
  11. mbuzina
    • Team MediaPortal

    mbuzina Retired Team Member

    Joined:
    April 11, 2005
    Messages:
    2,839
    Likes Received:
    627
    Location:
    Germany
    Ratings:
    +723 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Since it also happened using Default Wide it is probably not skin related (still might have the same bug in both).
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!