SAF v4.00 ''stable'' (StandAlone Filters) - DXVA ready (H.264 and VC-1). | Page 249

Discussion in 'Codecs, External Players' started by hoborg, September 2, 2008.

?

Should i integrate FFDshow in to SAF?

  1. Yes

    406 vote(s)
    85.5%
  2. No

    69 vote(s)
    14.5%
  1. mediortal

    mediortal Portal Member

    Joined:
    July 28, 2009
    Messages:
    46
    Likes Received:
    1
    Ratings:
    +1 / 0
    yes, I'm not saying its not an MP bug, so I've accepted that, and is why I'm using cyberlink h264 with DXVA, no other choice really, other than using MPChc decoder with dvxa off, which I don't want.


    Now to the mkv video error.
    I'm now more confused than ever.

    I have the 2 previous files I posted info about earlier.



    works.mkv
    error.mkv

    I used mkvmerge as you suggested to split the last 10secs of each file to upload.

    It splitted
    works.mkv int works01(1.14GB) and works02(5MB)
    error.mkv into error01(1.14GB) and error02(3MB)


    now the weird part, I quickly tested the end splits in Mportal, and the error.mkv end split plays, but the works.mkv end split errors! (the first parts of each are unchanged). :mad:

    Anyway I will upload the splits anyway...(sorry about the scene, it the only one that worked :p)


    :D
     

    Attached Files:

    • 1.rar
      File size:
      30.6 KB
      Uploaded:
      August 27, 2009
      Views:
      30
    • 2.rar
      File size:
      30.6 KB
      Uploaded:
      August 27, 2009
      Views:
      33
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. hoborg

    hoborg Portal Pro

    Joined:
    June 13, 2008
    Messages:
    4,413
    Likes Received:
    1,593
    Location:
    Nový Jičín
    Ratings:
    +1,621 / 2
    Home Country:
    Czech Republic Czech Republic
    Show System Specs
    Hmm, both samples playing fine here, but i have no DXVA hardware here.
    Try to remux whole video.

    Here is next SAF 4.00beta06

    Change LOG

    I recreate autodownloader, so it should work everywhere - hope so.
     
    • Like Like x 2
  4. csapollo

    csapollo Portal Pro

    Joined:
    May 17, 2007
    Messages:
    217
    Likes Received:
    13
    Occupation:
    Telecommuncations Engineer
    Location:
    Sydney, Australia
    Ratings:
    +13 / 0
    Home Country:
    I just moved from SAF3.49B24 to SAF4.00B6 - for videos I have MPC Video Decoder selected, how does it know to use FFDShow for Xvid content?
     
  5. hoborg

    hoborg Portal Pro

    Joined:
    June 13, 2008
    Messages:
    4,413
    Likes Received:
    1,593
    Location:
    Nový Jičín
    Ratings:
    +1,621 / 2
    Home Country:
    Czech Republic Czech Republic
    Show System Specs
    There is no need for that :)
     
  6. csapollo

    csapollo Portal Pro

    Joined:
    May 17, 2007
    Messages:
    217
    Likes Received:
    13
    Occupation:
    Telecommuncations Engineer
    Location:
    Sydney, Australia
    Ratings:
    +13 / 0
    Home Country:
    I see. My configuration seems to carry across so I wanted to make sure the FFDShow Xvid settings install properly =)

    [​IMG]
     
  7. Gup

    Gup Portal Pro

    Joined:
    May 29, 2007
    Messages:
    87
    Likes Received:
    13
    Ratings:
    +13 / 0
    Home Country:
    Netherlands Netherlands
    Hoborg,

    I don't know if its a bug from MPADecFilter or from SAF.

    IF i play a .mov file it doesnt output 5.1 over SPDIF. mkv-files are oke they output in 5.1
    Info from the mov file (avatar trailer HD1080):

    ideo
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Main@L4.0
    Format settings, CABAC : No
    Format settings, ReFrames : 2 frames
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 2mn 9s
    Bit rate mode : Variable
    Bit rate : 10.3 Mbps
    Width : 1 920 pixels
    Height : 800 pixels
    Display aspect ratio : 2.400
    Frame rate mode : Constant
    Frame rate : 23.976 fps
    Resolution : 24 bits
    Colorimetry : 4:2:0
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.280
    Stream size : 159 MiB (96%)
    Encoded date : UTC 2009-08-18 16:44:12
    Tagged date : UTC 2009-08-20 13:39:59

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format version : Version 4
    Format profile : LC
    Format settings, SBR : No
    Codec ID : 40
    Duration : 2mn 9s
    Bit rate mode : Constant
    Bit rate : 465 Kbps
    Nominal bit rate : 448 Kbps
    Channel(s) : 6 channels
    Channel positions : Front: L C R, Rear: L R, LFE
    Sampling rate : 48.0 KHz
    Resolution : 16 bits
    Stream size : 7.15 MiB (4%)
    Encoded date : UTC 2009-08-18 16:44:12
    Tagged date : UTC 2009-08-20 13:39:59

    Menu
    ID : 3
    Format : TimeCode
    Encoded_Date : UTC 2009-08-18 16:44:12
    Tagged_Date : UTC 2009-08-20 13:39:59


    ----------------------------------

    In graphstudio its always linked to MPA Decoder filter (other decoder settings in MP don't change a thing).

    Any idea?
     
  8. hoborg

    hoborg Portal Pro

    Joined:
    June 13, 2008
    Messages:
    4,413
    Likes Received:
    1,593
    Location:
    Nový Jičín
    Ratings:
    +1,621 / 2
    Home Country:
    Czech Republic Czech Republic
    Show System Specs
    And if you play your video in MPC-HC player, outpout is correct?
     
  9. Gup

    Gup Portal Pro

    Joined:
    May 29, 2007
    Messages:
    87
    Likes Received:
    13
    Ratings:
    +13 / 0
    Home Country:
    Netherlands Netherlands
    No, Same result.

    I tried the monogram decoder : same result.
    I tried the ffdshow decoder : same result but after enabling an option called "AC3 (S/PDIF encode mode)" in output panel of ffdshow i get 5.1 ...........

    The problem still stays as i can't set the prefered audio decoder to use in MP. Is it fixed set to MPA Decoder filter if the mov files get split?
     
  10. bart0190

    bart0190 Portal Pro

    Joined:
    January 17, 2009
    Messages:
    153
    Likes Received:
    1
    Ratings:
    +1 / 0
    Hi,
    I just updated from SAF 3.47 (with ccc 8.5) to SAF 4.0 beta2 (with ccc 9.5) and finally very happy as DVXA does work now with PVD9-codec. (Before I allways got bluescreen after a while with watchdog.sys oder ati2dvag).

    I have a
    Gigabyte Motherboard with
    ATI onboard Graphic HD 3200.
    MP1.0.2

    However, now AC3 sound (Dolby Digital via SPDIF) does not work anymore. Of course I did the resettings in MP configuration as after SAF installation the audio is always set to stereo.
    In PDVD Codec: SPDIF output selected
    In MPC-MPA decoder settings: AC3 and DTS set to SPDIF (2x) (of course no downmix to stereo); PCM 16 bit.

    But now if I change to AC3 while watching a movie the video starts to stutter with no sound. - Stereo works without problems. With SAF 3.47 DTS/AC3 did work.

    Please give me a hint what I might try to overcome this problem.

    Thanks
    Bart
     
  11. hoborg

    hoborg Portal Pro

    Joined:
    June 13, 2008
    Messages:
    4,413
    Likes Received:
    1,593
    Location:
    Nový Jičín
    Ratings:
    +1,621 / 2
    Home Country:
    Czech Republic Czech Republic
    Show System Specs
    Try to update to latest SAF beta, there was some changes in MPA decoder.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!