SAF v4.00 ''stable'' (StandAlone Filters) - DXVA ready (H.264 and VC-1). (4 Viewers)

Should i integrate FFDshow in to SAF?

  • Yes

    Votes: 406 85.5%
  • No

    Votes: 69 14.5%

  • Total voters
    475

hoborg

Portal Pro
June 13, 2008
4,413
1,644
Nový Jičín
Czech Republic Czech Republic
I notice you have the same 780G w. onboard ATI HD3200
what h264 codec are you using for live TV?
Sorry, i dont have TV card working & in place where i live, we have only old analog TV signal - no HD broadcast... :(
 

kiwijunglist

Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,750
    New Zealand
    New Zealand New Zealand
    Country flag
    .ts file recorded by MP RC2 from DVB-T Freeview HD New Zealand 1080i

    MEGAUPLOAD - The leading online storage and file delivery service

    Size = 10mb

    Also : are you sure that MP is using the MPC stand alone filter, if i just register the filter on its own, then remove all other h264 codecs i cant play h264 files anymore. I think when you set MP to MPC codec, it actually ends up using one of the other codecs.
     

    hoborg

    Portal Pro
    June 13, 2008
    4,413
    1,644
    Nový Jičín
    Czech Republic Czech Republic
    .ts file recorded by MP RC2 from DVB-T Freeview HD New Zealand 1080i

    MEGAUPLOAD - The leading online storage and file delivery service

    Size = 10mb

    Also : are you sure that MP is using the MPC stand alone filter, if i just register the filter on its own, then remove all other h264 codecs i cant play h264 files anymore. I think when you set MP to MPC codec, it actually ends up using one of the other codecs.
    Thanks, i will try it.

    Yes, i am sure about it, i dont have any other h264 codecs installed.
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,750
    New Zealand
    New Zealand New Zealand
    Country flag
    thanks...

    but you have pdvd8 codec installed as per your original post, so how do you know it is using MPC filter and not PDVD8 filter?
     

    Ruud

    MP Donator
  • Premium Supporter
  • December 5, 2004
    276
    6
    Netherlands Netherlands
    how would one change the settings to optimise for 1920x1080 - 60Hz ?
    I update my package, now you can choose TV type - HD/Full HD.

    Hi Hoborg,
    just tried your setup and it works. Just one question: when selecting in MP the Cyberlink decoder I hear sound but get a gray screen?
    I do not think it is related to your program (have seen this when trying to install newer version of e.g. windvd (version 8). But just could not resist asking it in this thread ;). Running an a nvidia 8500 video card
    k.r.
    Ruud.
    Sorry, i have no personal experience with nVidia cards.
    You got "gray screen" only when playing HD video ? Or XVid/DivX too?

    It is working when you choose MPC Video decoder?
    Hi Hoborg,
    only when playing recorded .TS format (mpeg2) or watching TV (is the same format). When using xvid/divx MP defaults back to ffdshow.
    MPC Video decoder is not choosable, this is only in the list of H.264 decoders?
    thanks again,
    Ruud.
     

    hoborg

    Portal Pro
    June 13, 2008
    4,413
    1,644
    Nový Jičín
    Czech Republic Czech Republic
    thanks...

    but you have pdvd8 codec installed as per your original post, so how do you know it is using MPC filter and not PDVD8 filter?
    If you want to know vhat filters are in use - run MP in Window mode, start some video with subtitles.
    You will see DirectVobSub icon down - right click and you will see something like this:
    inusefilters.png

    Thats is list of in use filters.
     

    hoborg

    Portal Pro
    June 13, 2008
    4,413
    1,644
    Nový Jičín
    Czech Republic Czech Republic
    how would one change the settings to optimise for 1920x1080 - 60Hz ?
    I update my package, now you can choose TV type - HD/Full HD.

    Hi Hoborg,
    just tried your setup and it works. Just one question: when selecting in MP the Cyberlink decoder I hear sound but get a gray screen?
    I do not think it is related to your program (have seen this when trying to install newer version of e.g. windvd (version 8). But just could not resist asking it in this thread ;). Running an a nvidia 8500 video card
    k.r.
    Ruud.
    Sorry, i have no personal experience with nVidia cards.
    You got "gray screen" only when playing HD video ? Or XVid/DivX too?

    It is working when you choose MPC Video decoder?
    Hi Hoborg,
    only when playing recorded .TS format (mpeg2) or watching TV (is the same format). When using xvid/divx MP defaults back to ffdshow.
    MPC Video decoder is not choosable, this is only in the list of H.264 decoders?
    thanks again,
    Ruud.
    I think the best way is to disable these formats directly in FFDshow.

    .ts file recorded by MP RC2 from DVB-T Freeview HD New Zealand 1080i

    MEGAUPLOAD - The leading online storage and file delivery service

    Size = 10mb

    Also : are you sure that MP is using the MPC stand alone filter, if i just register the filter on its own, then remove all other h264 codecs i cant play h264 files anymore. I think when you set MP to MPC codec, it actually ends up using one of the other codecs.
    Thanks, i will try it.

    Yes, i am sure about it, i dont have any other h264 codecs installed.
    Well i did some testing and i found that:

    MP have its own ts reader - "TsReader.ax", so Haali have no efect on it.
    In log file, i have this error "2008-09-16 14:23:49.812500 [ERROR][MPMain]: TSReaderPlayer:GetInterfaces() failed"
    So, maybe this is some MP isue/bug, try to report this to MP team.

    MPC HC handle your file without any problem.

    ***UPDATE***

    Rename *ts to *mp4 or *mkv - this will disable MP internal "TsReader.ax" and make Haali to handle your video. Now it works! So this must be an MP issue!
     

    eXDee

    Portal Pro
    February 20, 2008
    120
    1
    New Zealand New Zealand
    Country flag
    You claim that the MPC video decoder does DXVA and is working perfect in MP. I tried registering this codec myself and selected it, but MP falls back onto PDVD8.
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    You claim that the MPC video decoder does DXVA and is working perfect in MP. I tried registering this codec myself and selected it, but MP falls back onto PDVD8.
    Codec selection has never been 100% in MP's config and often falls back on highest merit windows system default, which in your case is PDVD, I did my testing with PDVD uninstalled.
     

    Users who are viewing this thread

    Top Bottom