[SOLVED] Radio issue in MediaPortal 1.20 Pre-Release (2 Viewers)

dturner_69

Portal Member
April 25, 2016
16
16
66
United Kingdom United Kingdom
Has anyone reported an issue with the 1.20, where on occasions after listening to a radio station, then trying to switch to a TV station, the guide comes up, but the Tv does not come on, it does absolutely nothing when you select a channel. The only way I have found of getting over this is to restart MediaPortal. The TV then works perfectly. This has only started since the 1.20 Pre Release was installed.
 

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    1,630
    1,229
    Germany Germany
    Country flag
    Has anyone reported an issue with the 1.20, where on occasions after listening to a radio station, then trying to switch to a TV station, the guide comes up, but the Tv does not come on, it does absolutely nothing when you select a channel. The only way I have found of getting over this is to restart MediaPortal. The TV then works perfectly. This has only started since the 1.20 Pre Release was installed.
    I'm also on 1.20 pre, as far as I can see there is so far nowhere to report bugs (there was for 1.19). I agree there seems to be something wrong with radio, I'm using TuneIn for internet radio and it plays OK but it does not respond to stop, although music, TV and everything else does, if I exit TuneIn (with music still playing and try TV, radio stops but TV does not work. Are you using the TuneIn plugin, it also works without problem for me on 1.19.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    1,977
    1,225
    Southampton
    United Kingdom United Kingdom
    Country flag
    listening to a radio station, then trying to switch to a TV station, the guide comes up, but the Tv does not come on, it does absolutely nothing when you select a channel.
    I can confirm this. Using "DefaultWideHD" plus a keyboard:

    (1) Navigate to the "Root" menu and then "Radio".
    (2) Press ENTER key to start a radio station playing.
    (3) Press B key to stop radio playing. Nothing happens.
    (4) Press ALT_F4 to exit MP. The exit pop-up appears.
    (5) Press ENTER key on first choice ("Exit MP"). Nothing happens.
    (6) Start "Task Manager" and kill the MP process.

    Note that TV seems to work correctly -- live TV can be stopped by using the B key on the keyboard. Logs attached.

    -- from CyberSimian in the UK
     

    Attachments

    dturner_69

    Portal Member
    April 25, 2016
    16
    16
    66
    United Kingdom United Kingdom
    I am not using the Tunein plugin, just Freeview radio via my DVBT tuner cards. When the problem occurs, going to the TV Tuner section, shows the TV turned on, but nothing in the preview window on the right. Whatever is happening, it seems to be disabling something in the TV tuner. I wonder if it is related to the new version of the TV Tuner Service. It is annoying, as the only way around it is to go to the Root Menu, and restart MediaPortal from there. for your info, I am using the Purevision HD skin.
     

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    I can confirm this. Using "DefaultWideHD" plus a keyboard:

    (1) Navigate to the "Root" menu and then "Radio".
    (2) Press ENTER key to start a radio station playing.
    (3) Press B key to stop radio playing. Nothing happens.
    (4) Press ALT_F4 to exit MP. The exit pop-up appears.
    (5) Press ENTER key on first choice ("Exit MP"). Nothing happens.
    (6) Start "Task Manager" and kill the MP process.

    Note that TV seems to work correctly -- live TV can be stopped by using the B key on the keyboard. Logs attached.

    -- from CyberSimian in the UK
    Try this.
     

    Attachments

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,630
    1,229
    Germany Germany
    Country flag
    Try this.
    No help for me, I'm still not able to stop the radio playing using the stop button on the remote. I am using the TuneIn plugin for radio if I play a radio station then hit stop it continues to play and if I attempt to then go to TV it shows the mini-menu (should play fullscreen) but no picture and radio continues to play. I did find that pressing the pause button on the remote works and if I then hit play radio stops and TV will play as normal. Logs with new TV .dll attached. Given I'm using the TuneIn plugin for radio I will be interested in how this goes for @CyberSimian
     

    Attachments

    dturner_69

    Portal Member
    April 25, 2016
    16
    16
    66
    United Kingdom United Kingdom
    Tried the new DLL, but it didn't work for me either. The only difference was that the radio now stops when you select a channel from the TV guide, but the TV still fails to start.
     

    dturner_69

    Portal Member
    April 25, 2016
    16
    16
    66
    United Kingdom United Kingdom
    This is one issue that is very easy to replicate. Simply start Mediaportal, then fire up the radio, then try switching to a TV channel, which won't work. If you go straight to TV from startup and then switch over to radio, that works fine, but then if you try to switch back to TV, you have to restart Mediaportal to get the TV to work again.
     

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    This is one issue that is very easy to replicate. Simply start Mediaportal, then fire up the radio, then try switching to a TV channel, which won't work. If you go straight to TV from startup and then switch over to radio, that works fine, but then if you try to switch back to TV, you have to restart Mediaportal to get the TV to work again.
    Logs please.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    OP Similar threads Forum Replies Date
    cladinshadows85 timeshift error <solved> General 2
    F [Solved] Movies View with Thumbnail Layou General Support 4
    squidina [solved] - MediaPortal 1.22 won't start even with new install General Support 4
    J [solved] Lag on client-only PCs General 0
    joecrow [solved] (Solved) Win 10 1809 Woes General Support 4
    L [solved] MovPicNFO mit NAS? Video & DVD 1
    joecrow (Solved) EPG wrong General Support 18
    TheBatfink [solved] Homescreen tile labels are offset Titanius 3
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 3
    Ralph Holmes Problem accessing radio channels General 4
    P Freesat EPG, no Freesat Info radio channel? Electronic Program Guide 3
    K How to turn off "All channels" groupe in Radio? MediaPortal 1 Talk 3
    N [Finished] [MP2-806] Playing a recorded radio program does not show screen to allow skipping forward, etc MediaPortal 2 141
    Rob Hexenmeister Radio Guide descriptions in myradio.xml (screen 30) MediaPortal 1 Skins 3
    N [Finished] [MP2-791] Radio recordings do not get imported into Recordings listing MediaPortal 2 25
    N [fixed] Where do I find radio programmes I have recorded MediaPortal 2 1
    cbr954rr [MP2-795] Where is the radio? General 4
    P [solved] Analog FM Radio stutter General 11
    N [Rejected] Include BBC Sounds (radio catch up) in the Online Videos plugin Feature Requests 4
    N Include both TV and Radio channels together in the guide Feature Requests 2
    N How to switch between TV and radio MediaPortal 2 15
    T Web/ Internet Radio Radio 24
    Frans Nijhuis Tv/Radio channel Import Export xml and multiple identical channel names Newcomers Forum 0
    CyberSimian [Action Required] Rework TV/Radio recordings screen MediaPortal 1 23
    R MP2 GUI Issues General 7
    Similar threads

























    Top Bottom