[no Bug] - Subtitle Issues (.m2ts .mkv) MPC Splitter Matroska and Mpeg. | Page 6

Discussion in 'MediaPortal 1.1.0 RC 1 & 2' started by Sebastiii, February 21, 2010.

  1. rivera
    • Team MediaPortal

    rivera Retired Team Member

    Joined:
    December 1, 2008
    Messages:
    237
    Likes Received:
    21
    Ratings:
    +21 / 0
    Home Country:
    Russian Federation Russian Federation
    I am almost sure that it happens ALWAYS - whenever and whatever separate m2ts-file (means "not in BDMV/STREAM folder") is opened in MPC-HC, it will be opened with some bugs (I told about these bugs above). But I did not analize why some bugs are occurred (for example, invalid languages for audio tracks) and why other bugs are not (for example, availability of subs).
    Let's imagine how it works in MPC-HC:
    a) m2ts container is opened by splitter (assume, Gabest),
    b) then video & decoders are dispatched to appropriate decoders,
    so far we can expect in Portal the same behaviour if we register in Portal same filters (means "select same decoders in Configuration" + "register Gabest splitter for m2ts in Registry").
    c) subtitle streams are also dispatched to the appropriate decoder.
    In Configuration we can select "MPC-HC subtitles engine" - so I think that this engine (which supposed to be the same as in MPC-HC) is incorporated inproperly !!!!!



    May be we should go to the corresponding thread on the forum (dedicated to "MPC-HC subtitles engine" integration) and ask people about the discussed problem?
    https://forum.team-mediaportal.com/...48/integration-mpc-hc-subtitles-engine-54130/
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. cpp2005
    • Team MediaPortal

    cpp2005 Retired Team Member

    Joined:
    November 7, 2006
    Messages:
    164
    Likes Received:
    127
    Ratings:
    +127 / 0
    Hi rivera,
    I didn't understand the problem,
    can you prepare sample that works in MPC-HC, but not in mediaportal?
     
    • Like Like x 1
  4. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,239
    Likes Received:
    6,202
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,201 / 9
    Home Country:
    France France
    Show System Specs
    Hi cpp2005 :)

    I'm happy to see you here :)
    I think but not sure this is the description on this thread :

    integration-mpc-hc-subtitles-engine-54130

    But i think it's related to the selection of sub in MP part but i must be wrong.

    To resume we must know if it's a splitter issue for .m2ts MPG MPEG Splitter (must be select OFF (twice) and select the right subs for make it work when splitter detect sub in it) and maybe on .mkv when sub is initially toggled ON.

    I'm pretty sure for .m2ts it's a splitter issue (like we now on some sample no subs is detected but in media info is here).
    For Matroska splitter, also have missing EDITION support for example.

    But with this splitter we can use HD Audio Bitstreaming :)

    Cheers,
    Seb.
     
  5. rivera
    • Team MediaPortal

    rivera Retired Team Member

    Joined:
    December 1, 2008
    Messages:
    237
    Likes Received:
    21
    Ratings:
    +21 / 0
    Home Country:
    Russian Federation Russian Federation
    Sample from "Troy" movie:
    RapidShare: 1-CLICK Web hosting - Easy Filehosting
    It has 3 subs.
    Also I attached logs from MP.

    BTW, the sample can be deleted soon from the rapidshare:
     
    • Like Like x 1
  6. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,239
    Likes Received:
    6,202
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,201 / 9
    Home Country:
    France France
    Show System Specs
    Hi Rivera :)

    I have put the sample too on :
    test3.rar

    On my side i can see all subs in MP (but Autoload is in OFF) and switch Audio.

    Cheers,
    Seb.
     
  7. rivera
    • Team MediaPortal

    rivera Retired Team Member

    Joined:
    December 1, 2008
    Messages:
    237
    Likes Received:
    21
    Ratings:
    +21 / 0
    Home Country:
    Russian Federation Russian Federation
    Hi Seb!
    With audio no problem at all.
    I got a problem with subs mentioned above:
    So, subs can be shown only ONCE.
    I am using MpegSplitter.ax registered manually in "Media Types" Registry section.
     
  8. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,239
    Likes Received:
    6,202
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,201 / 9
    Home Country:
    France France
    Show System Specs
    Hi,

    I go to test it :)
    Cheers,
    Seb.

    Edit : effectively, i have the same issue, when i try with MPC-HC it seems to work even if subtitle take a little time to appear (splitter side).
     
  9. cpp2005
    • Team MediaPortal

    cpp2005 Retired Team Member

    Joined:
    November 7, 2006
    Messages:
    164
    Likes Received:
    127
    Ratings:
    +127 / 0
    OK thanks I'll check it.
     
    • Like Like x 1
  10. cpp2005
    • Team MediaPortal

    cpp2005 Retired Team Member

    Joined:
    November 7, 2006
    Messages:
    164
    Likes Received:
    127
    Ratings:
    +127 / 0
    Please try the attached version, I'll update the MPC splitter support thread if this version is working OK.
     

    Attached Files:

    • mpcSubs.zip
      File size:
      30.6 KB
      Uploaded:
      April 10, 2010
      Views:
      98
    • Like Like x 1
  11. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,239
    Likes Received:
    6,202
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,201 / 9
    Home Country:
    France France
    Show System Specs
    Hi cpp2005,

    I have made some test and i think it's maybe better, on Troie Sample, i can go to sub and OFF and go again on sub and it appear.
    But i rewind 5 second at each time to MPC Splitter MPEG try to find sub( i'm sure that we has an issue with it) but in general it's works better.

    Can you post patch also :) ?

    Another thing that i have see is with MPC-SUB (but this issue is for MPC team), i have a sample that the subs (double subs) appear to quickly.

    Why i said that it's because with last ffdshow with PGS subtitle, i think the delay is correct, Albain has work with Pel (supread creator), i don't know if it's possible to fix it in MPC-SUB too.

    The Sample : Sample_SUB_OK.m2ts

    Cheers,
    Seb.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!