Swedish sites: SVT, TV4, Dplay Premium, UR, Viasat channels + Movie & Series sites (2 Viewers)

Ministerk

Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    @CountZer0 I don't know if anyone else have your problem, but verify that you use LAV codec. If you do and use intel graphics, try to disable quicksync if enabled.
     

    Luciferpower7264

    Portal Member
    June 8, 2017
    15
    4
    Sweden Sweden
    TV4 play has apparently created a new code thats not possible
    to open in online videos anymore. :(

    Incorrect message occurs:
    "Error retrieving dynamic categories"

    What to do about this? :love:
     

    ravenrocks

    Portal Pro
    October 11, 2007
    351
    96
    Country flag
    Unfortunately, since MinisterK stopped supporting the swedish sites(family do come first after all), no one is updating them anymore, so we just have to wait until someone take it upon themselves to do it. I have no programming skills, so I have the same predicament as you have.
     

    Luciferpower7264

    Portal Member
    June 8, 2017
    15
    4
    Sweden Sweden
    Of course, the family always comes first! :)

    Thank you for your quick response ravenrocks.(y)
    Then we hold our thumbs that someone else can take it over soon.:D
    Have a great day!
     

    snz

    Portal Member
    October 28, 2015
    17
    21
    Sweden Sweden
    Edit: you need to unzip it as well, it should replace the existing dll file
    Edit2: Or did you mean the .patch file? It needs to be applied to the source tree and then you need to rebuild onlinevideos. But you could just use the .dll I added now instead then.
    Edit3: I'll stop trying to write instructions in a hurry, fixed the path below..

    Put it in the
    C:\Program Files (x86)\Team MediaPortal\MediaPortal\plugins\Windows\OnlineVideos
    folder (this is where it is on my Windows 10 machine at least, it might some other path in other installations).

    Also, I think that if you press 'update' when launching onlinevideos in MP it will be overwritten..
     
    Last edited:

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    I've created a small patch to fix tv4play, attaching it here.

    Note that I know nothing about C#, but "It works for me (TM)"

    @offbyone are you the one to ask to merge this?

    Edit: I added the dll also if someone would like to test it
    Nice work! I can apply the patch and publish the site, I'll do it this evening.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    Top Bottom